summaryrefslogtreecommitdiffstats
path: root/testsuites/psxtests/Makefile.am
diff options
context:
space:
mode:
authorJoel Sherrill <joel@rtems.org>2019-05-07 15:01:03 -0500
committerJoel Sherrill <joel@rtems.org>2019-05-07 15:01:03 -0500
commit6d3e3934cdfbd2ec0142e6e0e612bc1abd031187 (patch)
treef592409ff09bb1db7120e7e284127ac9a6f68219 /testsuites/psxtests/Makefile.am
parentpsxhdrs: Add POSIX API Signature Compliance Tests for termios.h (diff)
downloadrtems-6d3e3934cdfbd2ec0142e6e0e612bc1abd031187.tar.bz2
Makefile.am: Add psxhdrs/termios files to build
Diffstat (limited to '')
-rwxr-xr-xtestsuites/psxtests/Makefile.am24
1 files changed, 12 insertions, 12 deletions
diff --git a/testsuites/psxtests/Makefile.am b/testsuites/psxtests/Makefile.am
index e7be09a0e9..1e354c0df7 100755
--- a/testsuites/psxtests/Makefile.am
+++ b/testsuites/psxtests/Makefile.am
@@ -1826,23 +1826,23 @@ lib_a_SOURCES = psxhdrs/devctl/posix_devctl.c \
psxhdrs/sys/select/FD_SET.c \
psxhdrs/sys/select/FD_ZERO.c \
psxhdrs/sys/select/pselect.c \
- psxhdrs/sys/select/select.c
+ psxhdrs/sys/select/select.c \
+ psxhdrs/termios/cfgetispeed.c \
+ psxhdrs/termios/cfgetospeed.c \
+ psxhdrs/termios/cfsetispeed.c \
+ psxhdrs/termios/cfsetospeed.c \
+ psxhdrs/termios/tcdrain.c \
+ psxhdrs/termios/tcflow.c \
+ psxhdrs/termios/tcflush.c \
+ psxhdrs/termios/tcgetattr.c \
+ psxhdrs/termios/tcgetsid.c \
+ psxhdrs/termios/tcsendbreak.c \
+ psxhdrs/termios/tcsetattr.c
## Not supported by RTEMS, but POSIX API Compliance tests exist.
## lib_a_SOURCES += psxhdrs/ulimit/ulimit.c
## lib_a_SOURCES += psxhdrs/monetary/strfmon.c
## lib_a_SOURCES += psxhdrs/monetary/strfmon_l.c
-## lib_a_SOURCES += psxhdrs/termios/cfgetispeed.c
-## lib_a_SOURCES += psxhdrs/termios/cfsetispeed.c
-## lib_a_SOURCES += psxhdrs/termios/tcdrain.c
-## lib_a_SOURCES += psxhdrs/termios/tcflush.c
-## lib_a_SOURCES += psxhdrs/termios/tcgetsid.c
-## lib_a_SOURCES += psxhdrs/termios/tcsetattr.c
-## lib_a_SOURCES += psxhdrs/termios/cfgetospeed.c
-## lib_a_SOURCES += psxhdrs/termios/cfsetospeed.c
-## lib_a_SOURCES += psxhdrs/termios/tcflow.c
-## lib_a_SOURCES += psxhdrs/termios/tcgetattr.c
-## lib_a_SOURCES += psxhdrs/termios/tcsendbreak.c
## Specific issues that tickets are tracking
## lib_a_SOURCES += psxhdrs/dirent/dirfd.c See ticket #3371