summaryrefslogtreecommitdiffstats
path: root/testsuites/psxtests/Makefile.am
diff options
context:
space:
mode:
authorJoel Sherrill <joel@rtems.org>2016-09-05 17:42:27 -0500
committerChris Johns <chrisj@rtems.org>2016-09-06 10:31:16 +1000
commit85910040d8bc7b2031656372042cf993caa90a86 (patch)
tree4bc105f890b1aea92509c19d10e1961fa24e2a8f /testsuites/psxtests/Makefile.am
parentAdd autotools generated files (diff)
downloadrtems-85910040d8bc7b2031656372042cf993caa90a86.tar.bz2
Backport capability to exclude tests from building
Backported build infrastructure and .tcfg files from master.
Diffstat (limited to 'testsuites/psxtests/Makefile.am')
-rw-r--r--testsuites/psxtests/Makefile.am10
1 files changed, 5 insertions, 5 deletions
diff --git a/testsuites/psxtests/Makefile.am b/testsuites/psxtests/Makefile.am
index b2bfb87c98..b0a68c58f5 100644
--- a/testsuites/psxtests/Makefile.am
+++ b/testsuites/psxtests/Makefile.am
@@ -4,9 +4,9 @@
ACLOCAL_AMFLAGS = -I ../aclocal
-SUBDIRS = psxclock
+_SUBDIRS = psxclock
if HAS_POSIX
-SUBDIRS += psxhdrs psx01 psx02 psx03 psx04 psx05 psx06 psx07 psx08 psx09 \
+_SUBDIRS += psxhdrs psx01 psx02 psx03 psx04 psx05 psx06 psx07 psx08 psx09 \
psx10 psx11 psx12 psx13 psx14 psx16 psxalarm01 \
psxautoinit01 psxautoinit02 psxbarrier01 \
psxcancel psxcancel01 psxcleanup psxcleanup01 \
@@ -19,18 +19,18 @@ SUBDIRS += psxhdrs psx01 psx02 psx03 psx04 psx05 psx06 psx07 psx08 psx09 \
endif
## File IO tests
-SUBDIRS += psxfile01 psxreaddir psxstat psxmount psx13 psxchroot01 \
+_SUBDIRS += psxfile01 psxreaddir psxstat psxmount psx13 psxchroot01 \
psxpasswd01
## Until sys/uio.h is moved to libcsupport, we have to have networking
## enabled to support readv and writev. Hopefully this is a temporary
## situation.
## if NEWLIB
-SUBDIRS += psxrdwrv
+_SUBDIRS += psxrdwrv
## endif
DIST_SUBDIRS = $(SUBDIRS) psxfatal_support
EXTRA_DIST = psxfatal_support/init.c psxfatal_support/system.h
-include $(top_srcdir)/../automake/subdirs.am
+include $(top_srcdir)/../automake/test-subdirs.am
include $(top_srcdir)/../automake/local.am