summaryrefslogtreecommitdiffstats
path: root/testsuites/mptests/mp08/node1/Makefile.am
diff options
context:
space:
mode:
authorRalf Corsepius <ralf.corsepius@rtems.org>2005-11-07 08:37:18 +0000
committerRalf Corsepius <ralf.corsepius@rtems.org>2005-11-07 08:37:18 +0000
commit91de254961a733dea87530a3fbe5ecaf690ec8b8 (patch)
treef653f651e6dc218ed1f71fb0947ba52a7016a6cc /testsuites/mptests/mp08/node1/Makefile.am
parent2005-11-07 Ralf Corsepius <ralf.corsepius@rtems.org> (diff)
downloadrtems-91de254961a733dea87530a3fbe5ecaf690ec8b8.tar.bz2
Partial conversion to automake.
Diffstat (limited to 'testsuites/mptests/mp08/node1/Makefile.am')
-rw-r--r--testsuites/mptests/mp08/node1/Makefile.am15
1 files changed, 5 insertions, 10 deletions
diff --git a/testsuites/mptests/mp08/node1/Makefile.am b/testsuites/mptests/mp08/node1/Makefile.am
index 5d824f1867..4a711bd407 100644
--- a/testsuites/mptests/mp08/node1/Makefile.am
+++ b/testsuites/mptests/mp08/node1/Makefile.am
@@ -8,24 +8,19 @@ PGM = ${ARCH}/$(TEST)-node$(NODE).exe
MANAGERS = io mp semaphore
-C_FILES = ../init.c ../task1.c
-C_O_FILES = $(C_FILES:../%.c=${ARCH}/%.$(OBJEXT))
-
-$(ARCH)/%.$(OBJEXT): ../%.c $(ARCH)/$(dirstamp)
- ${COMPILE} -o $@ -c $<
-
-H_FILES = system.h
+noinst_LIBRARIES = lib.a
+lib_a_SOURCES = ../init.c ../task1.c system.h
DOCTYPES = doc scn
DOCS = $(DOCTYPES:%=$(TEST).%)
-SRCS = $(DOCS) $(C_FILES) $(H_FILES)
-OBJS = $(C_O_FILES)
+SRCS = $(DOCS)
+OBJS = $(lib_a_OBJECTS)
PRINT_SRCS = $(DOCS)
include $(RTEMS_ROOT)/make/custom/@RTEMS_BSP@.cfg
-include $(top_srcdir)/../automake/compile.am
+include $(top_srcdir)/../automake/amcompile.am
include $(top_srcdir)/../automake/leaf.am
include $(top_srcdir)/mptests.am