summaryrefslogtreecommitdiffstats
path: root/testsuites/mptests/mp07/node2/Makefile.am
diff options
context:
space:
mode:
authorJoel Sherrill <joel.sherrill@OARcorp.com>1999-11-24 14:19:26 +0000
committerJoel Sherrill <joel.sherrill@OARcorp.com>1999-11-24 14:19:26 +0000
commitc4ea5efc613cad9bfb0c56c250a2f26b69249688 (patch)
tree49d29060773312f10c7c3989ac436fdf0973e8a8 /testsuites/mptests/mp07/node2/Makefile.am
parentAdded sem_timedwait to bullet list at front of chapter. (diff)
downloadrtems-c4ea5efc613cad9bfb0c56c250a2f26b69249688.tar.bz2
Patch rtems-rc-19991123-rc-0.diff from Ralf Corsepius <corsepiu@faw.uni-ulm.de>
which (among other things) converted the mptests to automake.
Diffstat (limited to 'testsuites/mptests/mp07/node2/Makefile.am')
-rw-r--r--testsuites/mptests/mp07/node2/Makefile.am58
1 files changed, 58 insertions, 0 deletions
diff --git a/testsuites/mptests/mp07/node2/Makefile.am b/testsuites/mptests/mp07/node2/Makefile.am
new file mode 100644
index 0000000000..f66111437c
--- /dev/null
+++ b/testsuites/mptests/mp07/node2/Makefile.am
@@ -0,0 +1,58 @@
+##
+## $Id$
+##
+
+AUTOMAKE_OPTIONS = foreign 1.4
+
+VPATH = @srcdir@:@srcdir@/..
+
+NODE = 2
+TEST = mp07
+PGM = ${ARCH}/$(TEST)-node$(NODE).exe
+
+MANAGERS = io mp event timer
+
+# C source names, if any, go here -- minus the .c
+C_FILES = init.c task1.c
+C_O_FILES = $(C_FILES:%.c=${ARCH}/%.o)
+
+H_FILES = system.h
+
+DOCTYPES = doc scn
+DOCS = $(DOCTYPES:%=$(TEST).%)
+
+SRCS = $(DOCS) $(C_FILES) $(H_FILES)
+OBJS = $(C_O_FILES)
+
+PRINT_SRCS = $(DOCS)
+
+include $(RTEMS_ROOT)/make/custom/@RTEMS_BSP@.cfg
+include $(RTEMS_ROOT)/make/leaf.cfg
+include $(top_srcdir)/mptests.am
+
+if HAS_MP
+
+#
+# (OPTIONAL) Add local stuff here using +=
+#
+
+AM_CPPFLAGS += -DNODE_NUMBER=$(NODE) -I$(srcdir)/..
+
+#
+# Add your list of files to delete here. The config files
+# already know how to delete some stuff, so you may want
+# to just run 'make clean' first to see what gets missed.
+# 'make clobber' already includes 'make clean'
+#
+
+${PGM}: $(OBJS) $(LINK_FILES)
+ $(make-exe)
+
+all-local: $(ARCH) $(TMPINSTALL_FILES)
+else
+all-local:
+endif
+
+EXTRA_DIST = $(DOCS)
+
+include $(top_srcdir)/../../../../automake/local.am