summaryrefslogtreecommitdiffstats
path: root/testsuites/mptests/mp07/node2/Makefile.am
diff options
context:
space:
mode:
authorRalf Corsepius <ralf.corsepius@rtems.org>2005-11-11 14:41:53 +0000
committerRalf Corsepius <ralf.corsepius@rtems.org>2005-11-11 14:41:53 +0000
commit564dcf4213507906c21e698cd89d510d73bc7f91 (patch)
treea8cf4399593efa54025374562e094d97c1bf7f84 /testsuites/mptests/mp07/node2/Makefile.am
parent * tm01/Makefile.am: Rework. (diff)
downloadrtems-564dcf4213507906c21e698cd89d510d73bc7f91.tar.bz2
Rework.
Diffstat (limited to 'testsuites/mptests/mp07/node2/Makefile.am')
-rw-r--r--testsuites/mptests/mp07/node2/Makefile.am42
1 files changed, 8 insertions, 34 deletions
diff --git a/testsuites/mptests/mp07/node2/Makefile.am b/testsuites/mptests/mp07/node2/Makefile.am
index 5198142adc..167f51a937 100644
--- a/testsuites/mptests/mp07/node2/Makefile.am
+++ b/testsuites/mptests/mp07/node2/Makefile.am
@@ -9,53 +9,27 @@ MANAGERS = io mp event timer
noinst_LIBRARIES = lib.a
lib_a_SOURCES = ../init.c ../task1.c ../system.h
-DOCS = mp07-node2.doc mp07-node2.scn
+testsdir = $(libdir)/tests
+scndir = $(testsdir)
+dist_scn_DATA = mp07-node2.scn
+docdir = $(testsdir)
+dist_doc_DATA = mp07-node2.doc
OBJS = $(lib_a_OBJECTS)
-
include $(RTEMS_ROOT)/make/custom/@RTEMS_BSP@.cfg
include $(top_srcdir)/../automake/compile.am
include $(top_srcdir)/../automake/leaf.am
-project_bspdir=$(PROJECT_ROOT)
-
-$(project_bspdir)/tests/$(dirstamp):
- @$(mkdir_p) $(project_bspdir)/tests
- @: > $(project_bspdir)/tests/$(dirstamp)
-
-$(project_bspdir)/tests/mp07-node2.exe: $(PGM) $(project_bspdir)/tests/$(dirstamp)
- $(INSTALL_PROGRAM) $< $@
-
-$(project_bspdir)/tests/screens/mptests/node2/$(dirstamp):
- @$(mkdir_p) $(project_bspdir)/tests/screens/mptests/node2
- @: > $(project_bspdir)/tests/screens/mptests/node2/$(dirstamp)
-
-$(project_bspdir)/tests/screens/mptests/node2/mp07-node2.scn: mp07-node2.scn $(project_bspdir)/tests/screens/mptests/node2/$(dirstamp)
- $(INSTALL_DATA) $< $@
-
-TMPINSTALL_FILES = $(project_bspdir)/tests/mp07-node2.exe
-TMPINSTALL_FILES += $(project_bspdir)/tests/screens/mptests/node2/mp07-node2.scn
-
$(PGM): ${ARCH}/$(dirstamp)
AM_CPPFLAGS += -DNODE_NUMBER=2 -I$(srcdir)/..
-if HAS_MP
-
-
AM_CPPFLAGS += -I$(top_srcdir)/../support/include
-${PGM}: $(OBJS) $(LINK_FILES)
- $(make-exe)
-
-all-local: $(TMPINSTALL_FILES)
-else
-all-local:
-endif
-
-EXTRA_DIST = $(DOCS)
+tests_SCRIPTS = $(PGM)
-CLEANFILES = $(TMPINSTALL_FILES)
+$(PGM): $(OBJS) $(LINK_FILES)
+ $(make-exe)
include $(top_srcdir)/../automake/local.am