summaryrefslogtreecommitdiffstats
path: root/testsuites/mptests/Makefile.am
diff options
context:
space:
mode:
authorSebastian Huber <sebastian.huber@embedded-brains.de>2019-11-06 16:23:28 +0100
committerSebastian Huber <sebastian.huber@embedded-brains.de>2019-11-12 09:36:20 +0100
commiteae263c609a3c62af8a0cd9aae240ed6394780aa (patch)
tree9c93506604fcbef910d1084fd5477c356bbf3f17 /testsuites/mptests/Makefile.am
parenttmtests: Avoid build system defined defines (diff)
downloadrtems-eae263c609a3c62af8a0cd9aae240ed6394780aa.tar.bz2
mptests/mp14: Make MAX_LONG_TEST_DURATION constant
If there is a real need, it can be made a configuration option again. Update #3818.
Diffstat (limited to 'testsuites/mptests/Makefile.am')
-rw-r--r--testsuites/mptests/Makefile.am4
1 files changed, 2 insertions, 2 deletions
diff --git a/testsuites/mptests/Makefile.am b/testsuites/mptests/Makefile.am
index 7111e2d109..6ddb2e80cc 100644
--- a/testsuites/mptests/Makefile.am
+++ b/testsuites/mptests/Makefile.am
@@ -231,7 +231,7 @@ mp14_node1_SOURCES = mp14/init.c mp14/exit.c mp14/delay.c \
mp14/evtask1.c mp14/evtmtask.c mp14/pttask1.c mp14/smtask1.c \
mp14/msgtask1.c mp14/system.h
mp14_node1_CPPFLAGS = -DNODE_NUMBER=1 $(AM_CPPFLAGS) $(TEST_FLAGS_mp14) \
- $(support_includes) -DMAX_LONG_TEST_DURATION=$(MAX_LONG_TEST_DURATION)
+ $(support_includes)
mp_tests += mp14_node2
mp_screens += mp14/mp14-node2.scn
mp_docs += mp14/mp14-node2.doc
@@ -239,7 +239,7 @@ mp14_node2_SOURCES = mp14/init.c mp14/exit.c mp14/delay.c \
mp14/evtask1.c mp14/evtmtask.c mp14/pttask1.c mp14/smtask1.c \
mp14/msgtask1.c mp14/system.h
mp14_node2_CPPFLAGS = -DNODE_NUMBER=2 $(AM_CPPFLAGS) $(TEST_FLAGS_mp14) \
- $(support_includes) -DMAX_LONG_TEST_DURATION=$(MAX_LONG_TEST_DURATION)
+ $(support_includes)
endif
endif