summaryrefslogtreecommitdiffstats
path: root/testsuites/libtests/termios08/Makefile.am
diff options
context:
space:
mode:
authorJoel Sherrill <joel.sherrill@OARcorp.com>2010-07-19 13:54:47 +0000
committerJoel Sherrill <joel.sherrill@OARcorp.com>2010-07-19 13:54:47 +0000
commit78da8ac3965fd42f11595f3d723386c46f2f0714 (patch)
tree1514fb31319d13a7013dcefffc9bd7e9d81dc261 /testsuites/libtests/termios08/Makefile.am
parent2010-07-19 Bharath Suri <bharath.s.jois@gmail.com> (diff)
downloadrtems-78da8ac3965fd42f11595f3d723386c46f2f0714.tar.bz2
2010-07-19 Joel Sherrill <joel.sherrill@oarcorp.com>
* Makefile.am, configure.ac, termios06/init.c: Add initial tests for XON/XOFF and VMIN/VMAX cases. * termios07/.cvsignore, termios07/Makefile.am, termios07/init.c, termios07/termios07.doc, termios07/termios07.scn, termios08/.cvsignore, termios08/Makefile.am, termios08/init.c, termios08/termios08.doc, termios08/termios08.scn: New files.
Diffstat (limited to 'testsuites/libtests/termios08/Makefile.am')
-rw-r--r--testsuites/libtests/termios08/Makefile.am27
1 files changed, 27 insertions, 0 deletions
diff --git a/testsuites/libtests/termios08/Makefile.am b/testsuites/libtests/termios08/Makefile.am
new file mode 100644
index 0000000000..322cd3fb1b
--- /dev/null
+++ b/testsuites/libtests/termios08/Makefile.am
@@ -0,0 +1,27 @@
+##
+## $Id$
+##
+
+MANAGERS = all
+
+rtems_tests_PROGRAMS = termios08
+termios08_SOURCES = init.c ../termios03/termios_testdriver_polled.c
+
+dist_rtems_tests_DATA = termios08.scn
+dist_rtems_tests_DATA += termios08.doc
+
+include $(RTEMS_ROOT)/make/custom/@RTEMS_BSP@.cfg
+include $(top_srcdir)/../automake/compile.am
+include $(top_srcdir)/../automake/leaf.am
+
+AM_CPPFLAGS += -I$(top_srcdir)/../support/include
+AM_CPPFLAGS += -I$(top_srcdir)/termios03
+
+LINK_OBJS = $(termios08_OBJECTS) $(termios08_LDADD)
+LINK_LIBS = $(termios08_LDLIBS)
+
+termios08$(EXEEXT): $(termios08_OBJECTS) $(termios08_DEPENDENCIES)
+ @rm -f termios08$(EXEEXT)
+ $(make-exe)
+
+include $(top_srcdir)/../automake/local.am