summaryrefslogtreecommitdiffstats
path: root/testsuites/libtests/termios/Makefile.am
diff options
context:
space:
mode:
authorRalf Corsepius <ralf.corsepius@rtems.org>2005-11-07 07:36:35 +0000
committerRalf Corsepius <ralf.corsepius@rtems.org>2005-11-07 07:36:35 +0000
commit0acb58f7643dd11836d4ce075570ea40c533d64c (patch)
treed22ab426ab1211ae6077a94485a5093c6423e011 /testsuites/libtests/termios/Makefile.am
parentAdd $(PGM): ${ARCH}/$(dirstamp). (diff)
downloadrtems-0acb58f7643dd11836d4ce075570ea40c533d64c.tar.bz2
Partial conversion to automake.
Diffstat (limited to '')
-rw-r--r--testsuites/libtests/termios/Makefile.am15
1 files changed, 6 insertions, 9 deletions
diff --git a/testsuites/libtests/termios/Makefile.am b/testsuites/libtests/termios/Makefile.am
index a7950f4e0b..6723b45ec7 100644
--- a/testsuites/libtests/termios/Makefile.am
+++ b/testsuites/libtests/termios/Makefile.am
@@ -6,24 +6,21 @@ TEST = termios
MANAGERS = io
-C_FILES = init.c
-C_O_FILES = $(C_FILES:%.c=${ARCH}/%.$(OBJEXT))
-
-H_FILES =
-noinst_HEADERS = $(H_FILES)
+noinst_LIBRARIES = lib.a
+lib_a_SOURCES = init.c
DOCTYPES =
DOCS = $(DOCTYPES:%=$(TEST).%)
-SRCS = $(DOCS) $(C_FILES) $(CC_FILES) $(H_FILES) $(S_FILES)
-OBJS = $(C_O_FILES) $(CC_O_FILES) $(S_O_FILES)
+SRCS = $(DOCS)
+OBJS = $(lib_a_OBJECTS)
PRINT_SRCS = $(DOCS)
PGM = ${ARCH}/$(TEST).exe
include $(RTEMS_ROOT)/make/custom/@RTEMS_BSP@.cfg
-include $(top_srcdir)/../automake/compile.am
+include $(top_srcdir)/../automake/amcompile.am
include $(top_srcdir)/../automake/leaf.am
include $(top_srcdir)/libtests.am
@@ -36,7 +33,7 @@ ${PGM}: $(OBJS) $(LINK_FILES)
all-local: $(TMPINSTALL_FILES)
-EXTRA_DIST = $(C_FILES) $(DOCS)
+EXTRA_DIST = $(DOCS)
CLEANFILES = $(TMPINSTALL_FILES)