summaryrefslogtreecommitdiffstats
path: root/testsuites/libtests/math/Makefile.am
diff options
context:
space:
mode:
authorRalf Corsépius <ralf.corsepius@rtems.org>2012-05-23 16:45:01 +0200
committerJoel Sherrill <joel.sherrill@oarcorp.com>2012-05-31 10:06:14 -0500
commit5e707bc75ebe7e481ec8a4920cab865d465c254a (patch)
treeb391a66749ac6e3c76078277fc54dbaddca59ab2 /testsuites/libtests/math/Makefile.am
parentRevert "libtests/complex: Avoid generated files" (diff)
downloadrtems-5e707bc75ebe7e481ec8a4920cab865d465c254a.tar.bz2
Revert "libtests/math*: Avoid generated files"
This reverts commit 6a5bd1c65c005457455db344f2ee831d7a5cf99b.
Diffstat (limited to '')
-rw-r--r--testsuites/libtests/math/Makefile.am8
1 files changed, 7 insertions, 1 deletions
diff --git a/testsuites/libtests/math/Makefile.am b/testsuites/libtests/math/Makefile.am
index 835bd931a5..5a8a010810 100644
--- a/testsuites/libtests/math/Makefile.am
+++ b/testsuites/libtests/math/Makefile.am
@@ -1,5 +1,12 @@
rtems_tests_PROGRAMS = math
math_SOURCES = init.c domath.c
+EXTRA_DIST = $(srcdir)/../math/domath.in
+
+$(srcdir)/domath.c: $(srcdir)/../math/domath.in
+ sed -e 's,[@]FTYPE[@],double,' \
+ -e 's,[@]FSUFFIX[@], ,g' \
+ -e 's,[@]FGUARD[@],NO_DOUBLE,' \
+ $(srcdir)/../math/domath.in > $(srcdir)/domath.c
dist_rtems_tests_DATA = math.scn
@@ -7,7 +14,6 @@ include $(RTEMS_ROOT)/make/custom/@RTEMS_BSP@.cfg
include $(top_srcdir)/../automake/compile.am
include $(top_srcdir)/../automake/leaf.am
-math_CPPFLAGS = $(AM_CPPFLAGS) -I$(top_srcdir)/math
math_LDADD = -lm
LINK_OBJS = $(math_OBJECTS) $(math_LDADD)