summaryrefslogtreecommitdiffstats
path: root/testsuites/libtests/configure.ac
diff options
context:
space:
mode:
authorJoel Sherrill <joel.sherrill@OARcorp.com>2001-10-12 18:47:00 +0000
committerJoel Sherrill <joel.sherrill@OARcorp.com>2001-10-12 18:47:00 +0000
commitd7aecdc8f866b978a4349b0e157f46877f60e414 (patch)
treedf28b2fa6611df7f1003f57447771edb69275761 /testsuites/libtests/configure.ac
parent2001-10-11 Ralf Corsepius <corsepiu@faw.uni-ulm.de> (diff)
downloadrtems-d7aecdc8f866b978a4349b0e157f46877f60e414.tar.bz2
2001-10-11 Ralf Corsepius <corsepiu@faw.uni-ulm.de>
* .cvsignore: Add autom4te.cache for autoconf > 2.52. * configure.in: Remove.
Diffstat (limited to 'testsuites/libtests/configure.ac')
-rw-r--r--testsuites/libtests/configure.ac54
1 files changed, 54 insertions, 0 deletions
diff --git a/testsuites/libtests/configure.ac b/testsuites/libtests/configure.ac
new file mode 100644
index 0000000000..e02cd43843
--- /dev/null
+++ b/testsuites/libtests/configure.ac
@@ -0,0 +1,54 @@
+## Process this file with autoconf to produce a configure script.
+##
+## $Id$
+
+AC_PREREQ(2.52)
+AC_INIT
+AC_CONFIG_SRCDIR([cpuuse])
+RTEMS_TOP(../../../..)
+AC_CONFIG_AUX_DIR(../../../..)
+
+RTEMS_CANONICAL_TARGET_CPU
+
+AM_INIT_AUTOMAKE(rtems-c-src-tests-libtests,$RTEMS_VERSION,no)
+AM_MAINTAINER_MODE
+
+RTEMS_ENABLE_CXX
+RTEMS_ENABLE_GCC28
+RTEMS_ENABLE_BARE
+
+RTEMS_ENV_RTEMSBSP
+RTEMS_CHECK_RTEMS_TEST_NO_PAUSE
+RTEMS_CHECK_CPU
+RTEMS_CANONICAL_HOST
+
+RTEMS_PROJECT_ROOT
+
+RTEMS_PROG_CC_FOR_TARGET([-ansi -fasm])
+
+if test "$RTEMS_HAS_CPLUSPLUS" = "yes"; then
+ RTEMS_PROG_CXX_FOR_TARGET
+fi
+
+RTEMS_CANONICALIZE_TOOLS
+
+RTEMS_CHECK_CUSTOM_BSP(RTEMS_BSP)
+RTEMS_CHECK_CXX(RTEMS_BSP)
+
+AC_SUBST(BARE_CPU_CFLAGS)
+AC_SUBST(BARE_CPU_MODEL)
+
+AM_CONDITIONAL(HAS_CXX,test "$HAS_CPLUSPLUS" = "yes")
+
+# Explicitly list all Makefiles here
+AC_CONFIG_FILES([Makefile
+cpuuse/Makefile
+malloctest/Makefile
+monitor/Makefile
+putenvtest/Makefile
+rtems++/Makefile
+rtmonuse/Makefile
+stackchk/Makefile
+termios/Makefile
+])
+AC_OUTPUT