summaryrefslogtreecommitdiffstats
path: root/testsuites/itrontests/itrontime01/Makefile.am
diff options
context:
space:
mode:
authorRalf Corsepius <ralf.corsepius@rtems.org>2005-11-07 08:03:28 +0000
committerRalf Corsepius <ralf.corsepius@rtems.org>2005-11-07 08:03:28 +0000
commitcdfd71036fa5d4dc32ba4c592489cbb9f75944ed (patch)
tree3c5a5adea5da5831ee3bd5fa20738563cad4dbd5 /testsuites/itrontests/itrontime01/Makefile.am
parentAdd $(PGM): ${ARCH}/$(dirstamp). (diff)
downloadrtems-cdfd71036fa5d4dc32ba4c592489cbb9f75944ed.tar.bz2
Partial conversion to automake.
Diffstat (limited to '')
-rw-r--r--testsuites/itrontests/itrontime01/Makefile.am15
1 files changed, 7 insertions, 8 deletions
diff --git a/testsuites/itrontests/itrontime01/Makefile.am b/testsuites/itrontests/itrontime01/Makefile.am
index 12d75247b9..ca8033384c 100644
--- a/testsuites/itrontests/itrontime01/Makefile.am
+++ b/testsuites/itrontests/itrontime01/Makefile.am
@@ -7,22 +7,21 @@ PGM = ${ARCH}/$(TEST).exe
MANAGERS = all
-C_FILES = init.c
-C_O_FILES = $(C_FILES:%.c=${ARCH}/%.$(OBJEXT))
+noinst_LIBRARIES = lib.a
+lib_a_SOURCES = init.c
-H_FILES = system.h
-noinst_HEADERS = $(H_FILES)
+lib_a_SOURCES += system.h
DOCTYPES = doc scn
DOCS = $(DOCTYPES:%=$(TEST).%)
-SRCS = $(DOCS) $(C_FILES) $(H_FILES)
-OBJS = $(C_O_FILES)
+SRCS = $(DOCS)
+OBJS = $(lib_a_OBJECTS)
PRINT_SRCS = $(DOCS)
include $(RTEMS_ROOT)/make/custom/@RTEMS_BSP@.cfg
-include $(top_srcdir)/../automake/compile.am
+include $(top_srcdir)/../automake/amcompile.am
include $(top_srcdir)/../automake/leaf.am
include $(top_srcdir)/itrontests.am
@@ -35,7 +34,7 @@ ${PGM}: $(OBJS) $(LINK_FILES)
all-local: $(TMPINSTALL_FILES)
-EXTRA_DIST = $(C_FILES) $(DOCS)
+EXTRA_DIST = $(DOCS)
CLEANFILES = $(TMPINSTALL_FILES)