summaryrefslogtreecommitdiffstats
path: root/testsuites/itrontests/itrontime01/Makefile.am
diff options
context:
space:
mode:
authorRalf Corsepius <ralf.corsepius@rtems.org>2009-04-03 12:55:13 +0000
committerRalf Corsepius <ralf.corsepius@rtems.org>2009-04-03 12:55:13 +0000
commit3d5483771c21619e164e5a5cc308802027785dcc (patch)
treee5517f30599b1c7b69c80a159ccae6851146508e /testsuites/itrontests/itrontime01/Makefile.am
parent2009-04-03 Ralf Corsépius <ralf.corsepius@rtems.org> (diff)
downloadrtems-3d5483771c21619e164e5a5cc308802027785dcc.tar.bz2
Eliminate _exe_/.exe.
Diffstat (limited to '')
-rw-r--r--testsuites/itrontests/itrontime01/Makefile.am14
1 files changed, 7 insertions, 7 deletions
diff --git a/testsuites/itrontests/itrontime01/Makefile.am b/testsuites/itrontests/itrontime01/Makefile.am
index 6a4c37a1f4..61654d861f 100644
--- a/testsuites/itrontests/itrontime01/Makefile.am
+++ b/testsuites/itrontests/itrontime01/Makefile.am
@@ -4,8 +4,8 @@
MANAGERS = all
-rtems_tests_PROGRAMS = itrontime01.exe
-itrontime01_exe_SOURCES = init.c system.h
+rtems_tests_PROGRAMS = itrontime01
+itrontime01_SOURCES = init.c system.h
dist_rtems_tests_DATA = itrontime01.scn
dist_rtems_tests_DATA += itrontime01.doc
@@ -14,15 +14,15 @@ include $(RTEMS_ROOT)/make/custom/@RTEMS_BSP@.cfg
include $(top_srcdir)/../automake/compile.am
include $(top_srcdir)/../automake/leaf.am
-itrontime01_exe_LDADD = $(MANAGERS_NOT_WANTED:%=$(PROJECT_LIB)/no-%.rel)
+itrontime01_LDADD = $(MANAGERS_NOT_WANTED:%=$(PROJECT_LIB)/no-%.rel)
AM_CPPFLAGS += -I$(top_srcdir)/../support/include
-LINK_OBJS = $(itrontime01_exe_OBJECTS) $(itrontime01_exe_LDADD)
-LINK_LIBS = $(itrontime01_exe_LDLIBS)
+LINK_OBJS = $(itrontime01_OBJECTS) $(itrontime01_LDADD)
+LINK_LIBS = $(itrontime01_LDLIBS)
-itrontime01.exe$(EXEEXT): $(itrontime01_exe_OBJECTS) $(itrontime01_exe_DEPENDENCIES)
- @rm -f itrontime01.exe$(EXEEXT)
+itrontime01$(EXEEXT): $(itrontime01_OBJECTS) $(itrontime01_DEPENDENCIES)
+ @rm -f itrontime01$(EXEEXT)
$(make-exe)
include $(top_srcdir)/../automake/local.am