summaryrefslogtreecommitdiffstats
path: root/testsuites/itrontests/configure.ac
diff options
context:
space:
mode:
authorJoel Sherrill <joel.sherrill@OARcorp.com>2001-10-12 18:47:00 +0000
committerJoel Sherrill <joel.sherrill@OARcorp.com>2001-10-12 18:47:00 +0000
commitd7aecdc8f866b978a4349b0e157f46877f60e414 (patch)
treedf28b2fa6611df7f1003f57447771edb69275761 /testsuites/itrontests/configure.ac
parent2001-10-11 Ralf Corsepius <corsepiu@faw.uni-ulm.de> (diff)
downloadrtems-d7aecdc8f866b978a4349b0e157f46877f60e414.tar.bz2
2001-10-11 Ralf Corsepius <corsepiu@faw.uni-ulm.de>
* .cvsignore: Add autom4te.cache for autoconf > 2.52. * configure.in: Remove.
Diffstat (limited to '')
-rw-r--r--testsuites/itrontests/configure.ac51
1 files changed, 51 insertions, 0 deletions
diff --git a/testsuites/itrontests/configure.ac b/testsuites/itrontests/configure.ac
new file mode 100644
index 0000000000..a693b01ea3
--- /dev/null
+++ b/testsuites/itrontests/configure.ac
@@ -0,0 +1,51 @@
+## Process this file with autoconf to produce a configure script.
+##
+## $Id$
+
+AC_PREREQ(2.52)
+AC_INIT
+AC_CONFIG_SRCDIR([itronhello])
+RTEMS_TOP(../../../..)
+AC_CONFIG_AUX_DIR(../../../..)
+
+RTEMS_CANONICAL_TARGET_CPU
+
+AM_INIT_AUTOMAKE(rtems-c-src-tests-itrontests,$RTEMS_VERSION,no)
+AM_MAINTAINER_MODE
+
+RTEMS_ENABLE_GCC28
+RTEMS_ENABLE_BARE
+
+RTEMS_ENV_RTEMSBSP
+RTEMS_CHECK_CPU
+RTEMS_CANONICAL_HOST
+
+RTEMS_PROJECT_ROOT
+
+RTEMS_PROG_CC_FOR_TARGET([-ansi -fasm])
+
+RTEMS_CANONICALIZE_TOOLS
+
+RTEMS_CHECK_CUSTOM_BSP(RTEMS_BSP)
+
+AC_SUBST(RTEMS_USE_GCC272)
+AC_SUBST(BARE_CPU_CFLAGS)
+AC_SUBST(BARE_CPU_MODEL)
+AC_SUBST(CC_CFLAGS_DEFAULT)
+AC_SUBST(CC_CFLAGS_DEBUG_V)
+AC_SUBST(CC_CFLAGS_PROFILE_V)
+AC_SUBST(CC_LDFLAGS_PROFILE_V)
+
+# Explicitly list all Makefiles here
+AC_CONFIG_FILES([Makefile
+itronhello/Makefile
+itronmbf01/Makefile
+itronmbox01/Makefile
+itronsem01/Makefile
+itrontask01/Makefile
+itrontask02/Makefile
+itrontask03/Makefile
+itrontask04/Makefile
+itrontime01/Makefile
+])
+AC_OUTPUT