summaryrefslogtreecommitdiffstats
path: root/testsuites/fstests/jffs2_fstime/Makefile.am
diff options
context:
space:
mode:
authorSebastian Huber <sebastian.huber@embedded-brains.de>2015-05-26 15:17:50 +0200
committerSebastian Huber <sebastian.huber@embedded-brains.de>2015-05-27 08:53:05 +0200
commitee4e7f09b4fa5f3a592d1052f841b690657fc166 (patch)
tree4b5ccda11692eb47cde046cbe51f93345bef5b20 /testsuites/fstests/jffs2_fstime/Makefile.am
parentgeneric_or1k: Fix a typo in a comment (diff)
downloadrtems-ee4e7f09b4fa5f3a592d1052f841b690657fc166.tar.bz2
jffs2: Move into separate library
In case the zlib compression was used, then the librtemscpu.a depended on libz.a. To avoid a GCC patch or complicated link flags move the JFFS2 support into a separate library to use a simple "-ljffs2 -lz" to link the executable.
Diffstat (limited to '')
-rw-r--r--testsuites/fstests/jffs2_fstime/Makefile.am3
1 files changed, 2 insertions, 1 deletions
diff --git a/testsuites/fstests/jffs2_fstime/Makefile.am b/testsuites/fstests/jffs2_fstime/Makefile.am
index 5beba8124f..a65dc23a00 100644
--- a/testsuites/fstests/jffs2_fstime/Makefile.am
+++ b/testsuites/fstests/jffs2_fstime/Makefile.am
@@ -7,6 +7,7 @@ jffs2_fstime_SOURCES += ../support/fstest.h
jffs2_fstime_SOURCES += ../../psxtests/include/pmacros.h
jffs2_fstime_SOURCES += ../jffs2_support/fs_support.c
jffs2_fstime_SOURCES += ../jffs2_support/fs_config.h
+jffs2_fstime_LDADD = -ljffs2
dist_rtems_tests_DATA = jffs2_fstime.scn
#dist_rtems_tests_DATA += jffs2_fstime.doc
@@ -21,7 +22,7 @@ AM_CPPFLAGS += -I$(top_srcdir)/jffs2_support
AM_CPPFLAGS += -I$(top_srcdir)/../support/include
AM_CPPFLAGS += -I$(top_srcdir)/../psxtests/include
-LINK_OBJS = $(jffs2_fstime_OBJECTS)
+LINK_OBJS = $(jffs2_fstime_OBJECTS) $(jffs2_fstime_LDADD)
LINK_LIBS = $(jffs2_fstime_LDLIBS)
jffs2_fstime$(EXEEXT): $(jffs2_fstime_OBJECTS) $(jffs2_fstime_DEPENDENCIES)