summaryrefslogtreecommitdiffstats
path: root/testsuites/configure.ac
diff options
context:
space:
mode:
authorChris Johns <chrisj@rtems.org>2016-08-10 13:07:29 +1000
committerChris Johns <chrisj@rtems.org>2016-08-11 17:20:10 +1000
commit9a4eca584321408ecac7b67a562d9c37be719d6a (patch)
treec8f0b5e9e4a1840ddf87d4ad6313613c1f4cf128 /testsuites/configure.ac
parentposix: nanosleep: adjust elapsed time calculation (diff)
downloadrtems-9a4eca584321408ecac7b67a562d9c37be719d6a.tar.bz2
build-system: Always enable C++ if the compiler is present.
We always build a C++ compiler and building with C++ does not effect RTEMS or the runtime. This patch always enabled the support. There is no need to manually enable it any more. You can disable C++ with '--disable-cxx'. If an architecture does not have a C++ compiler support is automatically disabled.
Diffstat (limited to 'testsuites/configure.ac')
-rw-r--r--testsuites/configure.ac6
1 files changed, 5 insertions, 1 deletions
diff --git a/testsuites/configure.ac b/testsuites/configure.ac
index 963e05b674..086f6367d5 100644
--- a/testsuites/configure.ac
+++ b/testsuites/configure.ac
@@ -17,8 +17,12 @@ RTEMS_ENV_RTEMSBSP
RTEMS_PROJECT_ROOT
+RTEMS_PROG_CC_FOR_TARGET
+RTEMS_PROG_CXX_FOR_TARGET
+RTEMS_CANONICALIZE_TOOLS
+AM_PROG_CC_C_O
+
RTEMS_CHECK_CUSTOM_BSP(RTEMS_BSP)
-RTEMS_PROG_CC
RTEMS_CHECK_CPUOPTS([RTEMS_POSIX_API])
RTEMS_CHECK_CPUOPTS([RTEMS_MULTIPROCESSING])