summaryrefslogtreecommitdiffstats
path: root/testsuites/configure.ac
diff options
context:
space:
mode:
authorRalf Corsepius <ralf.corsepius@rtems.org>2003-08-22 06:00:38 +0000
committerRalf Corsepius <ralf.corsepius@rtems.org>2003-08-22 06:00:38 +0000
commite41e3fe75ddf0c2316f33948e585d5f4e66e1b98 (patch)
treec7984b49f44bf7d343ef8854fd2e15e0e43d7b03 /testsuites/configure.ac
parent2003-08-22 Ralf Corsepius <corsepiu@faw.uni-ulm.de> (diff)
downloadrtems-e41e3fe75ddf0c2316f33948e585d5f4e66e1b98.tar.bz2
2003-08-22 Ralf Corsepius <corsepiu@faw.uni-ulm.de>
* aclocal/enable-tests.m4: Change to support --enable-tests=no|yes|samples, default is samples. * configure.ac: Reflect changes above.
Diffstat (limited to 'testsuites/configure.ac')
-rw-r--r--testsuites/configure.ac13
1 files changed, 9 insertions, 4 deletions
diff --git a/testsuites/configure.ac b/testsuites/configure.ac
index 4d5cf14bf1..dcb8b49276 100644
--- a/testsuites/configure.ac
+++ b/testsuites/configure.ac
@@ -29,12 +29,17 @@ RTEMS_CHECK_CUSTOM_BSP(RTEMS_BSP)
RTEMS_CHECK_MULTIPROCESSING(RTEMS_BSP)
RTEMS_CHECK_POSIX_API(RTEMS_BSP)
RTEMS_CHECK_ITRON_API(RTEMS_BSP)
+RTEMS_CHECK_TESTS
-AC_CONFIG_SUBDIRS(tools)
-AC_CONFIG_SUBDIRS(support)
-AC_CONFIG_SUBDIRS(samples)
+case $enable_tests in
+yes | samples )
+ AC_CONFIG_SUBDIRS(tools)
+ AC_CONFIG_SUBDIRS(support)
+ AC_CONFIG_SUBDIRS(samples)
+ ;;
+esac
-if test "$tests_enabled" = "yes"; then
+if test "$enable_tests" = "yes"; then
# do functionality tests first, then performance tests
AC_CONFIG_SUBDIRS(libtests sptests)
if test "$HAS_MP" = "yes"; then