summaryrefslogtreecommitdiffstats
path: root/scripts/rtems/Makefile.am
diff options
context:
space:
mode:
authorJoel Sherrill <joel.sherrill@OARcorp.com>1999-10-21 16:15:54 +0000
committerJoel Sherrill <joel.sherrill@OARcorp.com>1999-10-21 16:15:54 +0000
commit395376571816810d89492fa1452958840efa8c07 (patch)
tree9dbcb420674fdf0ded6edd3914abb29774e946fe /scripts/rtems/Makefile.am
parentChanges from Ralf with script-19991021-0. He fixed the %files (diff)
downloadrtems-395376571816810d89492fa1452958840efa8c07.tar.bz2
Added sh-rtemself and m68k-rtemself.
Diffstat (limited to '')
-rw-r--r--scripts/rtems/Makefile.am42
1 files changed, 25 insertions, 17 deletions
diff --git a/scripts/rtems/Makefile.am b/scripts/rtems/Makefile.am
index 94ff330145..f7158237ef 100644
--- a/scripts/rtems/Makefile.am
+++ b/scripts/rtems/Makefile.am
@@ -4,42 +4,50 @@ MKBSPSPEC = $(SHELL) $(top_builddir)/mkbspspec
MKBSPSPEC_DEPS = $(top_builddir)/mkbspspec rtems.spec.in $(top_builddir)/setup.cache
+hppa1.1-rtems-simhppa-$(BSPVERS).spec: $(MKBSPSPEC_DEPS)
+ $(MKBSPSPEC) -cfg $(top_builddir)/setup.cache -o . hppa1.1-rtems simhppa
+
i386-rtems-pc386-$(BSPVERS).spec: $(MKBSPSPEC_DEPS)
$(MKBSPSPEC) -cfg $(top_builddir)/setup.cache -o . i386-rtems pc386
-sh-rtems-gensh1-$(BSPVERS).spec: $(MKBSPSPEC_DEPS)
- $(MKBSPSPEC) -cfg $(top_builddir)/setup.cache -o . sh-rtems gensh1
-
-powerpc-rtems-mcp750-$(BSPVERS).spec: $(MKBSPSPEC_DEPS)
- $(MKBSPSPEC) -cfg $(top_builddir)/setup.cache -o . powerpc-rtems mcp750
-
-sparc-rtems-erc32-$(BSPVERS).spec: $(MKBSPSPEC_DEPS)
- $(MKBSPSPEC) -cfg $(top_builddir)/setup.cache -o . sparc-rtems erc32
+i960-rtems-cvme961-$(BSPVERS).spec: $(MKBSPSPEC_DEPS)
+ $(MKBSPSPEC) -cfg $(top_builddir)/setup.cache -o . i960-rtems cvme961
m68k-rtems-gen68360-$(BSPVERS).spec: $(MKBSPSPEC_DEPS)
$(MKBSPSPEC) -cfg $(top_builddir)/setup.cache -o . m68k-rtems gen68360
+m68k-rtemself-gen68360-$(BSPVERS).spec: $(MKBSPSPEC_DEPS)
+ $(MKBSPSPEC) -cfg $(top_builddir)/setup.cache -o . m68k-rtemself gen68360
+
mips64orion-rtems-p4600-$(BSPVERS).spec: $(MKBSPSPEC_DEPS)
$(MKBSPSPEC) -cfg $(top_builddir)/setup.cache -o . mips64orion-rtems p4600
-i960-rtems-cvme961-$(BSPVERS).spec: $(MKBSPSPEC_DEPS)
- $(MKBSPSPEC) -cfg $(top_builddir)/setup.cache -o . i960-rtems cvme961
+powerpc-rtems-mcp750-$(BSPVERS).spec: $(MKBSPSPEC_DEPS)
+ $(MKBSPSPEC) -cfg $(top_builddir)/setup.cache -o . powerpc-rtems mcp750
-hppa1.1-rtems-simhppa-$(BSPVERS).spec: $(MKBSPSPEC_DEPS)
- $(MKBSPSPEC) -cfg $(top_builddir)/setup.cache -o . hppa1.1-rtems simhppa
+sh-rtems-gensh1-$(BSPVERS).spec: $(MKBSPSPEC_DEPS)
+ $(MKBSPSPEC) -cfg $(top_builddir)/setup.cache -o . sh-rtems gensh1
+
+sh-rtemself-gensh1-$(BSPVERS).spec: $(MKBSPSPEC_DEPS)
+ $(MKBSPSPEC) -cfg $(top_builddir)/setup.cache -o . sh-rtemself gensh1
+
+sparc-rtems-erc32-$(BSPVERS).spec: $(MKBSPSPEC_DEPS)
+ $(MKBSPSPEC) -cfg $(top_builddir)/setup.cache -o . sparc-rtems erc32
TEMPLATES = \
rtems.spec.in
RPM_SPECS_DATA = \
+hppa1.1-rtems-simhppa-$(BSPVERS).spec \
i386-rtems-pc386-$(BSPVERS).spec \
-sh-rtems-gensh1-$(BSPVERS).spec \
-powerpc-rtems-mcp750-$(BSPVERS).spec \
-sparc-rtems-erc32-$(BSPVERS).spec \
+i960-rtems-cvme961-$(BSPVERS).spec \
m68k-rtems-gen68360-$(BSPVERS).spec \
+m68k-rtemself-gen68360-$(BSPVERS).spec \
mips64orion-rtems-p4600-$(BSPVERS).spec \
-i960-rtems-cvme961-$(BSPVERS).spec \
-hppa1.1-rtems-simhppa-$(BSPVERS).spec
+powerpc-rtems-mcp750-$(BSPVERS).spec \
+sh-rtems-gensh1-$(BSPVERS).spec \
+sh-rtemself-gensh1-$(BSPVERS).spec \
+sparc-rtems-erc32-$(BSPVERS).spec
noinst_DATA = \
$(TEMPLATES)