summaryrefslogtreecommitdiffstats
path: root/scripts/gnatnewlib/Makefile.am
diff options
context:
space:
mode:
authorJoel Sherrill <joel.sherrill@OARcorp.com>2000-01-27 23:48:50 +0000
committerJoel Sherrill <joel.sherrill@OARcorp.com>2000-01-27 23:48:50 +0000
commitf82fee97bb8d5429547aeb04d6812fae2610119f (patch)
treee1836f32c6ab0ee0beadedc4df2c18b7868f16b9 /scripts/gnatnewlib/Makefile.am
parentGNAT/RTEMS RPMs have built for the binutils/gnat/gcc combination (diff)
downloadrtems-f82fee97bb8d5429547aeb04d6812fae2610119f.tar.bz2
Patch rtems-rc-20000118-0.diff from Ralf Corsepius <corsepiu@faw.uni-ulm.de>
that converts the a29k to automake. This patch contains * An initial merger of the libcpu/a29k stuff you sent yesterday. AFAIS, most code inside them seems to be empty stubs. One file even contains a function called mips_*** which might indicate that this part might contain mips code or the code the initial porter used as template for porting. Unfortunately, I don't know anything about the a29k so I can't comment on the details. * A dummy bsp_specs to libbsp/29k/portsw * An update to the automake files related to the a29k. Note: * This patch is completely untested, because I don't have a toolchain for it. * The files in libcpu/a29k include bsp.h => The libbsp vs. libcpu-issue hits again.
Diffstat (limited to 'scripts/gnatnewlib/Makefile.am')
-rw-r--r--scripts/gnatnewlib/Makefile.am61
1 files changed, 0 insertions, 61 deletions
diff --git a/scripts/gnatnewlib/Makefile.am b/scripts/gnatnewlib/Makefile.am
deleted file mode 100644
index 60d7f0cc93..0000000000
--- a/scripts/gnatnewlib/Makefile.am
+++ /dev/null
@@ -1,61 +0,0 @@
-## $Id$
-
-AUTOMAKE_OPTIONS = foreign
-
-MKGNATNEWLIBSPEC = $(SHELL) $(top_builddir)/mkgnatnewlibspec
-
-MKGNATNEWLIBSPEC_DEPS = \
- $(top_builddir)/mkgnatnewlibspec gnatnewlib.spec.in $(top_builddir)/setup.cache
-
-hppa1.1-rtems-$(GNATNEWLIBVERS).spec: $(MKGNATNEWLIBSPEC_DEPS)
- $(MKGNATNEWLIBSPEC) -cfg $(top_builddir)/setup.cache -o . hppa1.1-rtems
-
-i386-rtems-$(GNATNEWLIBVERS).spec: $(MKGNATNEWLIBSPEC_DEPS)
- $(MKGNATNEWLIBSPEC) -cfg $(top_builddir)/setup.cache -o . i386-rtems
-
-i960-rtems-$(GNATNEWLIBVERS).spec: $(MKGNATNEWLIBSPEC_DEPS)
- $(MKGNATNEWLIBSPEC) -cfg $(top_builddir)/setup.cache -o . i960-rtems
-
-m68k-rtems-$(GNATNEWLIBVERS).spec: $(MKGNATNEWLIBSPEC_DEPS)
- $(MKGNATNEWLIBSPEC) -cfg $(top_builddir)/setup.cache -o . m68k-rtems
-
-m68k-rtemself-$(GNATNEWLIBVERS).spec: $(MKGNATNEWLIBSPEC_DEPS)
- $(MKGNATNEWLIBSPEC) -cfg $(top_builddir)/setup.cache -o . m68k-rtemself
-
-mips64orion-rtems-$(GNATNEWLIBVERS).spec: $(MKGNATNEWLIBSPEC_DEPS)
- $(MKGNATNEWLIBSPEC) -cfg $(top_builddir)/setup.cache -o . mips64orion-rtems
-
-powerpc-rtems-$(GNATNEWLIBVERS).spec: $(MKGNATNEWLIBSPEC_DEPS)
- $(MKGNATNEWLIBSPEC) -cfg $(top_builddir)/setup.cache -o . powerpc-rtems
-
-sh-rtems-$(GNATNEWLIBVERS).spec: $(MKGNATNEWLIBSPEC_DEPS)
- $(MKGNATNEWLIBSPEC) -cfg $(top_builddir)/setup.cache -o . sh-rtems
-
-sh-rtemself-$(GNATNEWLIBVERS).spec: $(MKGNATNEWLIBSPEC_DEPS)
- $(MKGNATNEWLIBSPEC) -cfg $(top_builddir)/setup.cache -o . sh-rtemself
-
-sparc-rtems-$(GNATNEWLIBVERS).spec: $(MKGNATNEWLIBSPEC_DEPS)
- $(MKGNATNEWLIBSPEC) -cfg $(top_builddir)/setup.cache -o . sparc-rtems
-
-TEMPLATES = \
-gnatnewlib.spec.in
-
-RPM_SPECS_DATA = \
-hppa1.1-rtems-$(GNATNEWLIBVERS).spec \
-i386-rtems-$(GNATNEWLIBVERS).spec \
-i960-rtems-$(GNATNEWLIBVERS).spec \
-m68k-rtems-$(GNATNEWLIBVERS).spec \
-m68k-rtemself-$(GNATNEWLIBVERS).spec \
-mips64orion-rtems-$(GNATNEWLIBVERS).spec \
-powerpc-rtems-$(GNATNEWLIBVERS).spec \
-sh-rtems-$(GNATNEWLIBVERS).spec \
-sh-rtemself-$(GNATNEWLIBVERS).spec \
-sparc-rtems-$(GNATNEWLIBVERS).spec
-
-noinst_DATA = \
-$(TEMPLATES)
-
-EXTRA_DIST = \
-$(TEMPLATES)
-
-CLEANFILES = $(RPM_SPECS_DATA)