summaryrefslogtreecommitdiffstats
path: root/scripts/gdb/Makefile.am
diff options
context:
space:
mode:
authorRalf Corsepius <ralf.corsepius@rtems.org>2003-09-04 13:35:27 +0000
committerRalf Corsepius <ralf.corsepius@rtems.org>2003-09-04 13:35:27 +0000
commitf8f365a6c9bd474457f9d7503fd0788abfb9a5c5 (patch)
treebbeef0b61ed02739a5cc01e73847fc27c24a957f /scripts/gdb/Makefile.am
parent2003-09-04 Joel Sherrill <joel@OARcorp.com> (diff)
downloadrtems-f8f365a6c9bd474457f9d7503fd0788abfb9a5c5.tar.bz2
2003-09-04 Ralf Corsepius <corsepiu@faw.uni-ulm.de>
* configure.ac: Add --enable-osversions (OS-versioned RPMS support). * binutils/Makefile.am: Add osversion support. * binutils/mkspec.in: Add osversion support. * gcc3newlib/Makefile.am: Add osversion support. * gcc3newlib/mkspec.in: Add osversion support. * gdb/Makefile.am: Add osversion support. * gdb/mkspec.in: Add osversion support. Add rpmprefix, rpmgroup.
Diffstat (limited to '')
-rw-r--r--scripts/gdb/Makefile.am84
1 files changed, 42 insertions, 42 deletions
diff --git a/scripts/gdb/Makefile.am b/scripts/gdb/Makefile.am
index f4d60a92ca..da59ed4d4b 100644
--- a/scripts/gdb/Makefile.am
+++ b/scripts/gdb/Makefile.am
@@ -23,73 +23,73 @@ MKGDBSPEC_DEPS = mkspec gdb.spec.in \
RPM_SPECS_DATA =
-arm-rtems-$(GDBVERS).spec: $(MKGDBSPEC_DEPS)
- $(MKSPEC) -cfg $(top_builddir)/setup.cache arm-rtems > $@
-RPM_SPECS_DATA += arm-rtems-$(GDBVERS).spec
+arm-rtems@osversion@-$(GDBVERS).spec: $(MKGDBSPEC_DEPS)
+ $(MKSPEC) -cfg $(top_builddir)/setup.cache arm-rtems@osversion@ > $@
+RPM_SPECS_DATA += arm-rtems@osversion@-$(GDBVERS).spec
# does not build with 5.2
-# c4x-rtems-$(GDBVERS).spec: $(MKGDBSPEC_DEPS)
-# $(MKSPEC) -cfg $(top_builddir)/setup.cache c4x-rtems > $@
-# RPM_SPECS_DATA += c4x-rtems-$(GDBVERS).spec
+# c4x-rtems@osversion@-$(GDBVERS).spec: $(MKGDBSPEC_DEPS)
+# $(MKSPEC) -cfg $(top_builddir)/setup.cache c4x-rtems@osversion@ > $@
+# RPM_SPECS_DATA += c4x-rtems@osversion@-$(GDBVERS).spec
-h8300-rtems-$(GDBVERS).spec: $(MKGDBSPEC_DEPS)
- $(MKSPEC) -cfg $(top_builddir)/setup.cache h8300-rtems > $@
-RPM_SPECS_DATA += h8300-rtems-$(GDBVERS).spec
+h8300-rtems@osversion@-$(GDBVERS).spec: $(MKGDBSPEC_DEPS)
+ $(MKSPEC) -cfg $(top_builddir)/setup.cache h8300-rtems@osversion@ > $@
+RPM_SPECS_DATA += h8300-rtems@osversion@-$(GDBVERS).spec
# does not build with 5.2
-# hppa1.1-rtems-$(GDBVERS).spec: $(MKGDBSPEC_DEPS)
-# $(MKSPEC) -cfg $(top_builddir)/setup.cache hppa1.1-rtems > $@
-# RPM_SPECS_DATA += hppa1.1-rtems-$(GDBVERS).spec
+# hppa1.1-rtems@osversion@-$(GDBVERS).spec: $(MKGDBSPEC_DEPS)
+# $(MKSPEC) -cfg $(top_builddir)/setup.cache hppa1.1-rtems@osversion@ > $@
+# RPM_SPECS_DATA += hppa1.1-rtems@osversion@-$(GDBVERS).spec
-RPM_SPECS_DATA += i386-rtems-$(GDBVERS).spec
-i386-rtems-$(GDBVERS).spec: $(MKGDBSPEC_DEPS)
- $(MKSPEC) -cfg $(top_builddir)/setup.cache i386-rtems > $@
+RPM_SPECS_DATA += i386-rtems@osversion@-$(GDBVERS).spec
+i386-rtems@osversion@-$(GDBVERS).spec: $(MKGDBSPEC_DEPS)
+ $(MKSPEC) -cfg $(top_builddir)/setup.cache i386-rtems@osversion@ > $@
# does not build with 5.2
# i386-RTEMS-$(GDBVERS).spec: $(MKGDBSPEC_DEPS)
# $(MKSPEC) -cfg $(top_builddir)/setup.cache i386-RTEMS > $@
# RPM_SPECS_DATA += i386-RTEMS-$(GDBVERS).spec
-i960-rtems-$(GDBVERS).spec: $(MKGDBSPEC_DEPS)
- $(MKSPEC) -cfg $(top_builddir)/setup.cache i960-rtems > $@
-RPM_SPECS_DATA += i960-rtems-$(GDBVERS).spec
+i960-rtems@osversion@-$(GDBVERS).spec: $(MKGDBSPEC_DEPS)
+ $(MKSPEC) -cfg $(top_builddir)/setup.cache i960-rtems@osversion@ > $@
+RPM_SPECS_DATA += i960-rtems@osversion@-$(GDBVERS).spec
-m68k-rtems-$(GDBVERS).spec: $(MKGDBSPEC_DEPS)
- $(MKSPEC) -cfg $(top_builddir)/setup.cache m68k-rtems > $@
-RPM_SPECS_DATA += m68k-rtems-$(GDBVERS).spec
+m68k-rtems@osversion@-$(GDBVERS).spec: $(MKGDBSPEC_DEPS)
+ $(MKSPEC) -cfg $(top_builddir)/setup.cache m68k-rtems@osversion@ > $@
+RPM_SPECS_DATA += m68k-rtems@osversion@-$(GDBVERS).spec
-mips64orion-rtems-$(GDBVERS).spec: $(MKGDBSPEC_DEPS)
- $(MKSPEC) -cfg $(top_builddir)/setup.cache mips64orion-rtems > $@
-RPM_SPECS_DATA += mips64orion-rtems-$(GDBVERS).spec
+mips64orion-rtems@osversion@-$(GDBVERS).spec: $(MKGDBSPEC_DEPS)
+ $(MKSPEC) -cfg $(top_builddir)/setup.cache mips64orion-rtems@osversion@ > $@
+RPM_SPECS_DATA += mips64orion-rtems@osversion@-$(GDBVERS).spec
-mips-rtems-$(GDBVERS).spec: $(MKGDBSPEC_DEPS)
- $(MKSPEC) -cfg $(top_builddir)/setup.cache mips-rtems > $@
-RPM_SPECS_DATA += mips-rtems-$(GDBVERS).spec
+mips-rtems@osversion@-$(GDBVERS).spec: $(MKGDBSPEC_DEPS)
+ $(MKSPEC) -cfg $(top_builddir)/setup.cache mips-rtems@osversion@ > $@
+RPM_SPECS_DATA += mips-rtems@osversion@-$(GDBVERS).spec
-mipstx39-rtems-$(GDBVERS).spec: $(MKGDBSPEC_DEPS)
- $(MKSPEC) -cfg $(top_builddir)/setup.cache mipstx39-rtems > $@
-RPM_SPECS_DATA += mipstx39-rtems-$(GDBVERS).spec
+mipstx39-rtems@osversion@-$(GDBVERS).spec: $(MKGDBSPEC_DEPS)
+ $(MKSPEC) -cfg $(top_builddir)/setup.cache mipstx39-rtems@osversion@ > $@
+RPM_SPECS_DATA += mipstx39-rtems@osversion@-$(GDBVERS).spec
# does not build with 5.2
# powerpc-RTEMS-$(GDBVERS).spec: $(MKGDBSPEC_DEPS)
# $(MKSPEC) -cfg $(top_builddir)/setup.cache powerpc-RTEMS > $@
# RPM_SPECS_DATA += powerpc-RTEMS-$(GDBVERS).spec
-powerpc-rtems-$(GDBVERS).spec: $(MKGDBSPEC_DEPS)
- $(MKSPEC) -cfg $(top_builddir)/setup.cache powerpc-rtems > $@
-RPM_SPECS_DATA += powerpc-rtems-$(GDBVERS).spec
+powerpc-rtems@osversion@-$(GDBVERS).spec: $(MKGDBSPEC_DEPS)
+ $(MKSPEC) -cfg $(top_builddir)/setup.cache powerpc-rtems@osversion@ > $@
+RPM_SPECS_DATA += powerpc-rtems@osversion@-$(GDBVERS).spec
-sh-rtems-$(GDBVERS).spec: $(MKGDBSPEC_DEPS)
- $(MKSPEC) -cfg $(top_builddir)/setup.cache sh-rtems > $@
-RPM_SPECS_DATA += sh-rtems-$(GDBVERS).spec
+sh-rtems@osversion@-$(GDBVERS).spec: $(MKGDBSPEC_DEPS)
+ $(MKSPEC) -cfg $(top_builddir)/setup.cache sh-rtems@osversion@ > $@
+RPM_SPECS_DATA += sh-rtems@osversion@-$(GDBVERS).spec
-sh-rtemself-$(GDBVERS).spec: $(MKGDBSPEC_DEPS)
- $(MKSPEC) -cfg $(top_builddir)/setup.cache sh-rtemself > $@
-RPM_SPECS_DATA += sh-rtemself-$(GDBVERS).spec
+sh-rtemself@osversion@-$(GDBVERS).spec: $(MKGDBSPEC_DEPS)
+ $(MKSPEC) -cfg $(top_builddir)/setup.cache sh-rtemself@osversion@ > $@
+RPM_SPECS_DATA += sh-rtemself@osversion@-$(GDBVERS).spec
-sparc-rtems-$(GDBVERS).spec: $(MKGDBSPEC_DEPS)
- $(MKSPEC) -cfg $(top_builddir)/setup.cache sparc-rtems > $@
-RPM_SPECS_DATA += sparc-rtems-$(GDBVERS).spec
+sparc-rtems@osversion@-$(GDBVERS).spec: $(MKGDBSPEC_DEPS)
+ $(MKSPEC) -cfg $(top_builddir)/setup.cache sparc-rtems@osversion@ > $@
+RPM_SPECS_DATA += sparc-rtems@osversion@-$(GDBVERS).spec
CLEANFILES += $(RPM_SPECS_DATA)