summaryrefslogtreecommitdiffstats
path: root/scripts/gdb/Makefile.am
diff options
context:
space:
mode:
authorJoel Sherrill <joel.sherrill@OARcorp.com>1999-10-20 15:50:13 +0000
committerJoel Sherrill <joel.sherrill@OARcorp.com>1999-10-20 15:50:13 +0000
commitc4d1d41cafa24f8c7877a6497931edc534a3012e (patch)
tree3a602a56fde31215d0354b8b6f64b1ddcaf1657f /scripts/gdb/Makefile.am
parentAdding the infrastructure for gdb. (diff)
downloadrtems-c4d1d41cafa24f8c7877a6497931edc534a3012e.tar.bz2
New files.
Diffstat (limited to '')
-rw-r--r--scripts/gdb/Makefile.am50
1 files changed, 50 insertions, 0 deletions
diff --git a/scripts/gdb/Makefile.am b/scripts/gdb/Makefile.am
new file mode 100644
index 0000000000..01d23117a6
--- /dev/null
+++ b/scripts/gdb/Makefile.am
@@ -0,0 +1,50 @@
+AUTOMAKE_OPTIONS = foreign
+
+MKGDBSPEC = $(SHELL) $(top_srcdir)/mkgdbspec
+
+MKGDBSPEC_DEPS = ../mkgdbspec gdb.spec.in ../setup.cache
+
+i386-rtems-$(GDBVERS).spec: $(MKGDBSPEC_DEPS)
+ $(MKGDBSPEC) -cfg ../setup.cache -o . i386-rtems
+
+sh-rtems-$(GDBVERS).spec: $(MKGDBSPEC_DEPS)
+ $(MKGDBSPEC) -cfg ../setup.cache -o . sh-rtems
+
+powerpc-rtems-$(GDBVERS).spec: $(MKGDBSPEC_DEPS)
+ $(MKGDBSPEC) -cfg ../setup.cache -o . powerpc-rtems
+
+sparc-rtems-$(GDBVERS).spec: $(MKGDBSPEC_DEPS)
+ $(MKGDBSPEC) -cfg ../setup.cache -o . sparc-rtems
+
+m68k-rtems-$(GDBVERS).spec: $(MKGDBSPEC_DEPS)
+ $(MKGDBSPEC) -cfg ../setup.cache -o . m68k-rtems
+
+mips64orion-rtems-$(GDBVERS).spec: $(MKGDBSPEC_DEPS)
+ $(MKGDBSPEC) -cfg ../setup.cache -o . mips64orion-rtems
+
+i960-rtems-$(GDBVERS).spec: $(MKGDBSPEC_DEPS)
+ $(MKGDBSPEC) -cfg ../setup.cache -o . i960-rtems
+
+hppa1.1-rtems-$(GDBVERS).spec: $(MKGDBSPEC_DEPS)
+ $(MKGDBSPEC) -cfg ../setup.cache -o . hppa1.1-rtems
+
+TEMPLATES = \
+gdb.spec.in
+
+RPM_SPECS_DATA = \
+i386-rtems-$(GDBVERS).spec \
+sh-rtems-$(GDBVERS).spec \
+powerpc-rtems-$(GDBVERS).spec \
+sparc-rtems-$(GDBVERS).spec \
+m68k-rtems-$(GDBVERS).spec \
+mips64orion-rtems-$(GDBVERS).spec \
+i960-rtems-$(GDBVERS).spec \
+hppa1.1-rtems-$(GDBVERS).spec
+
+noinst_DATA = \
+$(TEMPLATES)
+
+EXTRA_DIST = \
+$(TEMPLATES)
+
+CLEANFILES = $(RPM_SPECS_DATA)