summaryrefslogtreecommitdiffstats
path: root/scripts/gdb/Makefile.am
diff options
context:
space:
mode:
authorJoel Sherrill <joel.sherrill@OARcorp.com>1999-10-21 15:59:54 +0000
committerJoel Sherrill <joel.sherrill@OARcorp.com>1999-10-21 15:59:54 +0000
commit43e7d103a0aa620f5f75c4ccac2f5b6c3d3f9433 (patch)
tree4ac0457190bb29a927139d9a966ac14c88c2bb61 /scripts/gdb/Makefile.am
parentAdded Semaphore_Flush. (diff)
downloadrtems-43e7d103a0aa620f5f75c4ccac2f5b6c3d3f9433.tar.bz2
Changes from Ralf with script-19991021-0. He fixed the %files
issue and has mkbspspec in a better state. user.cfg is now gone. There are some miscellaneous changes to buildall done by Joel to clean up the build process.
Diffstat (limited to '')
-rw-r--r--scripts/gdb/Makefile.am21
1 files changed, 11 insertions, 10 deletions
diff --git a/scripts/gdb/Makefile.am b/scripts/gdb/Makefile.am
index 01d23117a6..ed3f51d7a9 100644
--- a/scripts/gdb/Makefile.am
+++ b/scripts/gdb/Makefile.am
@@ -1,32 +1,33 @@
AUTOMAKE_OPTIONS = foreign
-MKGDBSPEC = $(SHELL) $(top_srcdir)/mkgdbspec
+MKGDBSPEC = $(SHELL) $(top_builddir)/mkgdbspec
-MKGDBSPEC_DEPS = ../mkgdbspec gdb.spec.in ../setup.cache
+MKGDBSPEC_DEPS = \
+$(top_builddir)/mkgdbspec gdb.spec.in $(top_builddir)/setup.cache
i386-rtems-$(GDBVERS).spec: $(MKGDBSPEC_DEPS)
- $(MKGDBSPEC) -cfg ../setup.cache -o . i386-rtems
+ $(MKGDBSPEC) -cfg $(top_builddir)/setup.cache -o . i386-rtems
sh-rtems-$(GDBVERS).spec: $(MKGDBSPEC_DEPS)
- $(MKGDBSPEC) -cfg ../setup.cache -o . sh-rtems
+ $(MKGDBSPEC) -cfg $(top_builddir)/setup.cache -o . sh-rtems
powerpc-rtems-$(GDBVERS).spec: $(MKGDBSPEC_DEPS)
- $(MKGDBSPEC) -cfg ../setup.cache -o . powerpc-rtems
+ $(MKGDBSPEC) -cfg $(top_builddir)/setup.cache -o . powerpc-rtems
sparc-rtems-$(GDBVERS).spec: $(MKGDBSPEC_DEPS)
- $(MKGDBSPEC) -cfg ../setup.cache -o . sparc-rtems
+ $(MKGDBSPEC) -cfg $(top_builddir)/setup.cache -o . sparc-rtems
m68k-rtems-$(GDBVERS).spec: $(MKGDBSPEC_DEPS)
- $(MKGDBSPEC) -cfg ../setup.cache -o . m68k-rtems
+ $(MKGDBSPEC) -cfg $(top_builddir)/setup.cache -o . m68k-rtems
mips64orion-rtems-$(GDBVERS).spec: $(MKGDBSPEC_DEPS)
- $(MKGDBSPEC) -cfg ../setup.cache -o . mips64orion-rtems
+ $(MKGDBSPEC) -cfg $(top_builddir)/setup.cache -o . mips64orion-rtems
i960-rtems-$(GDBVERS).spec: $(MKGDBSPEC_DEPS)
- $(MKGDBSPEC) -cfg ../setup.cache -o . i960-rtems
+ $(MKGDBSPEC) -cfg $(top_builddir)/setup.cache -o . i960-rtems
hppa1.1-rtems-$(GDBVERS).spec: $(MKGDBSPEC_DEPS)
- $(MKGDBSPEC) -cfg ../setup.cache -o . hppa1.1-rtems
+ $(MKGDBSPEC) -cfg $(top_builddir)/setup.cache -o . hppa1.1-rtems
TEMPLATES = \
gdb.spec.in