summaryrefslogtreecommitdiffstats
path: root/scripts/gdb/Makefile.am
diff options
context:
space:
mode:
authorRalf Corsepius <ralf.corsepius@rtems.org>2005-03-17 13:42:17 +0000
committerRalf Corsepius <ralf.corsepius@rtems.org>2005-03-17 13:42:17 +0000
commit1a58b1f9d925dd6a16071a106c1aad0827c8e19d (patch)
tree992a883359e4960adf2603da0491187cc53236db /scripts/gdb/Makefile.am
parent2005-03-14 Joel Sherrill <joel@OARcorp.com> (diff)
downloadrtems-1a58b1f9d925dd6a16071a106c1aad0827c8e19d.tar.bz2
2005-03-17 Ralf Corsepius <ralf.corsepius@rtems.org>
* gdb/Makefile.am: Add avr, mips64. Cosmetics. * gdb/base-gdb.add: Reflect gdb-6.3 not shipping mmalloc.info*. * gdb/target-gdb.add: Add support for gcc-6.3's gdbtui. * gdb/mkspec.in: Add PATCH-magic. Add gdb_suffix.
Diffstat (limited to '')
-rw-r--r--scripts/gdb/Makefile.am10
1 files changed, 9 insertions, 1 deletions
diff --git a/scripts/gdb/Makefile.am b/scripts/gdb/Makefile.am
index 8ace9ffce0..6c1279460d 100644
--- a/scripts/gdb/Makefile.am
+++ b/scripts/gdb/Makefile.am
@@ -26,13 +26,17 @@ arm-rtems@osversion@-$(GDBVERS).spec: $(MKGDBSPEC_DEPS)
$(MKSPEC) -cfg $(top_builddir)/setup.cache arm-rtems@osversion@ > $@
RPM_SPECS_DATA += arm-rtems@osversion@-$(GDBVERS).spec
+avr-rtems@osversion@-$(GDBVERS).spec: $(MKGDBSPEC_DEPS)
+ $(MKSPEC) -cfg $(top_builddir)/setup.cache avr-rtems@osversion@ > $@
+RPM_SPECS_DATA += avr-rtems@osversion@-$(GDBVERS).spec
+
h8300-rtems@osversion@-$(GDBVERS).spec: $(MKGDBSPEC_DEPS)
$(MKSPEC) -cfg $(top_builddir)/setup.cache h8300-rtems@osversion@ > $@
RPM_SPECS_DATA += h8300-rtems@osversion@-$(GDBVERS).spec
-RPM_SPECS_DATA += i386-rtems@osversion@-$(GDBVERS).spec
i386-rtems@osversion@-$(GDBVERS).spec: $(MKGDBSPEC_DEPS)
$(MKSPEC) -cfg $(top_builddir)/setup.cache i386-rtems@osversion@ > $@
+RPM_SPECS_DATA += i386-rtems@osversion@-$(GDBVERS).spec
# does not build with 5.2
# i386-RTEMS-$(GDBVERS).spec: $(MKGDBSPEC_DEPS)
@@ -47,6 +51,10 @@ mips-rtems@osversion@-$(GDBVERS).spec: $(MKGDBSPEC_DEPS)
$(MKSPEC) -cfg $(top_builddir)/setup.cache mips-rtems@osversion@ > $@
RPM_SPECS_DATA += mips-rtems@osversion@-$(GDBVERS).spec
+mips64-rtems@osversion@-$(GDBVERS).spec: $(MKGDBSPEC_DEPS)
+ $(MKSPEC) -cfg $(top_builddir)/setup.cache mips64-rtems@osversion@ > $@
+RPM_SPECS_DATA += mips64-rtems@osversion@-$(GDBVERS).spec
+
mipstx39-rtems@osversion@-$(GDBVERS).spec: $(MKGDBSPEC_DEPS)
$(MKSPEC) -cfg $(top_builddir)/setup.cache mipstx39-rtems@osversion@ > $@
RPM_SPECS_DATA += mipstx39-rtems@osversion@-$(GDBVERS).spec