summaryrefslogtreecommitdiffstats
path: root/scripts/gdb/Makefile.am
diff options
context:
space:
mode:
authorJoel Sherrill <joel.sherrill@OARcorp.com>2000-07-27 01:04:11 +0000
committerJoel Sherrill <joel.sherrill@OARcorp.com>2000-07-27 01:04:11 +0000
commit08330bf0be8fed443402ffd1664b2ca4d16b6f8e (patch)
treed569b8f1786695e639ddef8e9caedf8874c1a24e /scripts/gdb/Makefile.am
parentPatch from Charles-Antoine Gauthier <charles.gauthier@nrc.ca> that (diff)
downloadrtems-08330bf0be8fed443402ffd1664b2ca4d16b6f8e.tar.bz2
Port of RTEMS to the ARM processor family by Eric Valette
<valette@crf.canon.fr> and Emmanuel Raguet <raguet@crf.canon.fr> of Canon CRF - Communication Dept. This port includes a basic BSP that is sufficient to link hello world.
Diffstat (limited to '')
-rw-r--r--scripts/gdb/Makefile.am16
1 files changed, 12 insertions, 4 deletions
diff --git a/scripts/gdb/Makefile.am b/scripts/gdb/Makefile.am
index a5b67c3652..bc8fc660b4 100644
--- a/scripts/gdb/Makefile.am
+++ b/scripts/gdb/Makefile.am
@@ -15,6 +15,12 @@ CLEANFILES += gdb.spec.in
MKGDBSPEC_DEPS = $(top_builddir)/mkgdbspec gdb.spec.in \
$(top_builddir)/setup.cache
+arm-rtems-$(GDBVERS).spec: $(MKGDBSPEC_DEPS)
+ $(MKGDBSPEC) -cfg $(top_builddir)/setup.cache -o . arm-rtems
+
+c4x-rtems-$(GDBVERS).spec: $(MKGDBSPEC_DEPS)
+ $(MKGDBSPEC) -cfg $(top_builddir)/setup.cache -o . c4x-rtems
+
h8300-rtems-$(GDBVERS).spec: $(MKGDBSPEC_DEPS)
$(MKGDBSPEC) -cfg $(top_builddir)/setup.cache -o . h8300-rtems
@@ -48,12 +54,14 @@ sh-rtemself-$(GDBVERS).spec: $(MKGDBSPEC_DEPS)
sparc-rtems-$(GDBVERS).spec: $(MKGDBSPEC_DEPS)
$(MKGDBSPEC) -cfg $(top_builddir)/setup.cache -o . sparc-rtems
-RPM_SPECS_DATA = h8300-rtems-$(GDBVERS).spec i386-rtems-$(GDBVERS).spec \
- hppa1.1-rtems-$(GDBVERS).spec i386-rtems-$(GDBVERS).spec \
- i960-rtems-$(GDBVERS).spec m68k-rtems-$(GDBVERS).spec \
- m68k-rtemself-$(GDBVERS).spec mips64orion-rtems-$(GDBVERS).spec \
+RPM_SPECS_DATA = \
+ arm-rtems-$(GDBVERS).spec c4x-rtems-$(GDBVERS).spec \
+ h8300-rtems-$(GDBVERS).spec hppa1.1-rtems-$(GDBVERS).spec \
+ i386-rtems-$(GDBVERS).spec i960-rtems-$(GDBVERS).spec \
+ m68k-rtems-$(GDBVERS).spec mips64orion-rtems-$(GDBVERS).spec \
powerpc-rtems-$(GDBVERS).spec sh-rtems-$(GDBVERS).spec \
sh-rtemself-$(GDBVERS).spec sparc-rtems-$(GDBVERS).spec
+
CLEANFILES += $(RPM_SPECS_DATA)
EXTRA_DIST = $(SUBPACKAGES)