summaryrefslogtreecommitdiffstats
path: root/scripts/gcc3newlib/Makefile.am
diff options
context:
space:
mode:
authorRalf Corsepius <ralf.corsepius@rtems.org>2003-09-04 13:35:27 +0000
committerRalf Corsepius <ralf.corsepius@rtems.org>2003-09-04 13:35:27 +0000
commitf8f365a6c9bd474457f9d7503fd0788abfb9a5c5 (patch)
treebbeef0b61ed02739a5cc01e73847fc27c24a957f /scripts/gcc3newlib/Makefile.am
parent2003-09-04 Joel Sherrill <joel@OARcorp.com> (diff)
downloadrtems-f8f365a6c9bd474457f9d7503fd0788abfb9a5c5.tar.bz2
2003-09-04 Ralf Corsepius <corsepiu@faw.uni-ulm.de>
* configure.ac: Add --enable-osversions (OS-versioned RPMS support). * binutils/Makefile.am: Add osversion support. * binutils/mkspec.in: Add osversion support. * gcc3newlib/Makefile.am: Add osversion support. * gcc3newlib/mkspec.in: Add osversion support. * gdb/Makefile.am: Add osversion support. * gdb/mkspec.in: Add osversion support. Add rpmprefix, rpmgroup.
Diffstat (limited to '')
-rw-r--r--scripts/gcc3newlib/Makefile.am74
1 files changed, 37 insertions, 37 deletions
diff --git a/scripts/gcc3newlib/Makefile.am b/scripts/gcc3newlib/Makefile.am
index b1e68cfe26..de26cf0048 100644
--- a/scripts/gcc3newlib/Makefile.am
+++ b/scripts/gcc3newlib/Makefile.am
@@ -28,57 +28,57 @@ MKGCCNEWLIBSPEC_DEPS = mkspec gccnewlib.spec.in \
RPM_SPECS_DATA =
-arm-rtems-$(GCC3NEWLIBVERS).spec: $(MKGCCNEWLIBSPEC_DEPS)
- $(MKSPEC) -cfg $(top_builddir)/setup.cache arm-rtems > $@
-RPM_SPECS_DATA += arm-rtems-$(GCC3NEWLIBVERS).spec
+arm-rtems@osversion@-$(GCC3NEWLIBVERS).spec: $(MKGCCNEWLIBSPEC_DEPS)
+ $(MKSPEC) -cfg $(top_builddir)/setup.cache arm-rtems@osversion@ > $@
+RPM_SPECS_DATA += arm-rtems@osversion@-$(GCC3NEWLIBVERS).spec
-c4x-rtems-$(GCC3NEWLIBVERS).spec: $(MKGCCNEWLIBSPEC_DEPS)
- $(MKSPEC) -cfg $(top_builddir)/setup.cache c4x-rtems > $@
-RPM_SPECS_DATA += c4x-rtems-$(GCC3NEWLIBVERS).spec
+c4x-rtems@osversion@-$(GCC3NEWLIBVERS).spec: $(MKGCCNEWLIBSPEC_DEPS)
+ $(MKSPEC) -cfg $(top_builddir)/setup.cache c4x-rtems@osversion@ > $@
+RPM_SPECS_DATA += c4x-rtems@osversion@-$(GCC3NEWLIBVERS).spec
-h8300-rtems-$(GCC3NEWLIBVERS).spec: $(MKGCCNEWLIBSPEC_DEPS)
- $(MKSPEC) -cfg $(top_builddir)/setup.cache h8300-rtems > $@
-RPM_SPECS_DATA += h8300-rtems-$(GCC3NEWLIBVERS).spec
+h8300-rtems@osversion@-$(GCC3NEWLIBVERS).spec: $(MKGCCNEWLIBSPEC_DEPS)
+ $(MKSPEC) -cfg $(top_builddir)/setup.cache h8300-rtems@osversion@ > $@
+RPM_SPECS_DATA += h8300-rtems@osversion@-$(GCC3NEWLIBVERS).spec
-hppa1.1-rtems-$(GCC3NEWLIBVERS).spec: $(MKGCCNEWLIBSPEC_DEPS)
- $(MKSPEC) -cfg $(top_builddir)/setup.cache hppa1.1-rtems > $@
-RPM_SPECS_DATA += hppa1.1-rtems-$(GCC3NEWLIBVERS).spec
+hppa1.1-rtems@osversion@-$(GCC3NEWLIBVERS).spec: $(MKGCCNEWLIBSPEC_DEPS)
+ $(MKSPEC) -cfg $(top_builddir)/setup.cache hppa1.1-rtems@osversion@ > $@
+RPM_SPECS_DATA += hppa1.1-rtems@osversion@-$(GCC3NEWLIBVERS).spec
-i386-rtems-$(GCC3NEWLIBVERS).spec: $(MKGCCNEWLIBSPEC_DEPS)
- $(MKSPEC) -cfg $(top_builddir)/setup.cache i386-rtems > $@
-RPM_SPECS_DATA += i386-rtems-$(GCC3NEWLIBVERS).spec
+i386-rtems@osversion@-$(GCC3NEWLIBVERS).spec: $(MKGCCNEWLIBSPEC_DEPS)
+ $(MKSPEC) -cfg $(top_builddir)/setup.cache i386-rtems@osversion@ > $@
+RPM_SPECS_DATA += i386-rtems@osversion@-$(GCC3NEWLIBVERS).spec
-i960-rtems-$(GCC3NEWLIBVERS).spec: $(MKGCCNEWLIBSPEC_DEPS)
- $(MKSPEC) -cfg $(top_builddir)/setup.cache i960-rtems > $@
-RPM_SPECS_DATA += i960-rtems-$(GCC3NEWLIBVERS).spec
+i960-rtems@osversion@-$(GCC3NEWLIBVERS).spec: $(MKGCCNEWLIBSPEC_DEPS)
+ $(MKSPEC) -cfg $(top_builddir)/setup.cache i960-rtems@osversion@ > $@
+RPM_SPECS_DATA += i960-rtems@osversion@-$(GCC3NEWLIBVERS).spec
-m68k-rtems-$(GCC3NEWLIBVERS).spec: $(MKGCCNEWLIBSPEC_DEPS)
- $(MKSPEC) -cfg $(top_builddir)/setup.cache m68k-rtems > $@
-RPM_SPECS_DATA += m68k-rtems-$(GCC3NEWLIBVERS).spec
+m68k-rtems@osversion@-$(GCC3NEWLIBVERS).spec: $(MKGCCNEWLIBSPEC_DEPS)
+ $(MKSPEC) -cfg $(top_builddir)/setup.cache m68k-rtems@osversion@ > $@
+RPM_SPECS_DATA += m68k-rtems@osversion@-$(GCC3NEWLIBVERS).spec
-mips64orion-rtems-$(GCC3NEWLIBVERS).spec: $(MKGCCNEWLIBSPEC_DEPS)
- $(MKSPEC) -cfg $(top_builddir)/setup.cache mips64orion-rtems > $@
-RPM_SPECS_DATA += mips64orion-rtems-$(GCC3NEWLIBVERS).spec
+mips64orion-rtems@osversion@-$(GCC3NEWLIBVERS).spec: $(MKGCCNEWLIBSPEC_DEPS)
+ $(MKSPEC) -cfg $(top_builddir)/setup.cache mips64orion-rtems@osversion@ > $@
+RPM_SPECS_DATA += mips64orion-rtems@osversion@-$(GCC3NEWLIBVERS).spec
-mips-rtems-$(GCC3NEWLIBVERS).spec: $(MKGCCNEWLIBSPEC_DEPS)
- $(MKSPEC) -cfg $(top_builddir)/setup.cache mips-rtems > $@
-RPM_SPECS_DATA += mips-rtems-$(GCC3NEWLIBVERS).spec
+mips-rtems@osversion@-$(GCC3NEWLIBVERS).spec: $(MKGCCNEWLIBSPEC_DEPS)
+ $(MKSPEC) -cfg $(top_builddir)/setup.cache mips-rtems@osversion@ > $@
+RPM_SPECS_DATA += mips-rtems@osversion@-$(GCC3NEWLIBVERS).spec
-powerpc-rtems-$(GCC3NEWLIBVERS).spec: $(MKGCCNEWLIBSPEC_DEPS)
- $(MKSPEC) -cfg $(top_builddir)/setup.cache powerpc-rtems > $@
-RPM_SPECS_DATA += powerpc-rtems-$(GCC3NEWLIBVERS).spec
+powerpc-rtems@osversion@-$(GCC3NEWLIBVERS).spec: $(MKGCCNEWLIBSPEC_DEPS)
+ $(MKSPEC) -cfg $(top_builddir)/setup.cache powerpc-rtems@osversion@ > $@
+RPM_SPECS_DATA += powerpc-rtems@osversion@-$(GCC3NEWLIBVERS).spec
-sh-rtems-$(GCC3NEWLIBVERS).spec: $(MKGCCNEWLIBSPEC_DEPS)
- $(MKSPEC) -cfg $(top_builddir)/setup.cache sh-rtems > $@
-RPM_SPECS_DATA += sh-rtems-$(GCC3NEWLIBVERS).spec
+sh-rtems@osversion@-$(GCC3NEWLIBVERS).spec: $(MKGCCNEWLIBSPEC_DEPS)
+ $(MKSPEC) -cfg $(top_builddir)/setup.cache sh-rtems@osversion@ > $@
+RPM_SPECS_DATA += sh-rtems@osversion@-$(GCC3NEWLIBVERS).spec
sh-rtemself-$(GCC3NEWLIBVERS).spec: $(MKGCCNEWLIBSPEC_DEPS)
- $(MKSPEC) -cfg $(top_builddir)/setup.cache sh-rtemself > $@
+ $(MKSPEC) -cfg $(top_builddir)/setup.cache sh-rtemself@osversion@ > $@
RPM_SPECS_DATA += sh-rtemself-$(GCC3NEWLIBVERS).spec
-sparc-rtems-$(GCC3NEWLIBVERS).spec: $(MKGCCNEWLIBSPEC_DEPS)
- $(MKSPEC) -cfg $(top_builddir)/setup.cache sparc-rtems > $@
-RPM_SPECS_DATA += sparc-rtems-$(GCC3NEWLIBVERS).spec
+sparc-rtems@osversion@-$(GCC3NEWLIBVERS).spec: $(MKGCCNEWLIBSPEC_DEPS)
+ $(MKSPEC) -cfg $(top_builddir)/setup.cache sparc-rtems@osversion@ > $@
+RPM_SPECS_DATA += sparc-rtems@osversion@-$(GCC3NEWLIBVERS).spec
CLEANFILES += $(RPM_SPECS_DATA)