summaryrefslogtreecommitdiffstats
path: root/scripts/cpukit/Makefile.am
diff options
context:
space:
mode:
authorRalf Corsepius <ralf.corsepius@rtems.org>2002-07-29 07:40:53 +0000
committerRalf Corsepius <ralf.corsepius@rtems.org>2002-07-29 07:40:53 +0000
commit620c972cf16a22dd3cb92e7ae127e915869df79b (patch)
tree0e5c5267aa98525385777ee5d4ee2193db131132 /scripts/cpukit/Makefile.am
parent2002-07-27 Ralf Corsepius <corsepiu@faw.uni-ulm.de> (diff)
downloadrtems-620c972cf16a22dd3cb92e7ae127e915869df79b.tar.bz2
2002-07-29 Ralf Corsepius <corsepiu@faw.uni-ulm.de>
* ChangeLog: Fix 2002-07-22 ChangeLog entry bogusly referring to Joel. * cpukit/Makefile.am: New. * cpukit/mkspec.in: New. * cpukit/rtems-cpukit.spec.in: New. * cpukit/.cvsignore: New. * configure.ac: Add cpukit. Add RTEMS_TOP to pickup _RTEMS_VERSION (required by cpukit). * Makefile.am: Add cpukit. Add ACLOCAL_AMFLAGS (required to pickup RTEMS_VERSION). * setup.def: Use %{_tmppath} as default for $rpm_build_root. * mkbinutilsspec.in: Use ',' as pattern delimiter in sed expression for $rpm_build_root. * mkgccnewlibspec.in: Use ',' as pattern delimiter in sed expression for $rpm_build_root. * mkgcc3newlibspec.in: Use ',' as pattern delimiter in sed expression for $rpm_build_root. * mkgdbspec.in: Use ',' as pattern delimiter in sed expression for $rpm_build_root.
Diffstat (limited to '')
-rw-r--r--scripts/cpukit/Makefile.am66
1 files changed, 66 insertions, 0 deletions
diff --git a/scripts/cpukit/Makefile.am b/scripts/cpukit/Makefile.am
new file mode 100644
index 0000000000..d17f183083
--- /dev/null
+++ b/scripts/cpukit/Makefile.am
@@ -0,0 +1,66 @@
+##
+## $Id$
+##
+
+
+MKSPEC = $(SHELL) ./mkspec
+
+MKSPEC_DEPS = mkspec rtems-cpukit.spec.in \
+ $(top_builddir)/setup.cache
+
+c4x-rtems-cpukit.spec: $(MKSPEC_DEPS)
+ $(MKSPEC) -cfg $(top_builddir)/setup.cache -o . c4x-rtems > $@
+RPM_SPECS_DATA = c4x-rtems-cpukit.spec
+
+hppa1.1-rtems-cpukit.spec: $(MKSPEC_DEPS)
+ $(MKSPEC) -cfg $(top_builddir)/setup.cache -o . hppa1.1-rtems > $@
+RPM_SPECS_DATA += hppa1.1-rtems-cpukit.spec
+
+h8300-rtems-cpukit.spec: $(MKSPEC_DEPS)
+ $(MKSPEC) -cfg $(top_builddir)/setup.cache -o . h8300-rtems > $@
+RPM_SPECS_DATA += h8300-rtems-cpukit.spec
+
+i386-rtems-cpukit.spec: $(MKSPEC_DEPS)
+ $(MKSPEC) -cfg $(top_builddir)/setup.cache -o . i386-rtems > $@
+RPM_SPECS_DATA += i386-rtems-cpukit.spec
+
+i960-rtems-cpukit.spec: $(MKSPEC_DEPS)
+ $(MKSPEC) -cfg $(top_builddir)/setup.cache -o . i960-rtems > $@
+RPM_SPECS_DATA += i960-rtems-cpukit.spec
+
+m68k-rtems-cpukit.spec: $(MKSPEC_DEPS)
+ $(MKSPEC) -cfg $(top_builddir)/setup.cache -o . m68k-rtems > $@
+RPM_SPECS_DATA += m68k-rtems-cpukit.spec
+
+mips64orion-rtems-cpukit.spec: $(MKSPEC_DEPS)
+ $(MKSPEC) -cfg $(top_builddir)/setup.cache -o . mips64orion-rtems > $@
+RPM_SPECS_DATA += mips64orion-rtems-cpukit.spec
+
+mips-rtems-cpukit.spec: $(MKSPEC_DEPS)
+ $(MKSPEC) -cfg $(top_builddir)/setup.cache -o . mips-rtems > $@
+RPM_SPECS_DATA += mips-rtems-cpukit.spec
+
+powerpc-rtems-cpukit.spec: $(MKSPEC_DEPS)
+ $(MKSPEC) -cfg $(top_builddir)/setup.cache -o . powerpc-rtems > $@
+RPM_SPECS_DATA += powerpc-rtems-cpukit.spec
+
+sh-rtems-cpukit.spec: $(MKSPEC_DEPS)
+ $(MKSPEC) -cfg $(top_builddir)/setup.cache -o . sh-rtems > $@
+RPM_SPECS_DATA += sh-rtems-cpukit.spec
+
+sh-rtemself-cpukit.spec: $(MKSPEC_DEPS)
+ $(MKSPEC) -cfg $(top_builddir)/setup.cache -o . sh-rtemself > $@
+RPM_SPECS_DATA += sh-rtemself-cpukit.spec
+
+sparc-rtems-cpukit.spec: $(MKSPEC_DEPS)
+ $(MKSPEC) -cfg $(top_builddir)/setup.cache -o . sparc-rtems > $@
+RPM_SPECS_DATA += sparc-rtems-cpukit.spec
+
+TEMPLATES = rtems-cpukit.spec.in
+
+noinst_DATA = $(TEMPLATES)
+
+EXTRA_DIST = $(TEMPLATES)
+
+CLEANFILES = $(RPM_SPECS_DATA)
+include $(top_srcdir)/../automake/local.am