summaryrefslogtreecommitdiffstats
path: root/scripts/cpukit/Makefile.am
diff options
context:
space:
mode:
authorRalf Corsepius <ralf.corsepius@rtems.org>2003-10-07 08:53:29 +0000
committerRalf Corsepius <ralf.corsepius@rtems.org>2003-10-07 08:53:29 +0000
commit06e70cd9c1894aded0bffa640e1f175b24f215e1 (patch)
tree0f92b796cd323d49b479a70cd649be5f2dcaf7fa /scripts/cpukit/Makefile.am
parent2003-10-07 Ralf Corsepius <corsepiu@faw.uni-ulm.de> (diff)
downloadrtems-06e70cd9c1894aded0bffa640e1f175b24f215e1.tar.bz2
2003-10-07 Ralf Corsepius <corsepiu@faw.uni-ulm.de>
* cpukit/target-cpukit.add: New. * cpukit/Makefile.am: Reflect having added target-cpukit.add. Acknowledge osversion. * cpukit/mkspec.in: Acknowledge osversion and rpmgroup. * cpukit/rtems-cpukit.add: Reflect new RTEMS spec conventions.
Diffstat (limited to '')
-rw-r--r--scripts/cpukit/Makefile.am67
1 files changed, 34 insertions, 33 deletions
diff --git a/scripts/cpukit/Makefile.am b/scripts/cpukit/Makefile.am
index 3b2100203a..29a82707d2 100644
--- a/scripts/cpukit/Makefile.am
+++ b/scripts/cpukit/Makefile.am
@@ -10,6 +10,7 @@ SUBPACKAGES = header.add
SUBPACKAGES += $(top_builddir)/common/common.add
SUBPACKAGES += rtems-cpukit.add
SUBPACKAGES += $(top_builddir)/common/clean.add
+SUBPACKAGES += target-cpukit.add
MKSPEC_DEPS = mkspec rtems-cpukit.spec.in \
$(top_builddir)/setup.cache
@@ -18,49 +19,49 @@ rtems-cpukit.spec.in: $(SUBPACKAGES)
cat $^ > $@
CLEANFILES = rtems-cpukit.spec.in
-c4x-rtems-cpukit.spec: $(MKSPEC_DEPS)
- $(MKSPEC) -cfg $(top_builddir)/setup.cache -o . c4x-rtems > $@
-RPM_SPECS_DATA = c4x-rtems-cpukit.spec
+c4x-rtems@osversion@-cpukit.spec: $(MKSPEC_DEPS)
+ $(MKSPEC) -cfg $(top_builddir)/setup.cache -o . c4x-rtems@osversion@ > $@
+RPM_SPECS_DATA = c4x-rtems@osversion@-cpukit.spec
-h8300-rtems-cpukit.spec: $(MKSPEC_DEPS)
- $(MKSPEC) -cfg $(top_builddir)/setup.cache -o . h8300-rtems > $@
-RPM_SPECS_DATA += h8300-rtems-cpukit.spec
+h8300-rtems@osversion@-cpukit.spec: $(MKSPEC_DEPS)
+ $(MKSPEC) -cfg $(top_builddir)/setup.cache -o . h8300-rtems@osversion@ > $@
+RPM_SPECS_DATA += h8300-rtems@osversion@-cpukit.spec
-i386-rtems-cpukit.spec: $(MKSPEC_DEPS)
- $(MKSPEC) -cfg $(top_builddir)/setup.cache -o . i386-rtems > $@
-RPM_SPECS_DATA += i386-rtems-cpukit.spec
+i386-rtems@osversion@-cpukit.spec: $(MKSPEC_DEPS)
+ $(MKSPEC) -cfg $(top_builddir)/setup.cache -o . i386-rtems@osversion@ > $@
+RPM_SPECS_DATA += i386-rtems@osversion@-cpukit.spec
-i960-rtems-cpukit.spec: $(MKSPEC_DEPS)
- $(MKSPEC) -cfg $(top_builddir)/setup.cache -o . i960-rtems > $@
-RPM_SPECS_DATA += i960-rtems-cpukit.spec
+i960-rtems@osversion@-cpukit.spec: $(MKSPEC_DEPS)
+ $(MKSPEC) -cfg $(top_builddir)/setup.cache -o . i960-rtems@osversion@ > $@
+RPM_SPECS_DATA += i960-rtems@osversion@-cpukit.spec
-m68k-rtems-cpukit.spec: $(MKSPEC_DEPS)
- $(MKSPEC) -cfg $(top_builddir)/setup.cache -o . m68k-rtems > $@
-RPM_SPECS_DATA += m68k-rtems-cpukit.spec
+m68k-rtems@osversion@-cpukit.spec: $(MKSPEC_DEPS)
+ $(MKSPEC) -cfg $(top_builddir)/setup.cache -o . m68k-rtems@osversion@ > $@
+RPM_SPECS_DATA += m68k-rtems@osversion@-cpukit.spec
-mips64orion-rtems-cpukit.spec: $(MKSPEC_DEPS)
- $(MKSPEC) -cfg $(top_builddir)/setup.cache -o . mips64orion-rtems > $@
-RPM_SPECS_DATA += mips64orion-rtems-cpukit.spec
+mips64orion-rtems@osversion@-cpukit.spec: $(MKSPEC_DEPS)
+ $(MKSPEC) -cfg $(top_builddir)/setup.cache -o . mips64orion-rtems@osversion@ > $@
+RPM_SPECS_DATA += mips64orion-rtems@osversion@-cpukit.spec
-mips-rtems-cpukit.spec: $(MKSPEC_DEPS)
- $(MKSPEC) -cfg $(top_builddir)/setup.cache -o . mips-rtems > $@
-RPM_SPECS_DATA += mips-rtems-cpukit.spec
+mips-rtems@osversion@-cpukit.spec: $(MKSPEC_DEPS)
+ $(MKSPEC) -cfg $(top_builddir)/setup.cache -o . mips-rtems@osversion@ > $@
+RPM_SPECS_DATA += mips-rtems@osversion@-cpukit.spec
-powerpc-rtems-cpukit.spec: $(MKSPEC_DEPS)
- $(MKSPEC) -cfg $(top_builddir)/setup.cache -o . powerpc-rtems > $@
-RPM_SPECS_DATA += powerpc-rtems-cpukit.spec
+powerpc-rtems@osversion@-cpukit.spec: $(MKSPEC_DEPS)
+ $(MKSPEC) -cfg $(top_builddir)/setup.cache -o . powerpc-rtems@osversion@ > $@
+RPM_SPECS_DATA += powerpc-rtems@osversion@-cpukit.spec
-sh-rtems-cpukit.spec: $(MKSPEC_DEPS)
- $(MKSPEC) -cfg $(top_builddir)/setup.cache -o . sh-rtems > $@
-RPM_SPECS_DATA += sh-rtems-cpukit.spec
+sh-rtems@osversion@-cpukit.spec: $(MKSPEC_DEPS)
+ $(MKSPEC) -cfg $(top_builddir)/setup.cache -o . sh-rtems@osversion@ > $@
+RPM_SPECS_DATA += sh-rtems@osversion@-cpukit.spec
-sh-rtemself-cpukit.spec: $(MKSPEC_DEPS)
- $(MKSPEC) -cfg $(top_builddir)/setup.cache -o . sh-rtemself > $@
-RPM_SPECS_DATA += sh-rtemself-cpukit.spec
+sh-rtemself@osversion@-cpukit.spec: $(MKSPEC_DEPS)
+ $(MKSPEC) -cfg $(top_builddir)/setup.cache -o . sh-rtemself@osversion@ > $@
+RPM_SPECS_DATA += sh-rtemself@osversion@-cpukit.spec
-sparc-rtems-cpukit.spec: $(MKSPEC_DEPS)
- $(MKSPEC) -cfg $(top_builddir)/setup.cache -o . sparc-rtems > $@
-RPM_SPECS_DATA += sparc-rtems-cpukit.spec
+sparc-rtems@osversion@-cpukit.spec: $(MKSPEC_DEPS)
+ $(MKSPEC) -cfg $(top_builddir)/setup.cache -o . sparc-rtems@osversion@ > $@
+RPM_SPECS_DATA += sparc-rtems@osversion@-cpukit.spec
EXTRA_DIST = $(SUBPACKAGES)