summaryrefslogtreecommitdiffstats
path: root/scripts/configure.in
diff options
context:
space:
mode:
authorJoel Sherrill <joel.sherrill@OARcorp.com>2000-11-09 16:51:47 +0000
committerJoel Sherrill <joel.sherrill@OARcorp.com>2000-11-09 16:51:47 +0000
commitbd914b46500b26093b23aa5c6d9710ec4acbccc2 (patch)
tree0d6c08caea3f3cdf08aad7d3bc3bedfe7a2a4bc5 /scripts/configure.in
parent2000-11-09 Ralf Corsepius <corsepiu@faw.uni-ulm.de> (diff)
downloadrtems-bd914b46500b26093b23aa5c6d9710ec4acbccc2.tar.bz2
2000-11-05 Ralf Corsepius <corsepiu@faw.uni-ulm.de>
* configure.in: Adapt m4-quoting to autoconf-2.49b, use $host instead of $target to setup RPM_CPU, move chmod 755 buildall to AC_OUTPUT's extra-cmds.
Diffstat (limited to 'scripts/configure.in')
-rw-r--r--scripts/configure.in11
1 files changed, 5 insertions, 6 deletions
diff --git a/scripts/configure.in b/scripts/configure.in
index b54d87c707..af2b918ecf 100644
--- a/scripts/configure.in
+++ b/scripts/configure.in
@@ -1,6 +1,7 @@
## $Id$
AC_INIT(binutils)
+
AM_INIT_AUTOMAKE(rtems-scripts,20000610-0,no)
AC_EXEEXT
@@ -34,16 +35,14 @@ AC_SUBST(RPM_SPECSdir)
AC_CANONICAL_HOST
AC_MSG_CHECKING(for RPM CPU type)
-changequote(,)dnl
case "${host}" in
- i[34567]86-*linux*) RPM_CPU=i386 ;;
- i[34567]86-pc-cygwin*) RPM_CPU=i386 ;;
+ i[[34567]]86-*linux*) RPM_CPU=i386 ;;
+ i[[34567]]86-pc-cygwin*) RPM_CPU=i386 ;;
sparc-sun-solaris*) RPM_CPU=sparc ;;
*)
- AC_MSG_ERROR(RPM CPU for ${target} is unknown)
+ AC_MSG_ERROR([RPM CPU for ${host} is unknown])
;;
esac
-changequote([,])dnl
AC_MSG_RESULT($RPM_CPU)
GCCNEWLIBVERS="gcc-${gcc_version}-newlib-${newlib_version}"
@@ -67,6 +66,6 @@ mkbspspec
binutils/Makefile
gccnewlib/Makefile
gdb/Makefile
-rtems/Makefile,,
+rtems/Makefile,
chmod 755 buildall
)