summaryrefslogtreecommitdiffstats
path: root/scripts/configure.in
diff options
context:
space:
mode:
authorJoel Sherrill <joel.sherrill@OARcorp.com>1999-10-20 15:29:12 +0000
committerJoel Sherrill <joel.sherrill@OARcorp.com>1999-10-20 15:29:12 +0000
commit10629f743599b259f03b74a376cf71f321469e0c (patch)
tree4b67b2b2b9a447bdd4613f96cd10649098c412b0 /scripts/configure.in
parentCommitting changes before Ralf's changed. (diff)
downloadrtems-10629f743599b259f03b74a376cf71f321469e0c.tar.bz2
New version from Ralf.
Diffstat (limited to 'scripts/configure.in')
-rw-r--r--scripts/configure.in40
1 files changed, 40 insertions, 0 deletions
diff --git a/scripts/configure.in b/scripts/configure.in
new file mode 100644
index 0000000000..551f039281
--- /dev/null
+++ b/scripts/configure.in
@@ -0,0 +1,40 @@
+AC_INIT(binutils)
+AM_INIT_AUTOMAKE(scripts,19991020-0,no)
+
+test -f ./setup.cache || cp ./setup.def ./setup.cache
+. ./setup.cache
+
+# Some linux distributions use /usr/src/packages
+# redhat uses /usr/src/redhat
+# others might use /usr/src
+AC_MSG_CHECKING(for rpm SPECS directory)
+if test -d /usr/src/packages/SPECS;
+then
+RPM_SPECSdir=/usr/src/packages/SPECS;
+elif test -d /usr/src/redhat/SPECS;
+then
+RPM_SPECSdirs=/usr/src/redhat/SPECS;
+elif test -d /usr/src/SPECS/;
+then
+RPM_SPECSdir=/usr/src/SPECS;
+fi
+if test x"$RPM_SPECSdir" = x; then
+AC_MSG_ERROR(not found)
+fi
+AC_MSG_RESULT($RPM_SPECSdir)
+AC_SUBST(RPM_SPECSdir)
+
+GCCNEWLIBVERS="gcc-${gcc_version}-newlib-${newlib_version}"
+AC_SUBST(GCCNEWLIBVERS)
+BINUTILSVERS="binutils-${binutils_version}"
+AC_SUBST(BINUTILSVERS)
+GDBVERS="gdb-${gdb_version}"
+AC_SUBST(GDBVERS)
+
+AC_OUTPUT(
+Makefile
+mkbinutilspec
+mkgccnewlibspec
+binutils/Makefile
+gccnewlib/Makefile
+)