summaryrefslogtreecommitdiffstats
path: root/scripts/configure.in
diff options
context:
space:
mode:
authorJoel Sherrill <joel.sherrill@OARcorp.com>2001-05-24 19:58:35 +0000
committerJoel Sherrill <joel.sherrill@OARcorp.com>2001-05-24 19:58:35 +0000
commit01ec6c0c4cc6668ea060e8486724ad01fe403624 (patch)
tree2f3f831d7072b55ba781a88b4f048750414bbe1f /scripts/configure.in
parent2000-05-24 Joel Sherrill <joel@OARcorp.com> (diff)
downloadrtems-01ec6c0c4cc6668ea060e8486724ad01fe403624.tar.bz2
2001-05-15 Ralf Corsepius <corsepiu@faw.uni-ulm.de>
* configure.in: Remove AC_EXEEXT, treat .exe manually. * gccnewlib/base-gcc.add: Remove cpp. * gccnewlib/gccnewlib.add: mv cpp $target_alias-cpp, update copyright.
Diffstat (limited to '')
-rw-r--r--scripts/configure.in24
1 files changed, 16 insertions, 8 deletions
diff --git a/scripts/configure.in b/scripts/configure.in
index af2b918ecf..f2f2cd0cb9 100644
--- a/scripts/configure.in
+++ b/scripts/configure.in
@@ -2,9 +2,19 @@
AC_INIT(binutils)
-AM_INIT_AUTOMAKE(rtems-scripts,20000610-0,no)
+AM_INIT_AUTOMAKE(rtems-scripts,20010516,no)
-AC_EXEEXT
+AC_CANONICAL_HOST
+
+# Check for .exe suffix.
+# With autoconf > 2.13 AC_EXEEXT is not what we want to use.
+AC_MSG_CHECKING([for executable suffix])
+case "$host" in
+i?86-*cygwin*)
+ EXEEXT=.exe ;;
+esac
+AC_SUBST(EXEEXT)
+AC_MSG_RESULT([$EXEEXT])
test -f ./setup.cache || cp ${srcdir}/setup.def ./setup.cache
. ./setup.cache
@@ -32,13 +42,11 @@ fi
AC_MSG_RESULT($RPM_SPECSdir)
AC_SUBST(RPM_SPECSdir)
-AC_CANONICAL_HOST
-
AC_MSG_CHECKING(for RPM CPU type)
-case "${host}" in
- i[[34567]]86-*linux*) RPM_CPU=i386 ;;
- i[[34567]]86-pc-cygwin*) RPM_CPU=i386 ;;
- sparc-sun-solaris*) RPM_CPU=sparc ;;
+case "$host" in
+ i?86-*linux*) RPM_CPU=i386 ;;
+ i?86-*cygwin*) RPM_CPU=i386 ;;
+ sparc-sun-solaris*) RPM_CPU=sparc ;;
*)
AC_MSG_ERROR([RPM CPU for ${host} is unknown])
;;