summaryrefslogtreecommitdiffstats
path: root/scripts/configure.ac
diff options
context:
space:
mode:
authorJoel Sherrill <joel.sherrill@OARcorp.com>2001-10-12 18:47:00 +0000
committerJoel Sherrill <joel.sherrill@OARcorp.com>2001-10-12 18:47:00 +0000
commitd7aecdc8f866b978a4349b0e157f46877f60e414 (patch)
treedf28b2fa6611df7f1003f57447771edb69275761 /scripts/configure.ac
parent2001-10-11 Ralf Corsepius <corsepiu@faw.uni-ulm.de> (diff)
downloadrtems-d7aecdc8f866b978a4349b0e157f46877f60e414.tar.bz2
2001-10-11 Ralf Corsepius <corsepiu@faw.uni-ulm.de>
* .cvsignore: Add autom4te.cache for autoconf > 2.52. * configure.in: Remove.
Diffstat (limited to 'scripts/configure.ac')
-rw-r--r--scripts/configure.ac84
1 files changed, 84 insertions, 0 deletions
diff --git a/scripts/configure.ac b/scripts/configure.ac
new file mode 100644
index 0000000000..2d94ef16bc
--- /dev/null
+++ b/scripts/configure.ac
@@ -0,0 +1,84 @@
+## $Id$
+
+AC_PREREQ(2.52)
+AC_INIT
+AC_CONFIG_SRCDIR([binutils])
+
+AM_INIT_AUTOMAKE(rtems-scripts,20010516,no)
+
+AC_CANONICAL_HOST
+
+# Check for .exe suffix.
+# With autoconf > 2.13 AC_EXEEXT is not what we want to use.
+AC_MSG_CHECKING([for executable suffix])
+case "$host" in
+i?86-*cygwin*)
+ EXEEXT=.exe ;;
+esac
+AC_SUBST(EXEEXT)
+AC_MSG_RESULT([$EXEEXT])
+
+test -f ./setup.cache || cp ${srcdir}/setup.def ./setup.cache
+. ./setup.cache
+
+# Some linux distributions use /usr/src/packages
+# redhat uses /usr/src/redhat
+# others might use /usr/src
+AC_MSG_CHECKING(for rpm SPECS directory)
+if test -d /usr/src/packages/SPECS;
+then
+ RPM_SPECSdir=/usr/src/packages/SPECS;
+elif test -d /usr/src/redhat/SPECS;
+then
+ RPM_SPECSdir=/usr/src/redhat/SPECS;
+elif test -d /usr/src/SPECS;
+then
+ RPM_SPECSdir=/usr/src/SPECS;
+elif test -d /usr/local/src/redhat/SPECS;
+then
+ RPM_SPECSdir=/usr/local/src/redhat/SPECS;
+fi
+if test x"$RPM_SPECSdir" = x"" ; then
+AC_MSG_ERROR(not found)
+fi
+AC_MSG_RESULT($RPM_SPECSdir)
+AC_SUBST(RPM_SPECSdir)
+
+AC_MSG_CHECKING(for RPM CPU type)
+case "$host" in
+ i?86-*linux*) RPM_CPU=i386 ;;
+ i?86-*cygwin*) RPM_CPU=i386 ;;
+ sparc-sun-solaris*) RPM_CPU=sparc ;;
+ *)
+ AC_MSG_ERROR([RPM CPU for ${host} is unknown])
+ ;;
+esac
+AC_MSG_RESULT($RPM_CPU)
+
+GCCNEWLIBVERS="gcc-${gcc_version}-newlib-${newlib_version}"
+AC_SUBST(GCCNEWLIBVERS)
+BINUTILSVERS="binutils-${binutils_version}"
+AC_SUBST(BINUTILSVERS)
+GDBVERS="gdb-${gdb_version}"
+AC_SUBST(GDBVERS)
+BSPVERS="${rtems_version}"
+AC_SUBST(RTEMS_VERSION)
+AC_SUBST(BSPVERS)
+AC_SUBST(RPM_CPU)
+
+AC_CONFIG_FILES([Makefile
+buildall
+buildalltar
+mkbinutilspec
+mkgccnewlibspec
+mkgdbspec
+mkbspspec
+binutils/Makefile
+gccnewlib/Makefile
+gdb/Makefile
+rtems/Makefile
+autotools/Makefile])
+AC_CONFIG_COMMANDS([default],[[chmod 755 buildall
+chmod 755 buildalltar
+]],[[]])
+AC_OUTPUT