summaryrefslogtreecommitdiffstats
path: root/scripts-ada/gdb/Makefile.am
diff options
context:
space:
mode:
authorJoel Sherrill <joel.sherrill@OARcorp.com>2000-01-26 19:56:54 +0000
committerJoel Sherrill <joel.sherrill@OARcorp.com>2000-01-26 19:56:54 +0000
commit64ab2e9eeb87a3ea1c48cea6d74647155f5e0e44 (patch)
tree6fa94e466a217c7bebb855ccd0e52174e5d02c18 /scripts-ada/gdb/Makefile.am
parentNo longer incorrectly references mips. (diff)
downloadrtems-64ab2e9eeb87a3ea1c48cea6d74647155f5e0e44.tar.bz2
First cut at adding RPM scripts for building GNAT/RTEMS RPMs.
Diffstat (limited to 'scripts-ada/gdb/Makefile.am')
-rw-r--r--scripts-ada/gdb/Makefile.am59
1 files changed, 59 insertions, 0 deletions
diff --git a/scripts-ada/gdb/Makefile.am b/scripts-ada/gdb/Makefile.am
new file mode 100644
index 0000000000..74782485cb
--- /dev/null
+++ b/scripts-ada/gdb/Makefile.am
@@ -0,0 +1,59 @@
+AUTOMAKE_OPTIONS = foreign
+
+MKGDBSPEC = $(SHELL) $(top_builddir)/mkgdbspec
+
+MKGDBSPEC_DEPS = \
+$(top_builddir)/mkgdbspec gdb.spec.in $(top_builddir)/setup.cache
+
+hppa1.1-rtems-$(GDBVERS).spec: $(MKGDBSPEC_DEPS)
+ $(MKGDBSPEC) -cfg $(top_builddir)/setup.cache -o . hppa1.1-rtems
+
+i386-rtems-$(GDBVERS).spec: $(MKGDBSPEC_DEPS)
+ $(MKGDBSPEC) -cfg $(top_builddir)/setup.cache -o . i386-rtems
+
+i960-rtems-$(GDBVERS).spec: $(MKGDBSPEC_DEPS)
+ $(MKGDBSPEC) -cfg $(top_builddir)/setup.cache -o . i960-rtems
+
+m68k-rtems-$(GDBVERS).spec: $(MKGDBSPEC_DEPS)
+ $(MKGDBSPEC) -cfg $(top_builddir)/setup.cache -o . m68k-rtems
+
+m68k-rtemself-$(GDBVERS).spec: $(MKGDBSPEC_DEPS)
+ $(MKGDBSPEC) -cfg $(top_builddir)/setup.cache -o . m68k-rtemself
+
+mips64orion-rtems-$(GDBVERS).spec: $(MKGDBSPEC_DEPS)
+ $(MKGDBSPEC) -cfg $(top_builddir)/setup.cache -o . mips64orion-rtems
+
+powerpc-rtems-$(GDBVERS).spec: $(MKGDBSPEC_DEPS)
+ $(MKGDBSPEC) -cfg $(top_builddir)/setup.cache -o . powerpc-rtems
+
+sh-rtems-$(GDBVERS).spec: $(MKGDBSPEC_DEPS)
+ $(MKGDBSPEC) -cfg $(top_builddir)/setup.cache -o . sh-rtems
+
+sh-rtemself-$(GDBVERS).spec: $(MKGDBSPEC_DEPS)
+ $(MKGDBSPEC) -cfg $(top_builddir)/setup.cache -o . sh-rtemself
+
+sparc-rtems-$(GDBVERS).spec: $(MKGDBSPEC_DEPS)
+ $(MKGDBSPEC) -cfg $(top_builddir)/setup.cache -o . sparc-rtems
+
+TEMPLATES = \
+gdb.spec.in
+
+RPM_SPECS_DATA = \
+hppa1.1-rtems-$(GDBVERS).spec \
+i386-rtems-$(GDBVERS).spec \
+i960-rtems-$(GDBVERS).spec \
+m68k-rtems-$(GDBVERS).spec \
+m68k-rtemself-$(GDBVERS).spec \
+mips64orion-rtems-$(GDBVERS).spec \
+powerpc-rtems-$(GDBVERS).spec \
+sh-rtems-$(GDBVERS).spec \
+sh-rtemself-$(GDBVERS).spec \
+sparc-rtems-$(GDBVERS).spec
+
+noinst_DATA = \
+$(TEMPLATES)
+
+EXTRA_DIST = \
+$(TEMPLATES)
+
+CLEANFILES = $(RPM_SPECS_DATA)