summaryrefslogtreecommitdiffstats
path: root/scripts-ada/configure.in
diff options
context:
space:
mode:
authorJoel Sherrill <joel.sherrill@OARcorp.com>2001-09-13 16:35:55 +0000
committerJoel Sherrill <joel.sherrill@OARcorp.com>2001-09-13 16:35:55 +0000
commit1e3f4633a0f54977134a9b803e1737c4eac25cd5 (patch)
tree95c425ab2770177f5820dc7b297c1ad31f415a26 /scripts-ada/configure.in
parent2001-09-13 Joel Sherrill <joel@OARcorp.com> (diff)
downloadrtems-1e3f4633a0f54977134a9b803e1737c4eac25cd5.tar.bz2
2001-09-13 Joel Sherrill <joel@OARcorp.com>
* configure.in: Add RTEMS specific version of EXEEXT test. * mkgdbspec.in, mkgnatnewlibspec.in, gdb/gdb.spec.in, gnatnewlib/gnatnewlib.spec.in: Change to Target_alias to avoid conflicts with new autoconf/automake. * setup, setup.def, mkgnatnewlibspec.in: Add gnat_newlib_patch_version variable. * gnatnewlib/Makefile.am: Add i386-rtemscoff target in attempt to build it.
Diffstat (limited to 'scripts-ada/configure.in')
-rw-r--r--scripts-ada/configure.in10
1 files changed, 9 insertions, 1 deletions
diff --git a/scripts-ada/configure.in b/scripts-ada/configure.in
index 69be27c82b..95233ba2f3 100644
--- a/scripts-ada/configure.in
+++ b/scripts-ada/configure.in
@@ -3,7 +3,15 @@
AC_INIT(binutils)
AM_INIT_AUTOMAKE(rtems-scripts_ada,20000125-0,no)
-AC_EXEEXT
+# Check for .exe suffix.
+# With autoconf > 2.13 AC_EXEEXT is not what we want to use.
+AC_MSG_CHECKING([for executable suffix])
+case "$host" in
+i?86-*cygwin*)
+ EXEEXT=.exe ;;
+esac
+AC_SUBST(EXEEXT)
+AC_MSG_RESULT([$EXEEXT])
test -f ./setup.cache || cp ${srcdir}/setup.def ./setup.cache
. ./setup.cache