summaryrefslogtreecommitdiffstats
path: root/doc/supplements/mips/Makefile.am
diff options
context:
space:
mode:
authorJoel Sherrill <joel.sherrill@OARcorp.com>2002-02-14 22:14:59 +0000
committerJoel Sherrill <joel.sherrill@OARcorp.com>2002-02-14 22:14:59 +0000
commit891d63bdddbd0539f031dd680ef62b3e5249b6b7 (patch)
treee021adc735c5f79b3e9dce6f4b89bdf2e9828b56 /doc/supplements/mips/Makefile.am
parent2002-02-13 Ralf Corsepius <corsepiu@faw.uni-ulm.de> (diff)
downloadrtems-891d63bdddbd0539f031dd680ef62b3e5249b6b7.tar.bz2
2002-02-04 Joel Sherrill <joel@OARcorp.com>
* bsp.t, BSP_TIMES, callconv.t, ChangeLog, cpumodel.t, cputable.t, fatalerr.t, intr_NOTIMES.t, Makefile.am, memmodel.t, mips.texi, preface.texi, stamp-vti, timeBSP.t, version.texi: New files.
Diffstat (limited to 'doc/supplements/mips/Makefile.am')
-rw-r--r--doc/supplements/mips/Makefile.am111
1 files changed, 111 insertions, 0 deletions
diff --git a/doc/supplements/mips/Makefile.am b/doc/supplements/mips/Makefile.am
new file mode 100644
index 0000000000..6715ae8aec
--- /dev/null
+++ b/doc/supplements/mips/Makefile.am
@@ -0,0 +1,111 @@
+#
+# COPYRIGHT (c) 1988-2002.
+# On-Line Applications Research Corporation (OAR).
+# All rights reserved.
+#
+# $Id$
+#
+
+AUTOMAKE_OPTIONS = foreign 1.5
+
+PROJECT = mips
+EDITION = 1
+
+include $(top_srcdir)/project.am
+include $(top_srcdir)/supplements/supplement.am
+
+GENERATED_FILES = cpumodel.texi callconv.texi memmodel.texi intr.texi \
+ fatalerr.texi bsp.texi cputable.texi wksheets.texi timing.texi \
+ timeBSP.texi
+
+COMMON_FILES = $(top_srcdir)/common/setup.texi \
+ $(top_srcdir)/common/cpright.texi $(top_srcdir)/common/timemac.texi
+
+FILES = preface.texi
+
+info_TEXINFOS = mips.texi
+mips_TEXINFOS = $(FILES) $(COMMON_FILES) $(GENERATED_FILES)
+
+#
+# Chapters which get automatic processing
+#
+
+$(srcdir)/cpumodel.texi: cpumodel.t
+ $(BMENU2) -p "Preface" \
+ -u "Top" \
+ -n "Calling Conventions" < $< > $@
+
+$(srcdir)/callconv.texi: callconv.t
+ $(BMENU2) -p "CPU Model Dependent Features Another Optional Feature" \
+ -u "Top" \
+ -n "Memory Model" < $< > $@
+
+$(srcdir)/memmodel.texi: memmodel.t
+ $(BMENU2) -p "Calling Conventions User-Provided Routines" \
+ -u "Top" \
+ -n "Interrupt Processing" < $< > $@
+
+# Interrupt Chapter:
+# 1. Replace Times and Sizes
+# 2. Build Node Structure
+$(srcdir)/intr.texi: intr_NOTIMES.t BSP_TIMES
+ ${REPLACE2} -p $(srcdir)/BSP_TIMES $(srcdir)/intr_NOTIMES.t | \
+ $(BMENU2) -p "Memory Model Flat Memory Model" \
+ -u "Top" \
+ -n "Default Fatal Error Processing" > $@
+
+$(srcdir)/fatalerr.texi: fatalerr.t
+ $(BMENU2) -p "Interrupt Processing Interrupt Stack" \
+ -u "Top" \
+ -n "Board Support Packages" < $< > $@
+
+$(srcdir)/bsp.texi: bsp.t
+ $(BMENU2) -p "Default Fatal Error Processing Default Fatal Error Handler Operations" \
+ -u "Top" \
+ -n "Processor Dependent Information Table" < $< > $@
+
+$(srcdir)/cputable.texi: cputable.t
+ $(BMENU2) -p "Board Support Packages Processor Initialization" \
+ -u "Top" \
+ -n "Memory Requirements" < $< > $@
+
+# Worksheets Chapter:
+# 1. Copy the Shared File
+# 2. Replace Times and Sizes
+# 3. Build Node Structure
+
+$(srcdir)/wksheets.texi: $(top_srcdir)/common/wksheets.t BSP_TIMES
+ ${REPLACE2} -p $(srcdir)/BSP_TIMES \
+ $(top_srcdir)/common/wksheets.t | \
+ $(BMENU2) -p "Processor Dependent Information Table CPU Dependent Information Table" \
+ -u "Top" \
+ -n "Timing Specification" > $@
+
+# Timing Specification Chapter:
+# 1. Copy the Shared File
+# 3. Build Node Structure
+
+$(srcdir)/timing.texi: $(top_srcdir)/common/timing.t
+ $(BMENU2) -p "Memory Requirements RTEMS RAM Workspace Worksheet" \
+ -u "Top" \
+ -n "BSP_FOR_TIMES Timing Data" < $< > $@
+
+# Timing Data for BSP Chapter:
+# 1. Copy the Shared File
+# 2. Replace Times and Sizes
+# 3. Build Node Structure
+
+$(srcdir)/timeBSP.texi: $(top_srcdir)/common/timetbl.t timeBSP.t
+ cat $(srcdir)/timeBSP.t $(top_srcdir)/common/timetbl.t >timeBSP_.t
+ @echo >>timeBSP_.t
+ @echo "@tex" >>timeBSP_.t
+ @echo "\\global\\advance \\smallskipamount by 4pt" >>timeBSP_.t
+ @echo "@end tex" >>timeBSP_.t
+ ${REPLACE2} -p $(srcdir)/BSP_TIMES timeBSP_.t | \
+ $(BMENU2) -p "Timing Specification Terminology" \
+ -u "Top" \
+ -n "Command and Variable Index" > $@
+CLEANFILES += timeBSP_.t
+
+EXTRA_DIST = BSP_TIMES bsp.t callconv.t cpumodel.t cputable.t fatalerr.t \
+ intr_NOTIMES.t memmodel.t timeBSP.t