summaryrefslogtreecommitdiffstats
path: root/doc/started/Makefile.am
diff options
context:
space:
mode:
authorJoel Sherrill <joel.sherrill@OARcorp.com>2000-06-01 15:29:01 +0000
committerJoel Sherrill <joel.sherrill@OARcorp.com>2000-06-01 15:29:01 +0000
commitfc76a6aa19af9606f260993811ac0dee8ec4e886 (patch)
tree039d079cce65ec28746118f177fc9bea2e737b11 /doc/started/Makefile.am
parentPatch from Ralf Corsepius <corsepiu@faw.uni-ulm.de>: (diff)
downloadrtems-fc76a6aa19af9606f260993811ac0dee8ec4e886.tar.bz2
Patch rtemsdoc-4.5.0-rc-8.diff from Ralf Corsepius <corsepiu@faw.uni-ulm.de>.
Ralf's comments follow: Changes: * Enhanced versioning: - Addition of automake's version.texi support - Replacement of rtemsdoc's former versioning support by automake's versioning support (Abandoning RTEMS-UPDATE-* etc.) - Abandoning setup.texi.in - Add EDITION to each documents Makefile.am - version.texi support in project.am - Addition of maintainer mode (currently only used to prevent incorrectly updating timestamps when users touch automake's version.texi timestamp files (stamp-vti)). * Fixing info dir support - Use texinfo's @dircategory and @direntry instead of infos *-DIR-ENTRY - $(infodir)/dir is now correctly set up * Avoid using temporary files - Pipe texts through REPLACE2 into BMENU2 instead of using temporary files. - Abandon using bmenu in favor of bmenu2 (bmenu could be removed now) * Prepare Makefile.ams for building in a separate buildtree - prefix files with $(srcdir) in Makefile.am for files which must be generated inside of the source tree Notes: * rtemsdoc can not yet be build in a separate source-tree, but we are very close to it. * You as the maintainer of this package now should always use --enable-maintainer-mode to configure rtemsdoc.
Diffstat (limited to '')
-rw-r--r--doc/started/Makefile.am65
1 files changed, 33 insertions, 32 deletions
diff --git a/doc/started/Makefile.am b/doc/started/Makefile.am
index f9de292656..e1782be731 100644
--- a/doc/started/Makefile.am
+++ b/doc/started/Makefile.am
@@ -6,67 +6,68 @@
# $Id$
#
-AUTOMAKE_OPTIONS = foreign
+AUTOMAKE_OPTIONS = foreign 1.4
-PROJECT=started
+PROJECT = started
+EDITION = 1
SUBDIRS = pictures
include $(top_srcdir)/project.am
-COMMON_FILES=$(top_srcdir)/common/cpright.texi $(top_builddir)/common/setup.texi
-
-GENERATED_FILES= binaries.texi buildc.texi buildrt.texi gdb.texi intro.texi \
+GENERATED_FILES = binaries.texi buildc.texi buildrt.texi gdb.texi intro.texi \
nt.texi require.texi nextstep.texi sample.texi
-FILES= tversions.texi
+COMMON_FILES = $(top_srcdir)/common/setup.texi $(top_srcdir)/common/cpright.texi
+
+FILES = tversions.texi
info_TEXINFOS = started.texi
started_TEXINFOS = $(FILES) $(COMMON_FILES) $(GENERATED_FILES)
-intro.texi: intro.t tversions.texi
- $(BMENU) -c -p "Top" \
+$(srcdir)/intro.texi: intro.t tversions.texi
+ $(BMENU2) -c -p "Top" \
-u "Top" \
- -n "Requirements" $<
+ -n "Requirements" < $< > $@
-require.texi: require.t tversions.texi
- $(BMENU) -c -p "GCC Mailing Lists" \
+$(srcdir)/require.texi: require.t tversions.texi
+ $(BMENU2) -c -p "GCC Mailing Lists" \
-u "Top" \
- -n "Prebuilt Toolset Executables" $<
+ -n "Prebuilt Toolset Executables" < $< > $@
-binaries.texi: binaries.t tversions.texi
- $(BMENU) -c -p "GNU makeinfo Version Requirements" \
+$(srcdir)/binaries.texi: binaries.t tversions.texi
+ $(BMENU2) -c -p "GNU makeinfo Version Requirements" \
-u "Top" \
- -n "Building the GNU C/C++ Cross Compiler Toolset" $<
+ -n "Building the GNU C/C++ Cross Compiler Toolset" < $< > $@
-buildc.texi: buildc.t tversions.texi
- $(BMENU) -c -p "Removing RPMs" \
+$(srcdir)/buildc.texi: buildc.t tversions.texi
+ $(BMENU2) -c -p "Removing RPMs" \
-u "Top" \
- -n "Building RTEMS" $<
+ -n "Building RTEMS" < $< > $@
-buildrt.texi: buildrt.t tversions.texi
- $(BMENU) -c -p "Error Messages Indicating Configuration Problems" \
+$(srcdir)/buildrt.texi: buildrt.t tversions.texi
+ $(BMENU2) -c -p "Error Messages Indicating Configuration Problems" \
-u "Top" \
- -n "Building the Sample Application" $<
+ -n "Building the Sample Application" < $< > $@
-sample.texi: sample.t tversions.texi
- $(BMENU) -c -p "Using the RTEMS configure Script Directly" \
+$(srcdir)/sample.texi: sample.t tversions.texi
+ $(BMENU2) -c -p "Using the RTEMS configure Script Directly" \
-u "Top" \
- -n "Building the GNU Debugger" $<
+ -n "Building the GNU Debugger" < $< > $@
gdb.texi: gdb.t tversions.texi
- $(BMENU) -c -p "More Information on RTEMS Application Makefiles" \
+ $(BMENU2) -c -p "More Information on RTEMS Application Makefiles" \
-u "Top" \
- -n "Where To Go From Here" $<
+ -n "Where To Go From Here" < $< > $@
-nextstep.texi: nextstep.t tversions.texi
- $(BMENU) -c -p "GDB for DINK32" \
+$(srcdir)/nextstep.texi: nextstep.t tversions.texi
+ $(BMENU2) -c -p "GDB for DINK32" \
-u "Top" \
- -n "Using MS-Windows as a Development Host" $<
+ -n "Using MS-Windows as a Development Host" < $< > $@
-nt.texi: nt.t tversions.texi
- $(BMENU) -c -p "Writing an Application" \
+$(srcdir)/nt.texi: nt.t tversions.texi
+ $(BMENU2) -c -p "Writing an Application" \
-u "Top" \
- -n "" $<
+ -n "" < $< > $@
EXTRA_DIST = *.t