summaryrefslogtreecommitdiffstats
path: root/doc/rtems_gdb/Makefile.am
diff options
context:
space:
mode:
authorJoel Sherrill <joel.sherrill@OARcorp.com>2000-06-01 15:29:01 +0000
committerJoel Sherrill <joel.sherrill@OARcorp.com>2000-06-01 15:29:01 +0000
commitfc76a6aa19af9606f260993811ac0dee8ec4e886 (patch)
tree039d079cce65ec28746118f177fc9bea2e737b11 /doc/rtems_gdb/Makefile.am
parentPatch from Ralf Corsepius <corsepiu@faw.uni-ulm.de>: (diff)
downloadrtems-fc76a6aa19af9606f260993811ac0dee8ec4e886.tar.bz2
Patch rtemsdoc-4.5.0-rc-8.diff from Ralf Corsepius <corsepiu@faw.uni-ulm.de>.
Ralf's comments follow: Changes: * Enhanced versioning: - Addition of automake's version.texi support - Replacement of rtemsdoc's former versioning support by automake's versioning support (Abandoning RTEMS-UPDATE-* etc.) - Abandoning setup.texi.in - Add EDITION to each documents Makefile.am - version.texi support in project.am - Addition of maintainer mode (currently only used to prevent incorrectly updating timestamps when users touch automake's version.texi timestamp files (stamp-vti)). * Fixing info dir support - Use texinfo's @dircategory and @direntry instead of infos *-DIR-ENTRY - $(infodir)/dir is now correctly set up * Avoid using temporary files - Pipe texts through REPLACE2 into BMENU2 instead of using temporary files. - Abandon using bmenu in favor of bmenu2 (bmenu could be removed now) * Prepare Makefile.ams for building in a separate buildtree - prefix files with $(srcdir) in Makefile.am for files which must be generated inside of the source tree Notes: * rtemsdoc can not yet be build in a separate source-tree, but we are very close to it. * You as the maintainer of this package now should always use --enable-maintainer-mode to configure rtemsdoc.
Diffstat (limited to 'doc/rtems_gdb/Makefile.am')
-rw-r--r--doc/rtems_gdb/Makefile.am51
1 files changed, 26 insertions, 25 deletions
diff --git a/doc/rtems_gdb/Makefile.am b/doc/rtems_gdb/Makefile.am
index 78c7c9feaf..782a151b00 100644
--- a/doc/rtems_gdb/Makefile.am
+++ b/doc/rtems_gdb/Makefile.am
@@ -6,54 +6,55 @@
# $Id$
#
-AUTOMAKE_OPTIONS = foreign
+AUTOMAKE_OPTIONS = foreign 1.4
-PROJECT=rtems_gdb
+PROJECT = rtems_gdb
+EDITION = 1
include $(top_srcdir)/project.am
-COMMON_FILES=$(top_srcdir)/common/cpright.texi $(top_builddir)/common/setup.texi
+GENERATED_FILES = intro.texi swarch.texi started.texi commands.texi \
+ trouble.texi example.texi
-GENERATED_FILES= \
- intro.texi swarch.texi started.texi commands.texi trouble.texi example.texi
+COMMON_FILES = $(top_srcdir)/common/setup.texi $(top_srcdir)/common/cpright.texi
-FILES=
+FILES =
info_TEXINFOS = rtems_gdb.texi
-rtems_gdb_TEXINFOS = $(FILES) $(COMMON_FILES) $(GENERATED_FILES)
+rtems_gdb_TEXINFOS = $(FILES) $(COMMON_FILES) $(GENERATED_FILES)
#
# Process Automatically Generated Files
#
-intro.texi: intro.t
- $(BMENU) -p "Top" \
+$(srcdir)/intro.texi: intro.t
+ $(BMENU2) -p "Top" \
-u "Top" \
- -n "Software Architecture" $<
+ -n "Software Architecture" < $< > $@
-swarch.texi: swarch.t
- $(BMENU) -p "Introduction" \
+$(srcdir)/swarch.texi: swarch.t
+ $(BMENU2) -p "Introduction" \
-u "Top" \
- -n "Getting Started" $<
+ -n "Getting Started" < $< > $@
-started.texi: started.t
- $(BMENU) -p "Software Architecture" \
+$(srcdir)/started.texi: started.t
+ $(BMENU2) -p "Software Architecture" \
-u "Top" \
- -n "Commands" $<
+ -n "Commands" < $< > $@
-commands.texi: commands.t
- $(BMENU) -p "Getting Started Attaching To The System" \
+$(srcdir)/commands.texi: commands.t
+ $(BMENU2) -p "Getting Started Attaching To The System" \
-u "Top" \
- -n "Troubleshooting" $<
+ -n "Troubleshooting" < $< > $@
-trouble.texi: trouble.t
- $(BMENU) -p "Commands Thread control" \
+$(srcdir)/trouble.texi: trouble.t
+ $(BMENU2) -p "Commands Thread control" \
-u "Top" \
- -n "Debug Session Example" $<
+ -n "Debug Session Example" < $< > $@
-example.texi: example.t
- $(BMENU) -p "Troubleshooting Debug server not present" \
+$(srcdir)/example.texi: example.t
+ $(BMENU2) -p "Troubleshooting Debug server not present" \
-u "Top" \
- -n "" $<
+ -n "" < $< > $@
EXTRA_DIST = *.t