summaryrefslogtreecommitdiffstats
path: root/doc/posix1003.1/Makefile.am
diff options
context:
space:
mode:
authorJoel Sherrill <joel.sherrill@OARcorp.com>2000-04-26 18:02:26 +0000
committerJoel Sherrill <joel.sherrill@OARcorp.com>2000-04-26 18:02:26 +0000
commit2ba8875a0b268d572ef2a27584d3f845ec1391b0 (patch)
tree70279d7624be264d69e3db5ab15a2af9278be0eb /doc/posix1003.1/Makefile.am
parentMerged changes from 4.5 branch and removed that branch. (diff)
downloadrtems-2ba8875a0b268d572ef2a27584d3f845ec1391b0.tar.bz2
Patch rtemsdoc-4.5.0-rc-0.diff from Ralf Corsepius <corsepiu@faw.uni-ulm.de>
which contains the bulk of converting the documentation tree to automake and GNU conventions. Comments follow: This is the automake port of rtemsdoc. To apply: cvs co rtemsdoc cd rtemsdoc sh cvs-rm.sh patch -p0 < rtemsdoc-4.5.0-rc-0.diff sh cvs-add.sh [Attention: cvs-rm.sh and cvs-add.sh directly modify cvs] Known bugs: 1) src2html is not supported (yet? - Is this supposed to work?) 2) all *.pdf images now are generated on-the-fly, but not yet deleted during "make distclean" 3) All supplements, including the templated ones, get build and installed. 4) Building outside of the source tree is completely untested and very likely does not work. 5) Make [ps|pdf] are not (yet) supported, make [dvi|info] are supported by automake's default texinfo rules. Fixing 2, 3 and 5 is almost trivial and needs to be done. 4) is a matter of testing and tool-properties, for now it is simply untested. General issues: * gif vs jpg vs png. I would recommend to replace all images with pngs to avoid potential copyright issues (gif) or lack in quality (jpg, jpg is good for real world photographs, but extremely poor on artificial images, graphs). * pdf images do net get placed correctly in pdf-documents. * texinfo: We now use a local copy of texinfo-4.0's texinfo.tex in texinfo/texinfo.tex for generating infos. However pdftex's system-wide texinfo.tex and pdftexinfo.tex are used for generating *.dvi, *.ps, *.pdf. * .cvsignore files still missing. * I have renamed the supplements filename not to use c_<supplement>, because automake seems to have problems with it. Notes: * Again, I recommend not to put any generated files into CVS. Here, this comprises some *texi, all *.pdf and many *.html pages. Ie. I recommend to run make maintainer-clean before checking in any files. * To get building started, this should be sufficient: ./bootstrap ./configure cd tools; make; cd .. make info * To make a public tarball: [cvs co ; ./bootstrap] ./configure cd tools; make; cd .. make info [make clean] make dist => This generates a rtems-<version>.tar.gz in the toplevel directory. => Building the tools only is required after a "cvs co", but not in a distribution tarball.
Diffstat (limited to '')
-rw-r--r--doc/posix1003.1/Makefile.am (renamed from doc/posix1003.1/Makefile)90
1 files changed, 28 insertions, 62 deletions
diff --git a/doc/posix1003.1/Makefile b/doc/posix1003.1/Makefile.am
index 2a3a6c3761..6f94255d78 100644
--- a/doc/posix1003.1/Makefile
+++ b/doc/posix1003.1/Makefile.am
@@ -6,139 +6,113 @@
# $Id$
#
-PROJECT=posix1003_1
-
-include ../Make.config
+AUTOMAKE_OPTIONS = foreign
-all: html info ps pdf
+PROJECT=posix1003_1
-dirs:
- $(make-dirs)
+include $(top_srcdir)/project.am
-COMMON_FILES=../common/cpright.texi ../common/setup.texi
+COMMON_FILES=$(top_srcdir)/common/cpright.texi $(top_builddir)/common/setup.texi
GENERATED_FILES=ch01.texi ch02.texi ch03.texi ch04.texi ch05.texi \
ch06.texi ch07.texi ch08.texi ch09.texi ch10.texi \
ch11.texi ch12.texi ch13.texi ch14.texi ch15.texi \
ch16.texi ch17.texi ch18.texi ch19.t ch19.texi
-FILES= $(PROJECT).texi \
- preface.texi $(GENERATED_FILES)
-
-INFOFILES=$(wildcard $(PROJECT) $(PROJECT)-*)
-
-info: dirs $(PROJECT)
- #cp $(wildcard $(PROJECT) $(PROJECT)-*) $(INFO_INSTALL)
- cp $(PROJECT) $(INFO_INSTALL)
-
-$(PROJECT): $(FILES)
- $(MAKEINFO) $(PROJECT).texi
-
-dvi: dirs $(PROJECT).dvi
-ps: dirs $(PROJECT).ps
-pdf: dirs $(PROJECT).pdf
-
-$(PROJECT).pdf: $(FILES)
- $(TEXI2PDF) $(PROJECT).texi
- cp $(PROJECT).pdf $(WWW_INSTALL)/$(PROJECT)
-
-$(PROJECT).ps: $(PROJECT).dvi
- dvips -o $(PROJECT).ps $(PROJECT).dvi
- cp $(PROJECT).ps $(WWW_INSTALL)/$(PROJECT)
+FILES= preface.texi
-$(PROJECT).dvi: $(FILES)
- $(TEXI2DVI) $(PROJECT).texi
- cp $(PROJECT).dvi $(WWW_INSTALL)/$(PROJECT)
+info_TEXINFOS = posix1003_1.texi
+posix1003_1_TEXINFOS = $(FILES) $(COMMON_FILES) $(GENERATED_FILES)
ch01.texi: ch01.t
$(BMENU) -c -p "Preface" \
-u "Top" \
- -n "Terminology and General Requirements" ${*}.t
+ -n "Terminology and General Requirements" $<
ch02.texi: ch02.t
$(BMENU) -c -p "Conformance" \
-u "Top" \
- -n "Process Primitives" ${*}.t
+ -n "Process Primitives" $<
ch03.texi: ch03.t
$(BMENU) -c -p "Execution-Time Symbolic Constants for Portability Specifications" \
-u "Top" \
- -n "Process Environment" ${*}.t
+ -n "Process Environment" $<
ch04.texi: ch04.t
$(BMENU) -c -p "Delay Process Execution" \
-u "Top" \
- -n "Files and Directories" ${*}.t
+ -n "Files and Directories" $<
ch05.texi: ch05.t
$(BMENU) -c -p "Get Configurable System Variables" \
-u "Top" \
- -n "Input and Output Primitives" ${*}.t
+ -n "Input and Output Primitives" $<
ch06.texi: ch06.t
$(BMENU) -c -p "Get Configurable Pathname Variables" \
-u "Top" \
- -n "Device- and Class-Specific Functions" ${*}.t
+ -n "Device- and Class-Specific Functions" $<
ch07.texi: ch07.t
$(BMENU) -c -p " Asynchronous File Synchronization" \
-u "Top" \
- -n "Language-Specific Services for the C Programming Language" ${*}.t
+ -n "Language-Specific Services for the C Programming Language" $<
ch08.texi: ch08.t
$(BMENU) -c -p "Set Foreground Process Group ID" \
-u "Top" \
- -n "System Databases" ${*}.t
+ -n "System Databases" $<
ch09.texi: ch09.t
$(BMENU) -c -p "Pseudo-Random Sequence Generation Functions" \
-u "Top" \
- -n "Data Interchange Format" ${*}.t
+ -n "Data Interchange Format" $<
ch10.texi: ch10.t
$(BMENU) -c -p "User Database Access" \
-u "Top" \
- -n "Synchronization" ${*}.t
+ -n "Synchronization" $<
ch11.texi: ch11.t
$(BMENU) -c -p "Multiple Volumes" \
-u "Top" \
- -n "Memory Management" ${*}.t
+ -n "Memory Management" $<
ch12.texi: ch12.t
$(BMENU) -c -p "Waiting on a Condition" \
-u "Top" \
- -n "Execution Scheduling" ${*}.t
+ -n "Execution Scheduling" $<
ch13.texi: ch13.t
$(BMENU) -c -p "Remove a Shared Memory Object" \
-u "Top" \
- -n "Clocks and Timers" ${*}.t
+ -n "Clocks and Timers" $<
ch14.texi: ch14.t
$(BMENU) -c -p "Change the Priority Ceiling of a Mutex" \
-u "Top" \
- -n "Message Passing" ${*}.t
+ -n "Message Passing" $<
ch15.texi: ch15.t
$(BMENU) -c -p "High Resolution Sleep" \
-u "Top" \
- -n "Thread Management" ${*}.t
+ -n "Thread Management" $<
ch16.texi: ch16.t
$(BMENU) -c -p "Get Message Queue Attributes" \
-u "Top" \
- -n "Thread-Specific Data" ${*}.t
+ -n "Thread-Specific Data" $<
ch17.texi: ch17.t
$(BMENU) -c -p "Dynamic Package Initialization" \
-u "Top" \
- -n "Thread Cancellation" ${*}.t
+ -n "Thread Cancellation" $<
ch18.texi: ch18.t
$(BMENU) -c -p "Thread-Specific Data Key Deletion" \
-u "Top" \
- -n "Compliance Summary" ${*}.t
+ -n "Compliance Summary" $<
ch19.t: ch01.t ch02.t ch03.t ch04.t ch05.t ch06.t ch07.t ch08.t ch09.t \
ch10.t ch11.t ch12.t ch13.t ch14.t ch15.t ch16.t ch17.t ch18.t \
@@ -148,16 +122,8 @@ ch19.t: ch01.t ch02.t ch03.t ch04.t ch05.t ch06.t ch07.t ch08.t ch09.t \
ch19.texi: ch19.t
$(BMENU) -c -p "List of Cancellation Points" \
-u "Top" \
- -n "Command and Variable Index" ${*}.t
-
-html: dirs $(FILES)
- -mkdir -p $(WWW_INSTALL)/$(PROJECT)
- $(TEXI2WWW) $(TEXI2WWW_ARGS) -dir $(WWW_INSTALL)/$(PROJECT) \
- $(PROJECT).texi
+ -n "Command and Variable Index" $<
-clean:
- rm -f *.o $(PROG) *.txt core $(PROJECT).pdf
- rm -f *.dvi *.ps *.log *.aux *.cp *.fn *.ky *.pg *.toc *.tp *.vr $(BASE)
- rm -f $(PROJECT) $(PROJECT)-* $(GENERATED_FILES)
- rm -f *.fixed _*
+noinst_SCRIPTS = summarize
+EXTRA_DIST = *.t compliance_list summarize