summaryrefslogtreecommitdiffstats
path: root/doc/posix1003.1/Makefile.am
diff options
context:
space:
mode:
authorJoel Sherrill <joel.sherrill@OARcorp.com>2000-06-10 19:41:09 +0000
committerJoel Sherrill <joel.sherrill@OARcorp.com>2000-06-10 19:41:09 +0000
commit110445cba5510f44c0fbd2ff13d7126459c188c6 (patch)
tree9a60f84af1b4e63d04d3af31f99066767ed241fa /doc/posix1003.1/Makefile.am
parentRemoved old bmenu version. (diff)
downloadrtems-110445cba5510f44c0fbd2ff13d7126459c188c6.tar.bz2
Patch rtems-rc-4.5.0-21.diff from Ralf Corsepius <corsepiu@faw.uni-ulm.de>
which splits the current monolithic specs files into a sequence of subparts. These can be concatenated togather to make a the whole .spec file. This cleans up the maintenance problem of having "all languages" and a "C/C++ only" gccnewlib spec files. Plus it should make it easier to produce variants like the gdb-m68k-bdm which require special hackery. :) Ralf's comments: It addresses the way *.spec.in get composed inside of the source tree. Changes: * Each spec.in is broken into several files (*.add), one *.add file per sub-package. * Each Makefile.am composes spec.ins from the *.add files * Removal of redundant automake support files. * Default value for BuildRoot changed to /tmp/<spec-file-name> * %clean stage added to *specs Advantages (IMHO). * The *.add files are easier to adminstrate and more flexible in comparison to the former *.specs.ins. * gccnewlib_c_only.spec.in now is composed from the same sources as gccnewlib.spec.in (less errors) * If using the default BuildRoot --clean now deletes all files that were generated while building. Notes: * rtems.spec.in has not yet been adapted to the scheme used for the other *spec.ins * Except for cosmetical changes the internals of the *.spec files should not have changed. To Apply: cvs rm -f scripts/binutils/binutils.spec.in cvs rm -f scripts/gccnewlib/gccnewlib.spec.in cvs rm -f scripts/gccnewlib/gccnewlib_c_only.spec.in cvs rm -f scripts/gdb/gdb.spec.in cvs rm -f scripts/config.sub cvs rm -f scripts/config.guess cvs rm -f scripts/install-sh cvs rm -f scripts/mkinstalldirs cvs rm -f scripts/missing patch -p1 < rtems-rc-4.5.0-21.diff cvs add scripts/*/*.add cvs add scripts/*/README
Diffstat (limited to 'doc/posix1003.1/Makefile.am')
-rw-r--r--doc/posix1003.1/Makefile.am13
1 files changed, 8 insertions, 5 deletions
diff --git a/doc/posix1003.1/Makefile.am b/doc/posix1003.1/Makefile.am
index cceafb6dfe..f36a0af20c 100644
--- a/doc/posix1003.1/Makefile.am
+++ b/doc/posix1003.1/Makefile.am
@@ -18,7 +18,8 @@ GENERATED_FILES = ch01.texi ch02.texi ch03.texi ch04.texi ch05.texi \
ch13.texi ch14.texi ch15.texi ch16.texi ch17.texi ch18.texi ch19.t \
ch19.texi
-COMMON_FILES = $(top_srcdir)/common/setup.texi $(top_srcdir)/common/cpright.texi
+COMMON_FILES = $(top_srcdir)/common/setup.texi \
+ $(top_srcdir)/common/cpright.texi
FILES = preface.texi
@@ -115,10 +116,10 @@ $(srcdir)/ch18.texi: ch18.t
-u "Top" \
-n "Compliance Summary" < $< > $@
-ch19.t: ch01.t ch02.t ch03.t ch04.t ch05.t ch06.t ch07.t ch08.t ch09.t \
- ch10.t ch11.t ch12.t ch13.t ch14.t ch15.t ch16.t ch17.t ch18.t \
+$(srcdir)/ch19.t: ch01.t ch02.t ch03.t ch04.t ch05.t ch06.t ch07.t ch08.t \
+ ch09.t ch10.t ch11.t ch12.t ch13.t ch14.t ch15.t ch16.t ch17.t ch18.t \
summarize
- ./summarize >ch19.t
+ (cd $(srcdir) && ./summarize > $@)
$(srcdir)/ch19.texi: ch19.t
$(BMENU2) -c -p "List of Cancellation Points" \
@@ -127,4 +128,6 @@ $(srcdir)/ch19.texi: ch19.t
noinst_SCRIPTS = summarize
-EXTRA_DIST = *.t compliance_list summarize
+EXTRA_DIST = ch01.t ch02.t ch03.t ch04.t ch05.t ch06.t ch07.t ch08.t ch09.t \
+ ch10.t ch11.t ch12.t ch13.t ch14.t ch15.t ch16.t ch17.t ch18.t ch19.t \
+ compliance_list summarize