summaryrefslogtreecommitdiffstats
path: root/doc/new_chapters/Makefile.am
diff options
context:
space:
mode:
authorJoel Sherrill <joel.sherrill@OARcorp.com>2000-06-01 15:29:01 +0000
committerJoel Sherrill <joel.sherrill@OARcorp.com>2000-06-01 15:29:01 +0000
commitfc76a6aa19af9606f260993811ac0dee8ec4e886 (patch)
tree039d079cce65ec28746118f177fc9bea2e737b11 /doc/new_chapters/Makefile.am
parentPatch from Ralf Corsepius <corsepiu@faw.uni-ulm.de>: (diff)
downloadrtems-fc76a6aa19af9606f260993811ac0dee8ec4e886.tar.bz2
Patch rtemsdoc-4.5.0-rc-8.diff from Ralf Corsepius <corsepiu@faw.uni-ulm.de>.
Ralf's comments follow: Changes: * Enhanced versioning: - Addition of automake's version.texi support - Replacement of rtemsdoc's former versioning support by automake's versioning support (Abandoning RTEMS-UPDATE-* etc.) - Abandoning setup.texi.in - Add EDITION to each documents Makefile.am - version.texi support in project.am - Addition of maintainer mode (currently only used to prevent incorrectly updating timestamps when users touch automake's version.texi timestamp files (stamp-vti)). * Fixing info dir support - Use texinfo's @dircategory and @direntry instead of infos *-DIR-ENTRY - $(infodir)/dir is now correctly set up * Avoid using temporary files - Pipe texts through REPLACE2 into BMENU2 instead of using temporary files. - Abandon using bmenu in favor of bmenu2 (bmenu could be removed now) * Prepare Makefile.ams for building in a separate buildtree - prefix files with $(srcdir) in Makefile.am for files which must be generated inside of the source tree Notes: * rtemsdoc can not yet be build in a separate source-tree, but we are very close to it. * You as the maintainer of this package now should always use --enable-maintainer-mode to configure rtemsdoc.
Diffstat (limited to '')
-rw-r--r--doc/new_chapters/Makefile.am73
1 files changed, 36 insertions, 37 deletions
diff --git a/doc/new_chapters/Makefile.am b/doc/new_chapters/Makefile.am
index faeb5e5a21..cf71a0a68e 100644
--- a/doc/new_chapters/Makefile.am
+++ b/doc/new_chapters/Makefile.am
@@ -6,70 +6,69 @@
# $Id$
#
-AUTOMAKE_OPTIONS = foreign
+AUTOMAKE_OPTIONS = foreign 1.4
-PROJECT=new_chapters
+PROJECT = new_chapters
+EDITION = 1
include $(top_srcdir)/project.am
-COMMON_FILES=$(top_srcdir)/common/cpright.texi
+GENERATED_FILES = adminiface.texi confspace.texi dumpcontrol.texi \
+ eventlog.texi stackchk.texi rtmonuse.texi cpuuse.texi error.texi \
+ monitor.texi
-GENERATED_FILES= \
- adminiface.texi confspace.texi \
- dumpcontrol.texi eventlog.texi \
- stackchk.texi rtmonuse.texi cpuuse.texi error.texi monitor.texi
+COMMON_FILES = $(top_srcdir)/common/setup.texi $(top_srcdir)/common/cpright.texi
-FILES=
+FILES =
info_TEXINFOS = new_chapters.texi
-new_chapters_TEXINFOS = $(FILES) $(COMMON_FILES) $(GENERATED_FILES)
+new_chapters_TEXINFOS = $(FILES) $(COMMON_FILES) $(GENERATED_FILES)
-eventlog.texi: eventlog.t
- $(BMENU) -p "" \
+$(srcdir)/eventlog.texi: eventlog.t
+ $(BMENU2) -p "" \
-u "Top" \
- -n "" $<
+ -n "" < $< > $@
-dumpcontrol.texi: dumpcontrol.t
- $(BMENU) -p "" \
+$(srcdir)/dumpcontrol.texi: dumpcontrol.t
+ $(BMENU2) -p "" \
-u "Top" \
- -n "" $<
+ -n "" < $< > $@
-confspace.texi: confspace.t
- $(BMENU) -p "" \
+$(srcdir)/confspace.texi: confspace.t
+ $(BMENU2) -p "" \
-u "Top" \
- -n "" $<
+ -n "" < $< > $@
-adminiface.texi: adminiface.t
- $(BMENU) -p "" \
+$(srcdir)/adminiface.texi: adminiface.t
+ $(BMENU2) -p "" \
-u "Top" \
- -n "" $<
+ -n "" < $< > $@
-stackchk.texi: stackchk.t
- $(BMENU) -p "" \
+$(srcdir)/stackchk.texi: stackchk.t
+ $(BMENU2) -p "" \
-u "Top" \
- -n "" $<
+ -n "" < $< > $@
-rtmonuse.texi: rtmonuse.t
- $(BMENU) -p "" \
+$(srcdir)/rtmonuse.texi: rtmonuse.t
+ $(BMENU2) -p "" \
-u "Top" \
- -n "" $<
+ -n "" < $< > $@
-cpuuse.texi: cpuuse.t
- $(BMENU) -p "" \
+$(srcdir)/cpuuse.texi: cpuuse.t
+ $(BMENU2) -p "" \
-u "Top" \
- -n "" $<
+ -n "" < $< > $@
-error.texi: error.t
- $(BMENU) -p "" \
+$(srcdir)/error.texi: error.t
+ $(BMENU2) -p "" \
-u "Top" \
- -n "" $<
+ -n "" < $< > $@
-monitor.texi: monitor.t
- $(BMENU) -p "" \
+$(srcdir)/monitor.texi: monitor.t
+ $(BMENU2) -p "" \
-u "Top" \
- -n "" $<
+ -n "" < $< > $@
noinst_SCRIPTS = gen_section
EXTRA_DIST = *.t STATUS TODO $(noinst_SCRIPTS)
- \ No newline at end of file