summaryrefslogtreecommitdiffstats
path: root/doc/networking/Makefile.am
diff options
context:
space:
mode:
authorJoel Sherrill <joel.sherrill@OARcorp.com>2000-06-01 15:29:01 +0000
committerJoel Sherrill <joel.sherrill@OARcorp.com>2000-06-01 15:29:01 +0000
commitfc76a6aa19af9606f260993811ac0dee8ec4e886 (patch)
tree039d079cce65ec28746118f177fc9bea2e737b11 /doc/networking/Makefile.am
parentPatch from Ralf Corsepius <corsepiu@faw.uni-ulm.de>: (diff)
downloadrtems-fc76a6aa19af9606f260993811ac0dee8ec4e886.tar.bz2
Patch rtemsdoc-4.5.0-rc-8.diff from Ralf Corsepius <corsepiu@faw.uni-ulm.de>.
Ralf's comments follow: Changes: * Enhanced versioning: - Addition of automake's version.texi support - Replacement of rtemsdoc's former versioning support by automake's versioning support (Abandoning RTEMS-UPDATE-* etc.) - Abandoning setup.texi.in - Add EDITION to each documents Makefile.am - version.texi support in project.am - Addition of maintainer mode (currently only used to prevent incorrectly updating timestamps when users touch automake's version.texi timestamp files (stamp-vti)). * Fixing info dir support - Use texinfo's @dircategory and @direntry instead of infos *-DIR-ENTRY - $(infodir)/dir is now correctly set up * Avoid using temporary files - Pipe texts through REPLACE2 into BMENU2 instead of using temporary files. - Abandon using bmenu in favor of bmenu2 (bmenu could be removed now) * Prepare Makefile.ams for building in a separate buildtree - prefix files with $(srcdir) in Makefile.am for files which must be generated inside of the source tree Notes: * rtemsdoc can not yet be build in a separate source-tree, but we are very close to it. * You as the maintainer of this package now should always use --enable-maintainer-mode to configure rtemsdoc.
Diffstat (limited to 'doc/networking/Makefile.am')
-rw-r--r--doc/networking/Makefile.am59
1 files changed, 28 insertions, 31 deletions
diff --git a/doc/networking/Makefile.am b/doc/networking/Makefile.am
index cb818dd7b1..5843f2bc06 100644
--- a/doc/networking/Makefile.am
+++ b/doc/networking/Makefile.am
@@ -6,21 +6,20 @@
# $Id$
#
-AUTOMAKE_OPTIONS = foreign
-
-PROJECT=networking
+AUTOMAKE_OPTIONS = foreign 1.4
+PROJECT = networking
+EDITION = 1
include $(top_srcdir)/project.am
-# FIXME: Why -c ?
-BMENU+= -c
+BMENU2 += -c
-COMMON_FILES=$(top_srcdir)/common/cpright.texi $(top_builddir)/common/setup.texi
+GENERATED_FILES = networkapp.texi driver.texi networktasks.texi testing.texi \
+ servers.texi decdriver.texi
-GENERATED_FILES=networkapp.texi driver.texi networktasks.texi testing.texi \
- servers.texi decdriver.texi
+COMMON_FILES = $(top_srcdir)/common/setup.texi $(top_srcdir)/common/cpright.texi
-FILES= networktasks.texi preface.texi
+FILES = networktasks.texi preface.texi
info_TEXINFOS = networking.texi
networking_TEXINFOS = $(FILES) $(COMMON_FILES) $(GENERATED_FILES)
@@ -33,39 +32,37 @@ if USE_HTML
html_project_DATA += networkflow.jpg networkflow.png PCIreg.jpg recvbd.jpg
endif
-networktasks.texi: networktasks.t
- $(BMENU) -p "Preface" \
+$(srcdir)/networktasks.texi: networktasks.t
+ $(BMENU2) -p "Preface" \
-u "Top" \
- -n "Networking Driver" $<
+ -n "Networking Driver" < $< > $@
-driver.texi: driver.t
- $(BMENU) -p "Network Task Structure and Data Flow" \
+$(srcdir)/driver.texi: driver.t
+ $(BMENU2) -p "Network Task Structure and Data Flow" \
-u "Top" \
- -n "Using Networking in an RTEMS Application" $<
+ -n "Using Networking in an RTEMS Application" < $< > $@
-networkapp.texi: networkapp.t
- $(BMENU) -p "Write the Driver Statistic-Printing Function" \
+$(srcdir)/networkapp.texi: networkapp.t
+ $(BMENU2) -p "Write the Driver Statistic-Printing Function" \
-u "Top" \
- -n "Testing the Driver" $<
+ -n "Testing the Driver" < $< > $@
-testing.texi: testing.t
- $(BMENU) -p "Time Synchronization Using NTP" \
+$(srcdir)/testing.texi: testing.t
+ $(BMENU2) -p "Time Synchronization Using NTP" \
-u "Top" \
- -n "Network Servers" $<
+ -n "Network Servers" < $< > $@
-servers.texi: servers.t
- $(BMENU) -p "Throughput" \
+$(srcdir)/servers.texi: servers.t
+ $(BMENU2) -p "Throughput" \
-u "Top" \
- -n "DEC 21140 Driver" $<
+ -n "DEC 21140 Driver" < $< > $@
-decdriver.texi: decdriver.t
- $(BMENU) -p "Using Hooks" \
+$(srcdir)/decdriver.texi: decdriver.t
+ $(BMENU2) -p "Using Hooks" \
-u "Top" \
- -n "Command and Variable Index" $<
+ -n "Command and Variable Index" < $< > $@
-PICTURE_FILES = \
-PCIreg.eps PCIreg.jpg \
-networkflow.eps networkflow.jpg networkflow.png \
-recvbd.eps recvbd.jpg
+PICTURE_FILES = PCIreg.eps PCIreg.jpg networkflow.eps networkflow.jpg \
+ networkflow.png recvbd.eps recvbd.jpg
EXTRA_DIST = *.t $(PICTURE_FILES)