summaryrefslogtreecommitdiffstats
path: root/doc/develenv/Makefile.am
diff options
context:
space:
mode:
authorJoel Sherrill <joel.sherrill@OARcorp.com>2003-02-18 16:16:12 +0000
committerJoel Sherrill <joel.sherrill@OARcorp.com>2003-02-18 16:16:12 +0000
commitaa4142936ed9a010b5982630f4116023e77b3b1d (patch)
tree0eef5694715b84f76f7ccb8c4a1dce6c744f8e70 /doc/develenv/Makefile.am
parent2003-02-15 Ralf Corsepius <corsepiu@faw.uni-ulm.de> (diff)
downloadrtems-aa4142936ed9a010b5982630f4116023e77b3b1d.tar.bz2
2003-02-18 Joel Sherrill <joel@OARcorp.com>
* Makefile.am, develenv.texi: Relect generating .texi from .t's. * direct.t, sample.t, utils.t: New files. * direct.texi, sample.texi, utils.texi: Removed. Now generated from corresponding .t files which are in the process of being updated. This commit is a anspshot of the update effort.
Diffstat (limited to 'doc/develenv/Makefile.am')
-rw-r--r--doc/develenv/Makefile.am19
1 files changed, 18 insertions, 1 deletions
diff --git a/doc/develenv/Makefile.am b/doc/develenv/Makefile.am
index 6e1e332681..c47f006b01 100644
--- a/doc/develenv/Makefile.am
+++ b/doc/develenv/Makefile.am
@@ -15,8 +15,25 @@ include $(top_srcdir)/main.am
FILES = compile.texi direct.texi intro.texi sample.texi utils.texi
+GENERATED_FILES = direct.texi sample.texi utils.texi
+
COMMON_FILES = $(top_srcdir)/common/setup.texi \
$(top_srcdir)/common/cpright.texi
info_TEXINFOS = develenv.texi
-develenv_TEXINFOS = $(FILES) $(COMMON_FILES)
+develenv_TEXINFOS = $(FILES) $(COMMON_FILES) $(GENERATED_FILES)
+
+$(srcdir)/direct.texi: direct.t
+ $(BMENU2) -p "Introduction" \
+ -u "Top" \
+ -n "Sample Applications" < $< > $@
+
+$(srcdir)/sample.texi: sample.t
+ $(BMENU2) -p "Directory Structure Test Suite Source Directory" \
+ -u "Top" \
+ -n "RTEMS Specific Utilities" < $< > $@
+
+$(srcdir)/utils.texi: utils.t
+ $(BMENU2) -p "Sample Applications Paranoia Floating Point Application" \
+ -u "Top" \
+ -n "Command and Variable Index" < $< > $@