summaryrefslogtreecommitdiffstats
path: root/doc/configure.ac
diff options
context:
space:
mode:
authorRalf Corsepius <ralf.corsepius@rtems.org>2003-08-07 05:17:27 +0000
committerRalf Corsepius <ralf.corsepius@rtems.org>2003-08-07 05:17:27 +0000
commit8e7cdc8b10ab915d1ffab70dfdcd8b3ea2088bac (patch)
tree1107187ec5cb624486c74d3c53ca5aeb32168de8 /doc/configure.ac
parentMerger from rtems-4-6-branch (diff)
downloadrtems-8e7cdc8b10ab915d1ffab70dfdcd8b3ea2088bac.tar.bz2
Merger from rtems-4-6-branch
Diffstat (limited to '')
-rw-r--r--doc/configure.ac18
1 files changed, 10 insertions, 8 deletions
diff --git a/doc/configure.ac b/doc/configure.ac
index bd8094eb78..213352fe65 100644
--- a/doc/configure.ac
+++ b/doc/configure.ac
@@ -5,7 +5,6 @@ AC_PREREQ(2.57)
AC_INIT([rtems-doc],[_RTEMS_VERSION],[rtems-bugs@OARcorp.com])
AC_CONFIG_SRCDIR([project.am])
RTEMS_TOP([..])
-AC_CONFIG_AUX_DIR([..])
AM_INIT_AUTOMAKE([no-define foreign 1.7.2])
AM_MAINTAINER_MODE
@@ -82,16 +81,19 @@ AM_CONDITIONAL(GS,test x"$GS" != x"")
AC_CHECK_PROGS(TEXI2DVI,texi2dvi)
AM_CONDITIONAL(TEXI2DVI,test x"$TEXI2DVI" != x"")
-if test "$enable_pdf" = "yes"; then
- AC_CHECK_PROGS(EPSTOPDF,epstopdf)
- AM_CONDITIONAL(EPSTOPDF,test x"$EPSTOPDF" != x"")
- AC_CHECK_PROGS(TEXI2PDF,texi2pdf)
- AM_CONDITIONAL(TEXI2PDF,test x"$TEXI2PDF" != x"")
-fi
+AC_CHECK_PROGS(EPSTOPDF,epstopdf)
+AM_CONDITIONAL(EPSTOPDF,
+ test "$enable_pdf" = "yes" \
+ && test x"$EPSTOPDF" != x"" )
+
+AC_CHECK_PROGS(TEXI2PDF,texi2pdf)
+AM_CONDITIONAL(TEXI2PDF,
+ test "$enable_pdf" = "yes" \
+ && test x"$TEXI2PDF" != x"")
AM_CONDITIONAL(USE_HTML,
- test "$enable_html" = "yes" \
+ test "$enable_html" = "yes" \
&& test x"PERL" != x"" )
AM_CONDITIONAL(USE_DVI,