summaryrefslogtreecommitdiffstats
path: root/doc/ada_user/Makefile.am
diff options
context:
space:
mode:
authorJoel Sherrill <joel.sherrill@OARcorp.com>2000-06-01 15:29:01 +0000
committerJoel Sherrill <joel.sherrill@OARcorp.com>2000-06-01 15:29:01 +0000
commitfc76a6aa19af9606f260993811ac0dee8ec4e886 (patch)
tree039d079cce65ec28746118f177fc9bea2e737b11 /doc/ada_user/Makefile.am
parentPatch from Ralf Corsepius <corsepiu@faw.uni-ulm.de>: (diff)
downloadrtems-fc76a6aa19af9606f260993811ac0dee8ec4e886.tar.bz2
Patch rtemsdoc-4.5.0-rc-8.diff from Ralf Corsepius <corsepiu@faw.uni-ulm.de>.
Ralf's comments follow: Changes: * Enhanced versioning: - Addition of automake's version.texi support - Replacement of rtemsdoc's former versioning support by automake's versioning support (Abandoning RTEMS-UPDATE-* etc.) - Abandoning setup.texi.in - Add EDITION to each documents Makefile.am - version.texi support in project.am - Addition of maintainer mode (currently only used to prevent incorrectly updating timestamps when users touch automake's version.texi timestamp files (stamp-vti)). * Fixing info dir support - Use texinfo's @dircategory and @direntry instead of infos *-DIR-ENTRY - $(infodir)/dir is now correctly set up * Avoid using temporary files - Pipe texts through REPLACE2 into BMENU2 instead of using temporary files. - Abandon using bmenu in favor of bmenu2 (bmenu could be removed now) * Prepare Makefile.ams for building in a separate buildtree - prefix files with $(srcdir) in Makefile.am for files which must be generated inside of the source tree Notes: * rtemsdoc can not yet be build in a separate source-tree, but we are very close to it. * You as the maintainer of this package now should always use --enable-maintainer-mode to configure rtemsdoc.
Diffstat (limited to '')
-rw-r--r--doc/ada_user/Makefile.am37
1 files changed, 20 insertions, 17 deletions
diff --git a/doc/ada_user/Makefile.am b/doc/ada_user/Makefile.am
index a1d23e721e..1249c3af26 100644
--- a/doc/ada_user/Makefile.am
+++ b/doc/ada_user/Makefile.am
@@ -6,25 +6,29 @@
# $Id$
#
-AUTOMAKE_OPTIONS = foreign
+AUTOMAKE_OPTIONS = foreign 1.4
-PROJECT=ada_user
+PROJECT = ada_user
+EDITION = 1
include $(top_srcdir)/project.am
-COMMON_FILES= $(top_srcdir)/common/cpright.texi \
- $(top_srcdir)/user/bsp.texi $(top_srcdir)/user/clock.texi \
- $(top_srcdir)/user/concepts.texi $(top_srcdir)/user/datatypes.texi \
- $(top_srcdir)/user/conf.texi $(top_srcdir)/user/dirstat.texi \
- $(top_srcdir)/user/dpmem.texi $(top_srcdir)/user/event.texi \
- $(top_srcdir)/user/fatal.texi $(top_srcdir)/user/glossary.texi $(top_srcdir)/user/init.texi \
- $(top_srcdir)/user/intr.texi $(top_srcdir)/user/io.texi $(top_srcdir)/user/mp.texi $(top_srcdir)/user/msg.texi \
- $(top_srcdir)/user/overview.texi $(top_srcdir)/user/part.texi $(top_srcdir)/user/preface.texi \
- $(top_srcdir)/user/region.texi $(top_srcdir)/user/rtmon.texi $(top_srcdir)/user/schedule.texi \
- $(top_srcdir)/user/sem.texi $(top_srcdir)/user/signal.texi $(top_srcdir)/user/task.texi \
- $(top_srcdir)/user/timer.texi $(top_srcdir)/user/userext.texi
-
-FILES= example.texi
+COMMON_FILES = $(top_srcdir)/user/bsp.texi $(top_srcdir)/user/clock.texi \
+ $(top_srcdir)/user/concepts.texi $(top_srcdir)/user/datatypes.texi \
+ $(top_srcdir)/user/conf.texi $(top_srcdir)/user/dirstat.texi \
+ $(top_srcdir)/user/dpmem.texi $(top_srcdir)/user/event.texi \
+ $(top_srcdir)/user/fatal.texi $(top_srcdir)/user/glossary.texi \
+ $(top_srcdir)/user/init.texi $(top_srcdir)/user/intr.texi \
+ $(top_srcdir)/user/io.texi $(top_srcdir)/user/mp.texi \
+ $(top_srcdir)/user/msg.texi $(top_srcdir)/user/overview.texi \
+ $(top_srcdir)/user/part.texi $(top_srcdir)/user/preface.texi \
+ $(top_srcdir)/user/region.texi $(top_srcdir)/user/rtmon.texi \
+ $(top_srcdir)/user/schedule.texi $(top_srcdir)/user/sem.texi \
+ $(top_srcdir)/user/signal.texi $(top_srcdir)/user/task.texi \
+ $(top_srcdir)/user/timer.texi $(top_srcdir)/user/userext.texi \
+ $(top_srcdir)/common/setup.texi $(top_srcdir)/common/cpright.texi
+
+FILES = example.texi
rtemspie.eps: $(top_srcdir)/user/rtemspie.eps
$(LN_S) $<
@@ -41,7 +45,7 @@ states.png: $(top_srcdir)/user/states.png
CLEANFILES += rtemsarc.png rtemspie.png states.png
info_TEXINFOS = ada_user.texi
-ada_user_TEXINFOS = $(FILES) $(COMMON_FILES) $(GENERATED_FILES)
+ada_user_TEXINFOS = $(FILES) $(COMMON_FILES) $(GENERATED_FILES)
if USE_HTML
html_project_DATA += rtemsarc.png rtemspie.png states.png
@@ -49,4 +53,3 @@ endif
$(PROJECT).dvi: rtemspie.eps states.eps
PDF_IMAGES = rtemspie.pdf states.pdf
-