summaryrefslogtreecommitdiffstats
path: root/doc/Makefile.am
diff options
context:
space:
mode:
authorJoel Sherrill <joel.sherrill@OARcorp.com>2002-01-30 20:05:56 +0000
committerJoel Sherrill <joel.sherrill@OARcorp.com>2002-01-30 20:05:56 +0000
commit279a6da241834505783c46f21b1842200e0e4c4f (patch)
tree5f48846738f28173eb333e9d7fec304170b342a0 /doc/Makefile.am
parentfixing branch (diff)
downloadrtems-279a6da241834505783c46f21b1842200e0e4c4f.tar.bz2
fixing branch
Diffstat (limited to 'doc/Makefile.am')
-rw-r--r--doc/Makefile.am30
1 files changed, 23 insertions, 7 deletions
diff --git a/doc/Makefile.am b/doc/Makefile.am
index 51a9b6f154..09ebca9708 100644
--- a/doc/Makefile.am
+++ b/doc/Makefile.am
@@ -1,9 +1,25 @@
-##
-## $Id$
-##
-## NOTE: This is just a stub.
-##
+#
+# $Id$
+#
-AUTOMAKE_OPTIONS = foreign 1.4
+AUTOMAKE_OPTIONS = foreign 1.5
+
+# NOTE: The order of the directories is essential.
+# + tools, common and images are shared across many documents
+
+SUBDIRS = tools common images FAQ started user bsp_howto porting develenv \
+ posix_users posix1003.1 filesystem itron3.0 networking ada_user \
+ started_ada rtems_gdb rgdb_specs new_chapters relnotes supplements \
+ gnu_docs src2html
+
+if USE_HTML
+html_DATA = index.html HELP.html
+endif
+
+AUTOMAKE_FILES = project.am main.am
+
+noinst_SCRIPTS = bootstrap
+
+EXTRA_DIST = $(AUTOMAKE_FILES) HELP.html \
+ $(noinst_SCRIPTS) rtems_header.html.in rtems_footer.html.in
-include $(top_srcdir)/automake/host.am