summaryrefslogtreecommitdiffstats
path: root/doc/Makefile.am
diff options
context:
space:
mode:
authorRalf Corsepius <ralf.corsepius@rtems.org>2002-12-08 09:04:43 +0000
committerRalf Corsepius <ralf.corsepius@rtems.org>2002-12-08 09:04:43 +0000
commit2106fc763f04645825d0e4a01d86bdf0d6a0ea09 (patch)
tree2e1f14e732c8e536eb58634c153eef614f535e4a /doc/Makefile.am
parent2002-12-07 Ralf Corsepius <corsepiu@faw.uni-ulm.de> (diff)
downloadrtems-2106fc763f04645825d0e4a01d86bdf0d6a0ea09.tar.bz2
2002-12-08 Ralf Corsepius <corsepiu@faw.uni-ulm.de>
* Makefile.am: Merge-in images/Makefile.am, common/Makefile.am. * images/Makefile.am: Remove. * common/Makefile.am: Remove. * configure.ac: Reflect changes above. * main.am: Append -I $(topsrc_dir) to AM_MAKEINFOFLAGS.
Diffstat (limited to '')
-rw-r--r--doc/Makefile.am15
1 files changed, 14 insertions, 1 deletions
diff --git a/doc/Makefile.am b/doc/Makefile.am
index 3e90933fba..cb50680bac 100644
--- a/doc/Makefile.am
+++ b/doc/Makefile.am
@@ -7,7 +7,7 @@ ACLOCAL_AMFLAGS = -I ../aclocal
# NOTE: The order of the directories is essential.
# + tools, common and images are shared across many documents
-SUBDIRS = tools common images FAQ started user bsp_howto porting develenv \
+SUBDIRS = tools FAQ started user bsp_howto porting develenv \
posix_users posix1003.1 filesystem itron3.0 networking ada_user \
started_ada rtems_gdb rgdb_specs new_chapters relnotes supplements \
gnu_docs src2html
@@ -21,3 +21,16 @@ AUTOMAKE_FILES = project.am main.am
EXTRA_DIST = $(AUTOMAKE_FILES) HELP.html \
rtems_header.html.in rtems_footer.html.in
+EXTRA_DIST += common/cpright.texi common/setup.texi common/timemac.texi \
+ common/timetbl.t common/treedef.tex common/wksheets.t common/timing.t
+
+html_imagesdir = $(htmldir)/images
+
+HTML_IMAGES = images/dir-arrow.gif images/dvi.gif images/missing-arrow.gif images/next-arrow.gif \
+ images/oaronly.jpg images/pdf.gif images/pdf1.gif images/prev-arrow.gif images/ps.gif images/up-arrow.gif
+
+if USE_HTML
+html_images_DATA = $(HTML_IMAGES)
+endif
+
+EXTRA_DIST += $(HTML_IMAGES)