summaryrefslogtreecommitdiffstats
path: root/doc/Makefile.am
diff options
context:
space:
mode:
authorJoel Sherrill <joel.sherrill@OARcorp.com>2000-06-10 19:41:09 +0000
committerJoel Sherrill <joel.sherrill@OARcorp.com>2000-06-10 19:41:09 +0000
commit110445cba5510f44c0fbd2ff13d7126459c188c6 (patch)
tree9a60f84af1b4e63d04d3af31f99066767ed241fa /doc/Makefile.am
parentRemoved old bmenu version. (diff)
downloadrtems-110445cba5510f44c0fbd2ff13d7126459c188c6.tar.bz2
Patch rtems-rc-4.5.0-21.diff from Ralf Corsepius <corsepiu@faw.uni-ulm.de>
which splits the current monolithic specs files into a sequence of subparts. These can be concatenated togather to make a the whole .spec file. This cleans up the maintenance problem of having "all languages" and a "C/C++ only" gccnewlib spec files. Plus it should make it easier to produce variants like the gdb-m68k-bdm which require special hackery. :) Ralf's comments: It addresses the way *.spec.in get composed inside of the source tree. Changes: * Each spec.in is broken into several files (*.add), one *.add file per sub-package. * Each Makefile.am composes spec.ins from the *.add files * Removal of redundant automake support files. * Default value for BuildRoot changed to /tmp/<spec-file-name> * %clean stage added to *specs Advantages (IMHO). * The *.add files are easier to adminstrate and more flexible in comparison to the former *.specs.ins. * gccnewlib_c_only.spec.in now is composed from the same sources as gccnewlib.spec.in (less errors) * If using the default BuildRoot --clean now deletes all files that were generated while building. Notes: * rtems.spec.in has not yet been adapted to the scheme used for the other *spec.ins * Except for cosmetical changes the internals of the *.spec files should not have changed. To Apply: cvs rm -f scripts/binutils/binutils.spec.in cvs rm -f scripts/gccnewlib/gccnewlib.spec.in cvs rm -f scripts/gccnewlib/gccnewlib_c_only.spec.in cvs rm -f scripts/gdb/gdb.spec.in cvs rm -f scripts/config.sub cvs rm -f scripts/config.guess cvs rm -f scripts/install-sh cvs rm -f scripts/mkinstalldirs cvs rm -f scripts/missing patch -p1 < rtems-rc-4.5.0-21.diff cvs add scripts/*/*.add cvs add scripts/*/README
Diffstat (limited to '')
-rw-r--r--doc/Makefile.am39
1 files changed, 9 insertions, 30 deletions
diff --git a/doc/Makefile.am b/doc/Makefile.am
index 30e42343cb..9184bdb776 100644
--- a/doc/Makefile.am
+++ b/doc/Makefile.am
@@ -6,41 +6,20 @@ AUTOMAKE_OPTIONS = foreign 1.4
# NOTE: The order of the directories is essential.
# + tools, common and images are shared across many documents
-SUBDIRS = \
-tools \
-common \
-images \
-FAQ \
-started \
-user \
-bsp_howto \
-porting \
-develenv \
-posix_users \
-posix1003.1 \
-filesystem \
-itron3.0 \
-networking \
-ada_user \
-started_ada \
-rtems_gdb \
-rgdb_specs \
-new_chapters \
-relnotes \
-supplements \
-gnu_docs \
-src2html
+
+SUBDIRS = tools common images FAQ started user bsp_howto porting develenv \
+ posix_users posix1003.1 filesystem itron3.0 networking ada_user \
+ started_ada rtems_gdb rgdb_specs new_chapters relnotes supplements \
+ gnu_docs src2html
if USE_HTML
-html_DATA = index.html HELP.html BAD.html
+html_DATA = index.html HELP.html
endif
AUTOMAKE_FILES = project.am
noinst_SCRIPTS = bootstrap
-EXTRA_DIST = \
-$(AUTOMAKE_FILES) \
-HELP.html BAD.html \
-texinfo/texinfo.tex \
-$(noinst_SCRIPTS)
+EXTRA_DIST = $(AUTOMAKE_FILES) HELP.html texinfo/texinfo.tex \
+ $(noinst_SCRIPTS) rtems_header.html.in rtems_footer.html.in
+