summaryrefslogtreecommitdiffstats
path: root/doc/FAQ/Makefile.am
diff options
context:
space:
mode:
authorJoel Sherrill <joel.sherrill@OARcorp.com>2000-06-01 15:29:01 +0000
committerJoel Sherrill <joel.sherrill@OARcorp.com>2000-06-01 15:29:01 +0000
commitfc76a6aa19af9606f260993811ac0dee8ec4e886 (patch)
tree039d079cce65ec28746118f177fc9bea2e737b11 /doc/FAQ/Makefile.am
parentPatch from Ralf Corsepius <corsepiu@faw.uni-ulm.de>: (diff)
downloadrtems-fc76a6aa19af9606f260993811ac0dee8ec4e886.tar.bz2
Patch rtemsdoc-4.5.0-rc-8.diff from Ralf Corsepius <corsepiu@faw.uni-ulm.de>.
Ralf's comments follow: Changes: * Enhanced versioning: - Addition of automake's version.texi support - Replacement of rtemsdoc's former versioning support by automake's versioning support (Abandoning RTEMS-UPDATE-* etc.) - Abandoning setup.texi.in - Add EDITION to each documents Makefile.am - version.texi support in project.am - Addition of maintainer mode (currently only used to prevent incorrectly updating timestamps when users touch automake's version.texi timestamp files (stamp-vti)). * Fixing info dir support - Use texinfo's @dircategory and @direntry instead of infos *-DIR-ENTRY - $(infodir)/dir is now correctly set up * Avoid using temporary files - Pipe texts through REPLACE2 into BMENU2 instead of using temporary files. - Abandon using bmenu in favor of bmenu2 (bmenu could be removed now) * Prepare Makefile.ams for building in a separate buildtree - prefix files with $(srcdir) in Makefile.am for files which must be generated inside of the source tree Notes: * rtemsdoc can not yet be build in a separate source-tree, but we are very close to it. * You as the maintainer of this package now should always use --enable-maintainer-mode to configure rtemsdoc.
Diffstat (limited to 'doc/FAQ/Makefile.am')
-rw-r--r--doc/FAQ/Makefile.am84
1 files changed, 42 insertions, 42 deletions
diff --git a/doc/FAQ/Makefile.am b/doc/FAQ/Makefile.am
index 876b034048..5200056258 100644
--- a/doc/FAQ/Makefile.am
+++ b/doc/FAQ/Makefile.am
@@ -6,81 +6,81 @@
# $Id$
#
-AUTOMAKE_OPTIONS = foreign
+AUTOMAKE_OPTIONS = foreign 1.4
-PROJECT=FAQ
+PROJECT = FAQ
+EDITION = 1
include $(top_srcdir)/project.am
-COMMON_FILES=$(top_srcdir)/common/cpright.texi $(top_builddir)/common/setup.texi
+GENERATED_FILES = basic.texi tools.texi concepts.texi build45.texi bsp.texi \
+ debug.texi freesw.texi embeddedinfo.texi hwdebugaids.texi projects.texi \
+ endoftime.texi
-GENERATED_FILES= \
- basic.texi tools.texi concepts.texi build45.texi bsp.texi debug.texi \
- freesw.texi embeddedinfo.texi hwdebugaids.texi projects.texi endoftime.texi
+COMMON_FILES = $(top_srcdir)/common/setup.texi $(top_srcdir)/common/cpright.texi
-FILES=
+FILES =
info_TEXINFOS = FAQ.texi
-FAQ_TEXINFOS = $(FILES) $(COMMON_FILES) $(GENERATED_FILES)
+FAQ_TEXINFOS = $(FILES) $(COMMON_FILES) $(GENERATED_FILES)
#
# Process Automatically Generated Files
#
-basic.texi: basic.t
- $(BMENU) -c -p "Top" \
+$(srcdir)/basic.texi: basic.t
+ $(BMENU2) -c -p "Top" \
-u "Top" \
- -n "" $<
+ -n "" < $< > $@
-tools.texi: tools.t
- $(BMENU) -c -p "Top" \
+$(srcdir)/tools.texi: tools.t
+ $(BMENU2) -c -p "Top" \
-u "Top" \
- -n "" $<
+ -n "" < $< > $@
-concepts.texi: concepts.t
- $(BMENU) -c -p "" \
+$(srcdir)/concepts.texi: concepts.t
+ $(BMENU2) -c -p "" \
-u "Top" \
- -n "" $<
+ -n "" < $< > $@
-build45.texi: build45.t
- $(BMENU) -c -p "" \
+$(srcdir)/build45.texi: build45.t
+ $(BMENU2) -c -p "" \
-u "Top" \
- -n "" $<
+ -n "" < $< > $@
-bsp.texi: bsp.t
- $(BMENU) -c -p "" \
+$(srcdir)/bsp.texi: bsp.t
+ $(BMENU2) -c -p "" \
-u "Top" \
- -n "" $<
+ -n "" < $< > $@
-debug.texi: debug.t
- $(BMENU) -c -p "" \
+$(srcdir)/debug.texi: debug.t
+ $(BMENU2) -c -p "" \
-u "Top" \
- -n "" $<
+ -n "" < $< > $@
-freesw.texi: freesw.t
- $(BMENU) -c -p "" \
+$(srcdir)/freesw.texi: freesw.t
+ $(BMENU2) -c -p "" \
-u "Top" \
- -n "" $<
+ -n "" < $< > $@
-embeddedinfo.texi: embeddedinfo.t
- $(BMENU) -c -p "" \
+$(srcdir)/embeddedinfo.texi: embeddedinfo.t
+ $(BMENU2) -c -p "" \
-u "Top" \
- -n "" $<
+ -n "" < $< > $@
-hwdebugaids.texi: hwdebugaids.t
- $(BMENU) -c -p "" \
+$(srcdir)/hwdebugaids.texi: hwdebugaids.t
+ $(BMENU2) -c -p "" \
-u "Top" \
- -n "" $<
+ -n "" < $< > $@
-projects.texi: projects.t
- $(BMENU) -c -p "" \
+$(srcdir)/projects.texi: projects.t
+ $(BMENU2) -c -p "" \
-u "Top" \
- -n "" $<
+ -n "" < $< > $@
-
-endoftime.texi: endoftime.t
- $(BMENU) -c -p "" \
+$(srcdir)/endoftime.texi: endoftime.t
+ $(BMENU2) -c -p "" \
-u "Top" \
- -n "" $<
+ -n "" < $< > $@
EXTRA_DIST = entry *.t