summaryrefslogtreecommitdiffstats
path: root/cpukit/wrapup/Makefile.am
diff options
context:
space:
mode:
authorSebastian Huber <sebastian.huber@embedded-brains.de>2018-10-05 20:12:40 +0200
committerSebastian Huber <sebastian.huber@embedded-brains.de>2018-10-10 07:57:01 +0200
commit637546a659cd71fba108bbdce4478e466d3b65bb (patch)
tree64fb164b85ccab12ebf419bfea27d3d9fe511b0e /cpukit/wrapup/Makefile.am
parentbuild: Merge libmisc/Makefile.am (diff)
downloadrtems-637546a659cd71fba108bbdce4478e466d3b65bb.tar.bz2
build: Merge score/cpu/*/Makefile.am
Diffstat (limited to 'cpukit/wrapup/Makefile.am')
-rw-r--r--cpukit/wrapup/Makefile.am53
1 files changed, 0 insertions, 53 deletions
diff --git a/cpukit/wrapup/Makefile.am b/cpukit/wrapup/Makefile.am
deleted file mode 100644
index 8286752fba..0000000000
--- a/cpukit/wrapup/Makefile.am
+++ /dev/null
@@ -1,53 +0,0 @@
-include $(top_srcdir)/automake/multilib.am
-include $(top_srcdir)/automake/compile.am
-
-## Setup the variant build subdirectory
-ARCH = o-optimize
-
-project_lib_LIBRARIES = librtemscpu.a
-
-$(PROJECT_LIB)/librtemscpu.a: librtemscpu.a
- $(INSTALL_DATA) $< $(PROJECT_LIB)/librtemscpu.a
-TMPINSTALL_FILES = $(PROJECT_LIB)/librtemscpu.a
-
-librtemscpu_a_SOURCES =
-
-TMP_LIBS =
-TMP_LIBS += ../score/cpu/@RTEMS_CPU@/libscorecpu.a
-TMP_LIBS += ../libcpukit.a
-
-librtemscpu.a: $(TMP_LIBS)
- $(AM_V_GEN)rm -f $@
- $(AM_V_GEN)$(MKDIR_P) $(ARCH)
- $(AM_V_GEN)rm -rf $(ARCH)/*.$(OBJEXT) $(ARCH)/*.rel
- $(AM_V_at)for f in $(TMP_LIBS); do \
- case $$f in \
- *.$(OBJEXT) | *.rel) \
- if test -f $(ARCH)/`basename $$f`; then \
- if cmp $$f $(ARCH)/`basename $$f`; then \
- true; \
- else \
- echo 1>&2 "ERROR -- `basename $$f` in multiple files"; \
- exit 1; \
- fi; \
- else \
- cp $$f $(ARCH)/; \
- chmod a-w $(ARCH)/`basename $$f`; \
- fi; \
- ;; \
- *.a) \
- cd $(ARCH); \
- $(AR) xv ../$$f > /dev/null || exit 1; \
- chmod a-w * ; \
- cd ..; \
- ;; \
- esac; \
- done
- $(AM_V_GEN)ls $(ARCH)/* > $@-list
- $(AM_V_AR)$(AR) rc $@ @$@-list
- $(AM_V_GEN)rm -f $@-list $(ARCH)/*.$(OBJEXT) $(ARCH)/*.rel
- $(AM_V_at)$(RANLIB) $@
-
-all-local: $(TMPINSTALL_FILES)
-
-include $(top_srcdir)/automake/local.am