summaryrefslogtreecommitdiffstats
path: root/cpukit/wrapup/Makefile.am
diff options
context:
space:
mode:
authorSebastian Huber <sebastian.huber@embedded-brains.de>2014-11-07 13:47:39 +0100
committerSebastian Huber <sebastian.huber@embedded-brains.de>2014-11-20 10:30:06 +0100
commit41c5f1b7795d95179d1b501fc93b27abd6c19d27 (patch)
tree688c479d01b3ae9f5c6de24bc2ebcbee2068afc8 /cpukit/wrapup/Makefile.am
parentAdd RTEMS port of Linux I2C user-space API (diff)
downloadrtems-41c5f1b7795d95179d1b501fc93b27abd6c19d27.tar.bz2
Add I2C driver framework
This I2C driver framework has some major differences compared to libi2c. * It is compatible to the Linux I2C user-space API. * It uses generic IMFS nodes and thus reduces the levels of indirection. * The drivers don't have to mess around with minor numbers to get their state information. * No arbitrary bus controller model is assumed. The main task of an I2C bus controller driver is to process I2C messages. How this is done is private to the driver. * Scatter/gather operations are supported (I2C_M_NOSTART).
Diffstat (limited to 'cpukit/wrapup/Makefile.am')
-rw-r--r--cpukit/wrapup/Makefile.am1
1 files changed, 1 insertions, 0 deletions
diff --git a/cpukit/wrapup/Makefile.am b/cpukit/wrapup/Makefile.am
index a3d1da29c2..58f17aced7 100644
--- a/cpukit/wrapup/Makefile.am
+++ b/cpukit/wrapup/Makefile.am
@@ -8,6 +8,7 @@ project_lib_LIBRARIES = librtemscpu.a
librtemscpu_a_SOURCES =
TMP_LIBS =
+TMP_LIBS += ../dev/libdev.a
TMP_LIBS += ../score/cpu/@RTEMS_CPU@/libscorecpu.a
TMP_LIBS += ../score/libscore.a
TMP_LIBS += ../sapi/libsapi.a