summaryrefslogtreecommitdiffstats
path: root/cpukit/telnetd/Makefile.am
diff options
context:
space:
mode:
authorJoel Sherrill <joel.sherrill@OARcorp.com>2001-08-09 22:06:51 +0000
committerJoel Sherrill <joel.sherrill@OARcorp.com>2001-08-09 22:06:51 +0000
commitbd520203a03ca023dcbc0c77a6af59c4dc4c3b9a (patch)
tree2b8ea98bc80ca168c3776ed17a49a061560db8b8 /cpukit/telnetd/Makefile.am
parent2001-08-09 Fernando-Ruiz Casas <correo@fernando-ruiz.com> (diff)
downloadrtems-bd520203a03ca023dcbc0c77a6af59c4dc4c3b9a.tar.bz2
2001-08-09 Fernando-Ruiz Casas <correo@fernando-ruiz.com>
* Makefile.am, configure.in, rtems_servers/Makefile.am, rtems_servers/telnetd.c, rtems_servers/telnetd.h, rtems_telnetd/Makefile.am, rtems_telnetd/README, rtems_telnetd/icmds.c, rtems_telnetd/pty.c, rtems_telnetd/pty.h, rtems_telnetd/telnetd.c, rtems_telnetd/telnetd.h, wrapup/Makefile.am: - pty and telnetd have a new subdir rtems_telnetd to avoid the side effect when ftpd change. - the tcp/ip stats have been implemented into icmds.c and started when telnetd daemon is started. * rtems_servers/telnetd.c, rtems_servers/telnetd.h: Removed. * rtems_telnetd: New directory. * rtems_telnetd/Makefile.am, rtems_telnetd/README, rtems_telnetd/icmds.c, rtems_telnetd/pty.c, rtems_telnetd/pty.h, rtems_telnetd/telnetd.c, rtems_telnetd/telnetd.h: New files.
Diffstat (limited to '')
-rw-r--r--cpukit/telnetd/Makefile.am44
1 files changed, 44 insertions, 0 deletions
diff --git a/cpukit/telnetd/Makefile.am b/cpukit/telnetd/Makefile.am
new file mode 100644
index 0000000000..a5d0480722
--- /dev/null
+++ b/cpukit/telnetd/Makefile.am
@@ -0,0 +1,44 @@
+##
+## $Id$
+##
+
+AUTOMAKE_OPTIONS = foreign 1.4
+
+include_rtemsdir = $(includedir)/rtems
+
+LIBNAME = libtelnetd-tmp
+LIB = $(ARCH)/$(LIBNAME).a
+
+C_FILES = pty.c telnetd.c icmds.c
+C_O_FILES = $(C_FILES:%.c=$(ARCH)/%.o)
+
+include_rtems_HEADERS = pty.h telnetd.h
+
+OBJS = $(C_O_FILES)
+
+include $(RTEMS_ROOT)/make/custom/@RTEMS_BSP@.cfg
+include $(top_srcdir)/../../../automake/compile.am
+include $(top_srcdir)/../../../automake/lib.am
+
+$(PROJECT_INCLUDE)/rtems:
+ @$(mkinstalldirs) $@
+$(PROJECT_INCLUDE)/rtems/%.h: %.h
+ $(INSTALL_DATA) $< $@
+
+#
+# (OPTIONAL) Add local stuff here using +=
+#
+
+$(LIB): $(OBJS)
+ $(make-library)
+
+PREINSTALL_FILES += $(PROJECT_INCLUDE)/rtems \
+ $(include_rtems_HEADERS:%=$(PROJECT_INCLUDE)/rtems/%)
+
+all-local: $(ARCH) $(PREINSTALL_FILES) $(OBJS) $(LIB)
+
+.PRECIOUS: $(LIB)
+
+EXTRA_DIST = README pty.c telnetd.c pty.h icmds.c telnetd.h
+
+include $(top_srcdir)/../../../automake/local.am