summaryrefslogtreecommitdiffstats
path: root/cpukit/telnetd/Makefile.am
diff options
context:
space:
mode:
authorRalf Corsepius <ralf.corsepius@rtems.org>2003-07-25 06:15:38 +0000
committerRalf Corsepius <ralf.corsepius@rtems.org>2003-07-25 06:15:38 +0000
commit4078e82ae544f8eec4fcfa05aeb1bf38e3c40099 (patch)
tree6a0bb0d4328f968ebb772749af25426d39a8556a /cpukit/telnetd/Makefile.am
parent2003-07-24 Jennifer Averett <jennifer.averett@OARcorp.com> (diff)
downloadrtems-4078e82ae544f8eec4fcfa05aeb1bf38e3c40099.tar.bz2
2003-07-25 Ralf Corsepius <corsepiu@faw.uni-ulm.de>
* configure.ac: Remove (Merged into ../configure.ac). * .cvsignore, Makefile.am, pppd/Makefile.am, rtems_servers/Makefile.am, rtems_telnetd/Makefile.am, rtems_webserver/Makefile.am, wrapup/Makefile.am: Reflect having merged configure.ac into ../configure.ac
Diffstat (limited to '')
-rw-r--r--cpukit/telnetd/Makefile.am13
1 files changed, 8 insertions, 5 deletions
diff --git a/cpukit/telnetd/Makefile.am b/cpukit/telnetd/Makefile.am
index d03d4272d5..26d5b24071 100644
--- a/cpukit/telnetd/Makefile.am
+++ b/cpukit/telnetd/Makefile.am
@@ -2,7 +2,6 @@
## $Id$
##
-include_rtemsdir = $(includedir)/rtems
LIBNAME = libtelnetd-tmp
LIB = $(ARCH)/$(LIBNAME).a
@@ -10,10 +9,9 @@ LIB = $(ARCH)/$(LIBNAME).a
C_FILES = pty.c telnetd.c icmds.c
OBJS = $(C_FILES:%.c=$(ARCH)/%.$(OBJEXT))
-include_rtems_HEADERS = pty.h telnetd.h
-include $(top_srcdir)/../../../automake/compile.am
-include $(top_srcdir)/../../../automake/lib.am
+include $(top_srcdir)/../../automake/compile.am
+include $(top_srcdir)/../../automake/lib.am
$(PROJECT_INCLUDE)/rtems:
@$(mkinstalldirs) $@
@@ -24,6 +22,10 @@ $(PROJECT_INCLUDE)/rtems/%.h: %.h
# (OPTIONAL) Add local stuff here using +=
#
+if HAS_NETWORKING
+include_rtemsdir = $(includedir)/rtems
+include_rtems_HEADERS = pty.h telnetd.h
+
$(LIB): $(OBJS)
$(make-library)
@@ -31,9 +33,10 @@ PREINSTALL_FILES = $(PROJECT_INCLUDE)/rtems \
$(include_rtems_HEADERS:%=$(PROJECT_INCLUDE)/rtems/%)
all-local: $(ARCH) $(PREINSTALL_FILES) $(OBJS) $(LIB)
+endif
.PRECIOUS: $(LIB)
EXTRA_DIST = README pty.c telnetd.c pty.h icmds.c telnetd.h
-include $(top_srcdir)/../../../automake/local.am
+include $(top_srcdir)/../../automake/local.am